Date   
Re: Pi 3b to 3b+?

Art - KC7SDA
 

Ok, so that worked, my wifi is back now....

HOWEVER... new(ish) problem: the udrc isn't recognized as a sound card, I'm going to play around with it for a bit... i think that the driver might have gotten uninstalled or left behind during the upgrade.

for the record here is the output from running ./sysver.sh:

----- /proc/version
Linux version 4.14.62-v7+ (dc4@dc4-XPS13-9333) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611)) #1134 SMP Tue Aug 14 17:10:10 BST 2018
----- /etc/*version
9.4
----- /etc/*release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
----- lsb_release
No LSB modules are available.
Distributor ID:    Raspbian
Description:    Raspbian GNU/Linux 9.4 (stretch)
Release:    9.4
Codename:    stretch
---- systemd
   Static hostname: KC7SDA
         Icon name: computer
        Machine ID: (you guys don't need to see that)
           Boot ID: (you guys don't need to see that)
  Operating System: Raspbian GNU/Linux 9 (stretch)
            Kernel: Linux 4.14.62-v7+
      Architecture: arm
----- direwolf
 ver: Dire Wolf version 1.4

Re: Pi 3b to 3b+?

Art - KC7SDA
 

this is my orginal install I did a long time ago, I've been patching and updating it as I'm only one of a small few in my area really knowlegable in linux and have the time to go searching for answers and work-arounds for issues... I'm also developing a script for my group that updates and patches any issues we find or crop up and allows the members to build the FLDIGI suite from the source whenever a new one comes out.

Re: Pi 3b to 3b+?

Art - KC7SDA
 

I'll give those a try, i figured i had to increment the distro at some point but usually my xubuntu rig would do it for me... maybe future feature for compass?

Re: Pi 3b to 3b+?

Annaliese McDermond
 

You are on the wrong distro on both Compass and Rasbian. These are very rough instructions, but should work okay.

1) In /etc/apt/sources.list.d/raspi.list, change the word “jessie” to “stretch” wherever you see it.
2) In /etc/apt/sources.list, change the word “jessie” to “stretch” wherever you see it.
3) In /etc/apt/sources.list.d/compass.list change the word “alder” to “cedar”
4) Remove the file /etc/apt/preferences.d/compass
5) Execute the command “apt-get update”
6) Execute the command “apt-get dist-upgrade”

This should update your older distro to the newest Stretch based image that will have the proper firmware to boot a Raspberry Pi 3B+. Note that I have *not* tested this and that this procedure is from memory.

--
Annaliese McDermond (NH6Z)
Xenotropic Systems
mcdermj@...

Re: Pi 3b to 3b+?

f6bvp
 

Did you download and install Compas Linux ?
It includes now an automatic update of UDRC driver that works great with Direwolf after apt-get upgrade RPi-update that are now accepted and doing fine.

73 de Bernard f6bvp

Envoyé de mon iPhone

Le 19 août 2018 à 19:32, Art - KC7SDA <nouse4anick@...> a écrit :

well i confirmed that its not a defective pi....just did a new image of raspbian and it works.... so I'll do a bit more research

Re: Pi 3b to 3b+?

Art - KC7SDA
 

well i confirmed that its not a defective pi....just did a new image of raspbian and it works.... so I'll do a bit more research

Re: Pi 3b to 3b+?

Art - KC7SDA
 

ok, so I did a bit of searching and got the following info as the upgrade/dist-upgrade and rpi-update didn't give me anything:
- uname -a gave me kernal version 4.9.80-v7+  #1 SMP Thu Mar 29 09:24:44 PDT 2018 armv7l GNU/Linux
- lsb_release - a gave me Raspbian release 8.0 codename jessie


So, my guess is that some how the driver just isn't loading or erroring out, I'm going to look at the boot logs to see whats going on here in a minute but I doubt that will give me anything useful right now

73
Art

Re: Pi 3b to 3b+?

 

So has anyone gotten a 3b+ and tried plugging in their sd card from their 3b and gotten the wifi to work? I'm looking through some of the boards to find a solution, one was to use rpi-update (which doesn't work in compass), I've run update/upgrade several times, tried installing firmware-brcm80211 (which is the latest version).

any other suggestions? Has anyone tried a fresh install with a 3b+?
From a Mar 17, 2018 posting to the wetnet list:


- NOTE #1: If you're going to use a Rpi 3B+, your version of
Raspbian has to be newer than 2018-03-13 or it won't boot (older
versions will see 8 flashes at the rainbow screen and stop there)
--

So, put the SD card back in your previous Raspberry Pi (assuming it's
running Stretch and it has Internet access), and do:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo rpi-update
sudo /sbin/shutdown -r now

Make sure things come back up ok and if they do, again, move the SD
card over to the 3B+ and hopefully it will boot up A-OK.

--David
KI6ZHD

Re: Pi 3b to 3b+?

Art - KC7SDA
 

I thought I had updated a few weeks ago all the way but it still doesn't work, maybe I'm missing something? loading of some driver or a reinstall of the wireless driver?

I might just do a new image for the group up here, I believe most of my fixes in my scripts will still work, I'll give it a week and then try it.... no big deal that it doesn't work right now.

73
Art

Re: Pi 3b to 3b+?

 

Check the email threads about the time the 3b+ came out. You have to
update all the way on the 3b before it will work on the 3b+. Best
just to start with a new image - IMHO.

On Sat, Aug 18, 2018 at 1:29 PM Art - KC7SDA <@nouse4anick> wrote:

So has anyone gotten a 3b+ and tried plugging in their sd card from their 3b and gotten the wifi to work? I'm looking through some of the boards to find a solution, one was to use rpi-update (which doesn't work in compass), I've run update/upgrade several times, tried installing firmware-brcm80211 (which is the latest version).

any other suggestions? Has anyone tried a fresh install with a 3b+?

Right now everything else works on the pi (the UDRC, the usb ports, and the LAN port), bluetooth works. I'd like to get the wifi working w/o having to do a reinstall as a lot of people here in whatcom county have UDRC setups and if they want to do an upgrade they would probably like a (more or less) plug-n-play solution than to do a complete reinstall.

73
Art



Pi 3b to 3b+?

Art - KC7SDA
 

So has anyone gotten a 3b+ and tried plugging in their sd card from their 3b and gotten the wifi to work? I'm looking through some of the boards to find  a solution, one was to use rpi-update (which doesn't work in compass), I've run update/upgrade several times, tried installing firmware-brcm80211 (which is the latest version).

any other suggestions? Has anyone tried a fresh install with a 3b+?

Right now everything else works on the pi (the UDRC, the usb ports, and the LAN port), bluetooth works. I'd like to get the wifi working w/o having to do a reinstall as a lot of people here in whatcom county have UDRC setups and if they want to do an upgrade they would probably like a (more or less) plug-n-play solution than to do a complete reinstall.

73
Art

 

Re: UDRC II DR-1X firmware 1.00b #12vsupply #barrelconnector #udrc-ii

El Erby
 

Howdy John,

I guess we'll be doing D-Star and analog.

El.

Re: UDRC II DR-1X firmware 1.00b #12vsupply #barrelconnector #udrc-ii

VE3MIC
 

Hi Johnny. Not at all. I've been running v1.00n for some time -so no issues there. And there is an advantage in running the v1.1x firmware. It permits C4FM(Fusion) as well as D-STAR, and analogue(regular) FM. I had forgot to mention that both firmware forks/paths are available from the Yaesu site. Just navigate from the main page to 'Digital', then scroll to the right over to DR-1x. Click on the 'Files' tab.
73 de Mike




On Tue, Aug 14, 2018 at 8:16 AM, Johnny
<w5pfr@...> wrote:
With this upgrade, would you loose Dstar operation?



On Aug 13, 2018, at 10:56 PM, VE3MIC via Groups.Io <ve3mic@...> wrote:

DR-1x firmware has 2 upgrade "paths". In short, you can only D.I.Y..update firmware for the same path. v1,1x can be updated to newer v1.1x versions, and v1.0x versions can be updated to newer v1.0x versions.. For your V1.00b DR-1x, the latest is v1.00n.

For a period of time, those wishing to update their v1.0x DR-1x  to v1.1x  could send it to Yaesu Service in California. I'm not sure if they are still performing these upgrades or if you now have to "Trade Up". I'd suggest contacting Yaesu Service directly if this is what you'd like to do

From the DR-1x Yaesu web site:

Please use the appropriated new firmware to provide the listed functions: V1.00n Replaces any firmware versions, other than V1.10D and V1.00f. Provides Wide-FM operation 


73 de Mike
On Monday, August 13, 2018, 3:02:19 p.m. EDT, El Erby <ELErby@...> wrote:


Can I update the firmware to 1.10 from 1.00b?  Where can I get the firmware?

Thanks,

K4DJL

Re: UDRC II DR-1X firmware 1.00b #12vsupply #barrelconnector #udrc-ii

 

What are you planning to run.  

D-STAR Only
D-STAR/Analog
D-STAR/Fusion
D-STAR/Fusion/Analog

The first 2 and possibly the 3rd can be supported under firmware 1.00, the 4th requires 1.10  

You can do 1.00 upgrades yourself.  Going to 1.10 has required a trip to Yaesu but be careful with that.  Once you 1.10 upgrades can be performed within the series.

https://nw-digital-radio.groups.io/g/udrc/wiki/UDRC%E2%84%A2-Setup-for-the-Yaesu-DR-1X-Repeater  -- we have done no testing of other firmware and not sure if a repeater was upgraded at this point, if the firmware would defeat D-STAR (as has been done for the DR-2X).





On Tue, Aug 14, 2018 at 2:23 PM, El Erby <ELErby@...> wrote:
Johnny,

I hope it does not loose Dstar.

El




--


John D. Hays
Edmonds, WA
K7VE

   

Re: UDRC II DR-1X firmware 1.00b #12vsupply #barrelconnector #udrc-ii

El Erby
 

Johnny,

I hope it does not loose Dstar.

El

Re: UDRC II DR-1X firmware 1.00b #12vsupply #barrelconnector #udrc-ii

El Erby
 

Mike,

Thank you for your response. I will give 1.00n firmware a try.

El

Re: UDRC II DR-1X firmware 1.00b #12vsupply #barrelconnector #udrc-ii

Johnny
 

With this upgrade, would you loose Dstar operation?



On Aug 13, 2018, at 10:56 PM, VE3MIC via Groups.Io <ve3mic@...> wrote:

DR-1x firmware has 2 upgrade "paths". In short, you can only D.I.Y..update firmware for the same path. v1,1x can be updated to newer v1.1x versions, and v1.0x versions can be updated to newer v1.0x versions.. For your V1.00b DR-1x, the latest is v1.00n.

For a period of time, those wishing to update their v1.0x DR-1x  to v1.1x  could send it to Yaesu Service in California. I'm not sure if they are still performing these upgrades or if you now have to "Trade Up". I'd suggest contacting Yaesu Service directly if this is what you'd like to do

From the DR-1x Yaesu web site:

Please use the appropriated new firmware to provide the listed functions: V1.00n Replaces any firmware versions, other than V1.10D and V1.00f. Provides Wide-FM operation 


73 de Mike
On Monday, August 13, 2018, 3:02:19 p.m. EDT, El Erby <ELErby@...> wrote:


Can I update the firmware to 1.10 from 1.00b?  Where can I get the firmware?

Thanks,

K4DJL

Re: UDRC II DR-1X firmware 1.00b #12vsupply #barrelconnector #udrc-ii

VE3MIC
 

DR-1x firmware has 2 upgrade "paths". In short, you can only D.I.Y..update firmware for the same path. v1,1x can be updated to newer v1.1x versions, and v1.0x versions can be updated to newer v1.0x versions.. For your V1.00b DR-1x, the latest is v1.00n.

For a period of time, those wishing to update their v1.0x DR-1x  to v1.1x  could send it to Yaesu Service in California. I'm not sure if they are still performing these upgrades or if you now have to "Trade Up". I'd suggest contacting Yaesu Service directly if this is what you'd like to do

From the DR-1x Yaesu web site:

Please use the appropriated new firmware to provide the listed functions: V1.00n Replaces any firmware versions, other than V1.10D and V1.00f. Provides Wide-FM operation 


73 de Mike

On Monday, August 13, 2018, 3:02:19 p.m. EDT, El Erby <ELErby@...> wrote:


Can I update the firmware to 1.10 from 1.00b?  Where can I get the firmware?

Thanks,

K4DJL

UDRC II DR-1X firmware 1.00b #12vsupply #barrelconnector #udrc-ii

El Erby
 

Can I update the firmware to 1.10 from 1.00b?  Where can I get the firmware?

Thanks,

K4DJL

Re: UDRC II as DV Adaptor for DSTAR on a IC 7000 to transmite/receive DSTAR in HF #hf #udrc-ii

 

Add a ThumbDV and find a good software solution, then yes.  There is not a simple recipe for it, but with some trial and error and work you could put out a signal HF.

This doesn't directly answer your question, but part of the presentation goes into what is required to generate and receive digital voice at a block level.

On Thu, Aug 9, 2018 at 5:04 PM, Lardizabal David D. via Groups.Io <davidlardizabal@...> wrote:

[Edited Message Follows]

I have a IC 7000 and was wondering if I can use my UDRC II with RPi 3+  to be able to use the transceiver as HF DSTAR.  I have looked around but could not find anything.  Is it possible ?  

Thanks

David Lardizabal
HQ2DDL




--


John D. Hays
Edmonds, WA
K7VE