Date   
Re: DRAWS FT817 no TX audio

William McKeehan
 

I've found that I need to run the `setalsa-ft817.sh` script that was
included in the ~/bin directory, after that, I opened the DRAWS
Manager and changed the Input from Receiver Signal Source to "DISC
(pin4)" to get my 817 to work as expected with the hat. YMMV

On Thu, Jul 18, 2019 at 9:17 PM Ken Myers <ken.vk4gc@...> wrote:

Hi. Im have set up my DRAWS hat/FT817 according to "temporarily Offline" youtube video.

Install good
WSJT-X good
CAT good\ - PTT band change etc.
RX good - waterfall/decode etc great.
I set my WSJT-X audio to in/out toplughwCARD=udrc.DEV=0
Seems my only problem is audio from HAT to FT817 as while rig goes to TX, no audio drive.
Radio is all OK as I use it for Win/FT8 SSB etc.

I do not know where to look for audio output drive adjust on the Pi/HAT/WSJT-X steup

I am new to all this and learning.

Any help would be gratefully received.

Ken VK4GC
--
William
KI4HDU

Re: No WSJT-X transmission with FT-891 #ft-891 #draws #ft-8 #wsjtx

AG6RS@...
 

Matt,

Also make sure your width is set to 3000Hz
I notice on your radio it says LAP on the screen, upper left
Do you have an amp connected?
Maybe try the radio without a tuner or amp connected.

Tim / AG6RS

Re: Config check now not acting right #earlyadopter #beta13

K4SPB
 

Is that written somewhere? I recall reading an April thread about beta 10 that said otherwise so what should I reference to keep up?

Re: No WSJT-X transmission with FT-891 #ft-891 #draws #ft-8 #wsjtx

Matt N7ROO
 

Forgot to include my DRAWS manager screenshot!

image.png
Cheers,
Matt  - N7ROO


On Fri, Jul 19, 2019 at 9:08 PM Matt N7ROO via Groups.Io <n7roo=swift-x.com@groups.io> wrote:
Thanks for the response Tim.

I tried resetting my radio and also reflashed the DRAWS image. I've confirmed that I have the same menu settings as you, and that I'm using the left channel.

I've included a screenshot of the DRAWS Manager settings and have attempted sending both prior to and after configuration. I've also confirmed that Direwolf is not running.

image.png

My FT-891 PTT is still triggered but the power output never changes from zero while transmitting. I've also confirmed that I've not been heard on PSKReporter.

image.png

I've tried both 6 pin cables, in case one was defective, and both 6 pin ports on the DRAWS hat. The only thing I've yet to try is to swap out the USB cable.

Following that I'm all out of ideas.

Cheers,
Matt  - N7ROO


On Mon, Jul 8, 2019 at 8:30 PM Tim Sperry via Groups.Io <tsperry=verizon.net@groups.io> wrote:
Matt,
You may want to reset the radio.
I have done that in the past when problems arise.
I use the included menu settings after I reset the radio.
I am using the left audio channel.
Have you checked the draws manager and make sure AF (pin5) for your channel.
Also make sure Direwolf is not running 
cd
cd bin
sudo su
./ax25-stop

Tim / AG6RS

Re: No WSJT-X transmission with FT-891 #ft-891 #draws #ft-8 #wsjtx

Matt N7ROO
 

Thanks for the response Tim.

I tried resetting my radio and also reflashed the DRAWS image. I've confirmed that I have the same menu settings as you, and that I'm using the left channel.

I've included a screenshot of the DRAWS Manager settings and have attempted sending both prior to and after configuration. I've also confirmed that Direwolf is not running.

image.png

My FT-891 PTT is still triggered but the power output never changes from zero while transmitting. I've also confirmed that I've not been heard on PSKReporter.

image.png

I've tried both 6 pin cables, in case one was defective, and both 6 pin ports on the DRAWS hat. The only thing I've yet to try is to swap out the USB cable.

Following that I'm all out of ideas.

Cheers,
Matt  - N7ROO


On Mon, Jul 8, 2019 at 8:30 PM Tim Sperry via Groups.Io <tsperry=verizon.net@groups.io> wrote:
Matt,
You may want to reset the radio.
I have done that in the past when problems arise.
I use the included menu settings after I reset the radio.
I am using the left audio channel.
Have you checked the draws manager and make sure AF (pin5) for your channel.
Also make sure Direwolf is not running 
cd
cd bin
sudo su
./ax25-stop

Tim / AG6RS

Re: DRAWS FT817 no TX audio

LA9KOA - Karl
 

What is the mode of your 817 while TX?
I think it should be "DIG", otherwise it might not use sound input from the data port on back.

You can set this up from WSJT-X by choosing USB-D (can't remember exact description now) 
Choosing USB for mode could make the radio take sound input from mic and not from data port.

Re: DRAWS FT817 no TX audio

Richard Waller <rewaller@...>
 

Ken, did you look at Draws manager? That has output adjustments . Also the power slider on the right of the wsjt-x screen can be adjusted. Rick. Ka4ohm 


On Jul 18, 2019, at 7:34 PM, Ken Myers <ken.vk4gc@...> wrote:

Hi.  Im have set up my DRAWS hat/FT817 according to "temporarily Offline" youtube video.

Install good
WSJT-X good
CAT good\ - PTT band change etc.
RX good - waterfall/decode etc great.
I set my WSJT-X audio to in/out toplughwCARD=udrc.DEV=0
Seems my only problem is audio from HAT to FT817 as while rig goes to TX, no audio drive.
Radio is all OK as I use it for Win/FT8 SSB etc.

I do not know where to look for audio output drive adjust on the Pi/HAT/WSJT-X steup

I am new to all this and learning.

Any help would be gratefully received.

Ken VK4GC

Re: DRAWS FT817 no TX audio

 

Did you try DRAWS ™ Manager?


You may want to also do a factory reset on the radio. 

On Thu, Jul 18, 2019, 18:17 Ken Myers <ken.vk4gc@...> wrote:
Hi.  Im have set up my DRAWS hat/FT817 according to "temporarily Offline" youtube video.

Install good
WSJT-X good
CAT good\ - PTT band change etc.
RX good - waterfall/decode etc great.
I set my WSJT-X audio to in/out toplughwCARD=udrc.DEV=0
Seems my only problem is audio from HAT to FT817 as while rig goes to TX, no audio drive.
Radio is all OK as I use it for Win/FT8 SSB etc.

I do not know where to look for audio output drive adjust on the Pi/HAT/WSJT-X steup

I am new to all this and learning.

Any help would be gratefully received.

Ken VK4GC

DRAWS FT817 no TX audio

Ken Myers
 

Hi.  Im have set up my DRAWS hat/FT817 according to "temporarily Offline" youtube video.

Install good
WSJT-X good
CAT good\ - PTT band change etc.
RX good - waterfall/decode etc great.
I set my WSJT-X audio to in/out toplughwCARD=udrc.DEV=0
Seems my only problem is audio from HAT to FT817 as while rig goes to TX, no audio drive.
Radio is all OK as I use it for Win/FT8 SSB etc.

I do not know where to look for audio output drive adjust on the Pi/HAT/WSJT-X steup

I am new to all this and learning.

Any help would be gratefully received.

Ken VK4GC

Re: Config check now not acting right #earlyadopter #beta13

 

Doing an upgrade is not recommended for that beta image.

On Thu, Jul 18, 2019 at 4:04 PM K4SPB <k4spblife@...> wrote:
Also ran these checks:

pi@SpoobyDRAWS:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
pi@SpoobyDRAWS:~ $ chk_conflict.sh
 
Check udrc driver conflict for Kernel release: 4.14.98-v7+
 
=== Loaded module check
 
=== Sound card check
udrc driver not loaded.
pi@SpoobyDRAWS:~ $ chk_bootcfg.sh
 
Verify IF dtoverlay= is set properly
  dtoverlay currently set to: dtoverlay=draws,alsaname=udrc
  dtoverlay for DRAWS OK
 
Verify IF dtparam=audio is set properly
  Last line in /boot/config.txt OK
 



--
John D. Hays
Kingston, WA
K7VE

 

Re: Config check now not acting right #earlyadopter #beta13

K4SPB
 

Also ran these checks:

pi@SpoobyDRAWS:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
pi@SpoobyDRAWS:~ $ chk_conflict.sh
 
Check udrc driver conflict for Kernel release: 4.14.98-v7+
 
=== Loaded module check
 
=== Sound card check
udrc driver not loaded.
pi@SpoobyDRAWS:~ $ chk_bootcfg.sh
 
Verify IF dtoverlay= is set properly
  dtoverlay currently set to: dtoverlay=draws,alsaname=udrc
  dtoverlay for DRAWS OK
 
Verify IF dtparam=audio is set properly
  Last line in /boot/config.txt OK
 

Config check now not acting right #earlyadopter #beta13

K4SPB
 

I started with a fresh write of beta 13 the other day that I configured and then check without issue. Only think I've done since is update and upgrade which ran into a kernel upgrade issue I've seen repeatedly and ran KM4ACK's auto hotspot script. Now outputs of sndcard.sh, alsa-show.sh, and gpsmon are all giving negative information.
My most recent config checks: followed by the outputs of gpsmon and cgps

pi@SpoobyDRAWS:~ $ cd ~/n7nix/bin
pi@SpoobyDRAWS:~/n7nix/bin $ ./piver.sh
 Pi 3 Model B+ Mfg by Sony UK
 Has WiFi
pi@SpoobyDRAWS:~/n7nix/bin $ ./udrcver.sh
Found a DRAWS
 
     HAT ID EEPROM
Name:        hat
Product:     Digital Radio Amateur Work Station
Product ID:  0x0004
Product ver: 0x0405
UUID:        3036072f-20a8-441c-9901-4e8abec0fab4
Vendor:      NW Digital Radio
pi@SpoobyDRAWS:~/n7nix/bin $ cd
pi@SpoobyDRAWS:~ $ cd ~/bin
pi@SpoobyDRAWS:~/bin $ ./sndcard.sh
No udrc sound card found.
pi@SpoobyDRAWS:~/bin $ ls
alsa-show.sh     crontab.txt       pluweb-sysd.sh       setalsa-tmv71a.sh
ap-start.sh      dstar-stop.sh     prog_refresh.sh      setalsa-udrc-alinco.sh
ap-status.sh     gatewaylist.sh    radiopwr.sh          setalsa-udrc-din6.sh
ap-stop.sh       hwtest.sh         rmslist.sh           set-time.sh
ax25-start       iptable-check.sh  rmsverlist.sh        showudrc.sh
ax25-status      iptable-flush.sh  setalsa-default.sh   sndcard.sh
ax25-stop        iptable-up.sh     setalsa-dr1x.sh      sysver.sh
chk_bootcfg.sh   manager-sysd.sh   setalsa-ft817.sh     udrcver.sh
chk_conflict.sh  mgr-stop.sh       setalsa-ic7000.sh
chk_perm.sh      piver.sh          setalsa-not-dr1x.sh
pi@SpoobyDRAWS:~/bin $ alsa-show.sh
 ===== ALSA Controls for Radio Transmit =====
Invalid card number.
Invalid card number.
Invalid card number.
LO Driver Gain  L: R:
Invalid card number.
Invalid card number.
Invalid card number.
PCM         L: R:
Invalid card number.
 
 ===== ALSA Controls for Radio Receive =====
Invalid card number.
Invalid card number.
Invalid card number.
ADC Level L: R:
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
Invalid card number.
IN1 L:[] R:[]
IN2 L:[] R:[]
CM L:[] R:[]
pi@SpoobyDRAWS:~/bin $ cd
pi@SpoobyDRAWS:~ $ gpsmon
pi@SpoobyDRAWS:~ $ cgps
cgps: caught signal 2
pi@SpoobyDRAWS:~ $ sudo nano /etc/default/gpsd
pi@SpoobyDRAWS:~ $ sudo systemctl enable gpsd && sudo systemctl restart gpsd
Synchronizing state of gpsd.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable gpsd
pi@SpoobyDRAWS:~ $ 
pi@SpoobyDRAWS:~ $ 
pi@SpoobyDRAWS:~ $ sudo systemctl status gpsd
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: ena
   Active: active (running) since Fri 2019-07-12 11:31:02 UTC; 26s ago
  Process: 2246 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (
 Main PID: 2247 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─2247 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0
 
Jul 12 11:31:02 SpoobyDRAWS systemd[1]: Starting GPS (Global Positioning System)
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/tty
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open o
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: initial GPS device /dev/ttyS
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/pps
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open o
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: initial GPS device /dev/pps0
Jul 12 11:31:02 SpoobyDRAWS systemd[1]: Started GPS (Global Positioning System) 
lines 1-16/16 (END)
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled
   Active: active (running) since Fri 2019-07-12 11:31:02 UTC; 26s ago
  Process: 2246 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (code
 Main PID: 2247 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─2247 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0
 
Jul 12 11:31:02 SpoobyDRAWS systemd[1]: Starting GPS (Global Positioning System) Dae
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/ttySC0 
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open of /d
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: initial GPS device /dev/ttySC0 o
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/pps0 fa
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open of /d
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: initial GPS device /dev/pps0 ope
Jul 12 11:31:02 SpoobyDRAWS systemd[1]: Started GPS (Global Positioning System) Daem
~
~
~
~
~
~
~
lines 1-16/16 (END)
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-07-12 11:31:02 UTC; 26s ago
  Process: 2246 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (code=exi
 Main PID: 2247 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─2247 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0
 
Jul 12 11:31:02 SpoobyDRAWS systemd[1]: Starting GPS (Global Positioning System) Daemon.
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/ttySC0 fail
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open of /dev/t
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: initial GPS device /dev/ttySC0 open 
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/pps0 failed
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open of /dev/p
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: initial GPS device /dev/pps0 open fa
Jul 12 11:31:02 SpoobyDRAWS systemd[1]: Started GPS (Global Positioning System) Daemon.
~
~
~
~
~
~
~
 
pi@SpoobyDRAWS:~ $ gpsmon
pi@SpoobyDRAWS:~ $ sudo systemctl status gpsd
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-07-12 11:31:02 UTC; 5min ago
  Process: 2246 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (code=exited, status=0/SUCCESS)
 Main PID: 2247 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─2247 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0
 
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: initial GPS device /dev/pps0 open failed
Jul 12 11:31:02 SpoobyDRAWS systemd[1]: Started GPS (Global Positioning System) Daemon.
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/ttySC0 failed: No such file or directory - re
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open of /dev/ttySC0 failed: No such file or dire
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: /dev/ttySC0: device activation failed.
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: /dev/ttySC0: activation failed, freeing device
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/pps0 failed: No such file or directory - retr
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open of /dev/pps0 failed: No such file or direct
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: /dev/pps0: device activation failed.
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: /dev/pps0: activation failed, freeing device
...skipping...
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-07-12 11:31:02 UTC; 5min ago
  Process: 2246 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (code=exited, status=0/SUCCESS)
 Main PID: 2247 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─2247 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0
 
Jul 12 11:31:02 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: initial GPS device /dev/pps0 open failed
Jul 12 11:31:02 SpoobyDRAWS systemd[1]: Started GPS (Global Positioning System) Daemon.
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/ttySC0 failed: No such file or directory - re
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open of /dev/ttySC0 failed: No such file or dire
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: /dev/ttySC0: device activation failed.
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: /dev/ttySC0: activation failed, freeing device
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: device open of /dev/pps0 failed: No such file or directory - retr
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: SER: read-only device open of /dev/pps0 failed: No such file or direct
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: /dev/pps0: device activation failed.
Jul 12 11:32:30 SpoobyDRAWS gpsd[2247]: gpsd:ERROR: /dev/pps0: activation failed, freeing device
~
~
~
~
~
lines 1-18/18 (END)
pi@SpoobyDRAWS:~ $ gpsmon
pi@SpoobyDRAWS:~ $ cgps
cgps: caught signal 2
pi@SpoobyDRAWS:~ $ sudo systemctl restart gpsd
pi@SpoobyDRAWS:~ $ sudo systemctl status gpsd
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-07-12 11:37:54 UTC; 5s ago
  Process: 2988 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (code=exited, status=0/SUCCESS)
 Main PID: 2989 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─2989 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0
 
Jul 12 11:37:54 SpoobyDRAWS systemd[1]: Starting GPS (Global Positioning System) Daemon...
Jul 12 11:37:54 SpoobyDRAWS systemd[1]: Started GPS (Global Positioning System) Daemon.
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: device open of /dev/ttySC0 failed: No such file or directory - re
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: read-only device open of /dev/ttySC0 failed: No such file or dire
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: initial GPS device /dev/ttySC0 open failed
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: device open of /dev/pps0 failed: No such file or directory - retr
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: read-only device open of /dev/pps0 failed: No such file or direct
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: initial GPS device /dev/pps0 open failed
 
pi@SpoobyDRAWS:~ $ sudo systemctl status gpsd
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-07-12 11:37:54 UTC; 21s ago
  Process: 2988 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (code=exited, status=0/SUCCESS)
 Main PID: 2989 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─2989 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0
 
Jul 12 11:37:54 SpoobyDRAWS systemd[1]: Starting GPS (Global Positioning System) Daemon...
Jul 12 11:37:54 SpoobyDRAWS systemd[1]: Started GPS (Global Positioning System) Daemon.
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: device open of /dev/ttySC0 failed: No such file or directory - re
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: read-only device open of /dev/ttySC0 failed: No such file or dire
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: initial GPS device /dev/ttySC0 open failed
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: device open of /dev/pps0 failed: No such file or directory - retr
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: read-only device open of /dev/pps0 failed: No such file or direct
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: initial GPS device /dev/pps0 open failed
 
pi@SpoobyDRAWS:~ $ sudo systemctl status gpsd
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-07-12 11:37:54 UTC; 1min 5s ago
  Process: 2988 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (code=exited, status=0/SUCCESS)
 Main PID: 2989 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─2989 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0
 
Jul 12 11:37:54 SpoobyDRAWS systemd[1]: Starting GPS (Global Positioning System) Daemon...
Jul 12 11:37:54 SpoobyDRAWS systemd[1]: Started GPS (Global Positioning System) Daemon.
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: device open of /dev/ttySC0 failed: No such file or directory - re
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: read-only device open of /dev/ttySC0 failed: No such file or dire
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: initial GPS device /dev/ttySC0 open failed
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: device open of /dev/pps0 failed: No such file or directory - retr
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: SER: read-only device open of /dev/pps0 failed: No such file or direct
Jul 12 11:37:54 SpoobyDRAWS gpsd[2989]: gpsd:ERROR: initial GPS device /dev/pps0 open failed

gpsmon:
tcp://localhost:2947          JSON slave driver>
(86) {"class":"VERSION","release":"3.18.1","rev":"3.18.1","proto_major":3,"proto_minor":13}
(32) {"class":"DEVICES","devices":[]}
(122) {"class":"WATCH","enable":true,"json":false,"nmea":false,"raw":2,"scaled":false,"timing":false,"split24":false,"pps"
:true}
 
cgps:
┌───────────────────────────────────────────┐┌──────────────────Seen  0/Used  0┐
│ Time:          n/a                        ││    PRN  Elev   Azim   SNR  Use  │
│ Latitude:      n/a                        ││                                 │
│ Longitude:     n/a                        ││                                 │
│ Altitude:      n/a                        ││                                 │
│ Speed:         n/a                        ││                                 │
│ Heading:         n/a                      ││                                 │
│ Climb:         n/a                        ││                                 │
│ Status:         NO FIX (0 secs)           ││                                 │
│ Long Err  (XDOP, EPX):  n/a ,  n/a        ││                                 │
│ Lat Err   (YDOP, EPY):  n/a ,  n/a        ││                                 │
│ Alt Err   (VDOP, EPV):  n/a ,  n/a        ││                                 │
│ 2D Err    (HDOP, CEP):  n/a ,  n/a        ││                                 │
│ 3D Err    (PDOP, SEP):  n/a ,  n/a        ││                                 │
│ Time Err  (TDOP):       n/a               ││                                 │
│ Geo Err   (GDOP):       n/a               ││                                 │
│ ECEF X, VX:   n/a    n/a                  ││                                 │
│ ECEF Y, VY:   n/a    n/a                  ││                                 │
│ ECEF Z, VZ:   n/a    n/a                  ││                                 │
│ Speed Err (EPS):               n/a        ││                                 │
│ Head Err  (EPD):        n/a               ││                                 │
│ Time offset:            n/a               ││                                 │
│ Grid Square:            n/a               ││                                 │
└───────────────────────────────────────────┘└─────────────────────────────────┘
 
{"class":"VERSION","release":"3.18.1","rev":"3.18.1","proto_major":3,"proto_minor":13}
{"class":"DEVICES","devices":[]}
{"class":"WATCH","enable":true,"json":true,"nmea":false,"raw":0,"scaled":false,"timing":false,"split24":false,"pps":false}
 
 
I'm relatively inexperienced with RPi although I've been running linux for a couple years I don't any deep technical background. All help is appreciated. 
Thanks,
K4SPB

Re: X11 forwarding

Paul Johnson
 

Linux = open source = choices (;

On Wed, 2019-07-17 at 11:30 -0700, John D Hays - K7VE wrote:
I find the built in VNC to be pretty efficient and better than X11

On Wed, Jul 17, 2019 at 11:26 AM Paul Johnson <ve7dhm@...> wrote:


Just an info note.  I found fldigi GUI response very poor to almost
a "locked up" response when I was running it remotely via a ssh
connection.  I changed the encryption algorithm on my command line
login and now get a real time response from the GUI.  This was with
a Pi 3B+ with DRAWS hat over a wireless connection.

ssh -XC -c aes128-ctr user@IPaddress

Paul VE7DHM




Re: X11 forwarding

 

I find the built in VNC to be pretty efficient and better than X11

On Wed, Jul 17, 2019 at 11:26 AM Paul Johnson <ve7dhm@...> wrote:
Just an info note.  I found fldigi GUI response very poor to almost
a "locked up" response when I was running it remotely via a ssh
connection.  I changed the encryption algorithm on my command line
login and now get a real time response from the GUI.  This was with
a Pi 3B+ with DRAWS hat over a wireless connection.

ssh -XC -c aes128-ctr user@IPaddress

Paul VE7DHM
    





--
John D. Hays
Kingston, WA
K7VE

 

X11 forwarding

Paul Johnson
 

Just an info note.  I found fldigi GUI response very poor to almost
a "locked up" response when I was running it remotely via a ssh
connection.  I changed the encryption algorithm on my command line
login and now get a real time response from the GUI.  This was with
a Pi 3B+ with DRAWS hat over a wireless connection.

ssh -XC -c aes128-ctr user@IPaddress

Paul VE7DHM

Re: DRAWS on Pi 3b+ with Raspbian Buster #draws

Frank Ivan
 

Hi Jon,

Can you tell me where you got the snd-soc-tlv320aic32x4-i2c.ko file and do you also need UDRC and snd-soc-tlv320aic32x4.ko?  Is there a ax25.ko? Where do you put those files in /lib/modules?  Did you need to do a insmod command?

Thanks
Frank - K0FEI

On Jul 12, 2019, at 12:02 PM, Jon Gross <jong@...> wrote:


Thanks!

What I ended up doing was basically this:

1. vanilla buster install
2. update all the things (apt update ; apt upgrade)
3. add snd-soc-tlv320aic32x4-i2c and ax25 to /etc/modules
4. add dtoverlay=draws,alsaname=udrc and dtparam=audio=on to /boot/config.txt
5. install ax25, gpsd, hamlib, and related dev packages with apt
6. compile/install dire wolf from source

The hardware is working (gps confirmed, radio interface not yet confirmed), and I'm still working on getting the ax25 stuff configured and direwolf wired up correctly, but I think the hardware is functional now, as I'm seeing the sound card and the gps is working great.

Thanks again for your help!

-jon

Re: Echolink install on Raspi3 and UDRC II with Direwolf from n7nix

Bjorn Pehrson
 

Hi Wim,

I would be interested to know what repeater you connected and if all went well to simultaneously use svxlink/echolink and direwolf/aprs on an RPi with Draws.
Did you install and configure svxlink/echolink independently of the Draws software or are there any interdependencies?

Thanks and 73
sa0bxi

Re: prog_refresh.sh error?

Basil Gunn
 

Thanks Edd & Jim for verifying the changes I made. I appreciate your
support.
/Basil n7nix

Jim Erickson <jim@...> writes:

I didn’t save the output, but mine successfully detected that gpsd was
a different version, downloaded the new version (3.19), compiled it
and installed it in place. That appears to have fixed the same
problem I was having Basil.

73
Jim

On Jul 16, 2019, at 13:02, Edward Seeliger <eseeliger@...> wrote:

Here is the console output after git pull:

pi@KD5MDRAWS:~/n7nix/gps $ ./gp_verchk.sh
gp_verchk.sh: Detected gpsd package.
gpsd: current version: 3.19, installed: 3.19
pi@KD5MDRAWS:~/n7nix/gps $ ./gp_verchk.sh -u
gp_verchk.sh: Detected gpsd package.
gpsd: Running current version 3.19
pi@KD5MDRAWS:~/n7nix/gps $ sudo systemctl restart gpsd
pi@KD5MDRAWS:~/n7nix/gps $ ./gp_verchk.sh
gp_verchk.sh: Detected gpsd package.
gpsd: current version: 3.19, installed: 3.19
pi@KD5MDRAWS:~/n7nix/gps $

Edd - KD5M

Re: prog_refresh.sh error?

Edward Seeliger
 

Basil, after the update above, I ran prog_refresh.sh again and it updates as it should without the previous errors.
It also updated XASTIR to a new version. It shows the correct GPSD version is installed.
Thanks for your help and all the (prompt) support you provide here for all of us!
Edd - KD5M

Re: prog_refresh.sh error?

Jim Erickson
 

I didn’t save the output, but mine successfully detected that gpsd was a different version, downloaded the new version (3.19), compiled it and installed it in place.  That appears to have fixed the same problem I was having Basil.

73
Jim

On Jul 16, 2019, at 13:02, Edward Seeliger <eseeliger@...> wrote:

Here is the console output after git pull:

pi@KD5MDRAWS:~/n7nix/gps $ ./gp_verchk.sh
gp_verchk.sh: Detected gpsd package.
gpsd: current version: 3.19, installed: 3.19
pi@KD5MDRAWS:~/n7nix/gps $ ./gp_verchk.sh -u
gp_verchk.sh: Detected gpsd package.
gpsd: Running current version 3.19
pi@KD5MDRAWS:~/n7nix/gps $ sudo systemctl restart gpsd
pi@KD5MDRAWS:~/n7nix/gps $ ./gp_verchk.sh
gp_verchk.sh: Detected gpsd package.
gpsd: current version: 3.19, installed: 3.19
pi@KD5MDRAWS:~/n7nix/gps $

Edd - KD5M