Direwolf with HT


 

I am working on a portable setup utilizing a raspberry pi 3 with UDRC II and handheld radio. I have a cable which will work with my Kenwood THf6a and my Radiooddity GD77.  I utilize Winlink on my Windows 10 computer. When I have the HT's connected to an outside antenna they both work fine, switching from TX to RX and accessing the local RMS Server. However, when I do not have the HT connected to an outside antenna as soon as I initiate a connection the radio goes into TX mode and does not switch back to RX. 

I am about 4 miles from the EOC where the server and packet station is located and have good RX signals when not connected to the outside antenna. I am at a loss to figure out why the ht remains in TX mode when not connected to the outside antenna. It happens to both the THf6a and the GD77. The THf6a has settings to enable it to connect directly to the discriminator while the GD77 does not. 

Any Ideas would be appreciated.

Have a great day.
Rich, KR4PI


Chris - KC9AD
 

Rich,

 

I would guess that it might be RF getting into your RPi or UDRC. Can you separate the radio, especially vertically, and see if that improves it? Or maybe try an external mag-mount antenna on a tripod, well above your RPi-UDRC? 73.

 

Chris KC9AD

 

From: udrc@nw-digital-radio.groups.io <udrc@nw-digital-radio.groups.io> On Behalf Of Rich KR4PI
Sent: Monday, May 14, 2018 1:42 PM
To: udrc@nw-digital-radio.groups.io
Subject: [udrc] Direwolf with HT

 

I am working on a portable setup utilizing a raspberry pi 3 with UDRC II and handheld radio. I have a cable which will work with my Kenwood THf6a and my Radiooddity GD77.  I utilize Winlink on my Windows 10 computer. When I have the HT's connected to an outside antenna they both work fine, switching from TX to RX and accessing the local RMS Server. However, when I do not have the HT connected to an outside antenna as soon as I initiate a connection the radio goes into TX mode and does not switch back to RX. 

I am about 4 miles from the EOC where the server and packet station is located and have good RX signals when not connected to the outside antenna. I am at a loss to figure out why the ht remains in TX mode when not connected to the outside antenna. It happens to both the THf6a and the GD77. The THf6a has settings to enable it to connect directly to the discriminator while the GD77 does not. 

Any Ideas would be appreciated.

Have a great day.
Rich, KR4PI


 

Thank you, Chris, you are absolutely correct. I used a mag mount antenna removed by just a couple feet from the Pi with UDRC and it worked just fine. Makes a very nice small portable setup for working Winlink via VHF 1200 baud packet. 

Thanks again Chris, I had not thought about RF getting into the pi or the UDRC.

Rich, KR4PI