Topics

Fixed:[udrc] No Transmit Audio #draws #direwolf #xastir


Jack Spitznagel
 

All,

 

Thanks for your patience on this thread – the problem was not self-evident and I don’t understand why the following situation works for me. The solution was to comment out all references to port 1 – left channel in the direwolf.config file as shown below with changes in red.

 

What confuses me:

  1. Even if port 1 is not configured, when a radio is attached to the left port and turned on, Direwolf will not digipeat. Turn it off and it will digipeat from port 0.
  2. If the left channel port 1 references are all enabled, Direwolf will not digipeat on port 0 or port 1 regardless if the port 1 radio is turned on or off.

 

Jack – KD4IZ

 

----- Working direwolf.conf -----

ADEVICE plughw:CARD=udrc,DEV=0

ARATE 48000

ACHANNELS 1

#Port 0

CHANNEL 0

MYCALL KD4IZ-2

MODEM 1200

PTT GPIO 23

#Port 1

#CHANNEL 1

#MYCALL KD4IZ-3

#MODEM 9600

#PTT GPIO 12

AGWPORT 8000

KISSPORT 8001

TBEACON delay=1 sendto=0 every=10 overlay=S symbol="digi" power=5 height=20 gain=6 comment="DRAWS 0 1200" via=WIDE1-1,WIDE2-1

#TBEACON delay=1 sendto=1 every=10 overlay=S symbol="digi" power=5 height=20 gain=6 comment="DRAWS 1 9600" via=WIDE1-1,WIDE2-1

DIGIPEAT 0 0 ^WIDE[3-7]-[1-7]$|^TEST$ ^WIDE[12]-[12]$ TRACE

#DIGIPEAT 1 1 ^WIDE[3-7]-[1-7]$|^TEST$ ^WIDE[12]-[12]$ TRACE

#DIGIPEAT 0 1 ^WIDE[3-7]-[1-7]$|^TEST$ ^WIDE[12]-[12]$ TRACE

#DIGIPEAT 1 0 ^WIDE[3-7]-[1-7]$|^TEST$ ^WIDE[12]-[12]$ TRACE

IGSERVER northwest.aprs2.net

#IGLOGIN YOUR INTERNET LOGIN AND PASSCODE FOR APRS REPORTING

IGLOGIN xxxxx #####

TBEACON sendto=IG delay=1 every=60:00 symbol="igate" overlay=R

IGTXLIMIT 6 10

GPSD localhost

 


--
J Spitznagel
Science River LLC
KD4IZ