Topics

ntpd not installed on beta 5 #ntp #chrony #ntpd

Bernard Pidoux
 

Hi,
I noticed that on my compass beta-5 system the time was not set correctly despite I did perform initial country, keyboard etc...configuration.
Thus I apt-get installed ntp
and after one or two minutes the console clock did display local time correctly.
Consequently I suggest to pre install ntpd on next compass draws releases.

Bernard, f6bvp

 

Look at the Wiki. Chrony is installed in lieu of ntpd. 


On Tue, Dec 18, 2018, 07:52 Bernard Pidoux <bernard.f6bvp@... wrote:
Hi,
I noticed that on my compass beta-5 system the time was not set correctly despite I did perform initial country, keyboard etc...configuration.
Thus  I apt-get installed ntp
and after one or two minutes the console clock did display  local time correctly.
Consequently I suggest to pre install ntpd on next compass draws releases.

Bernard, f6bvp




Basil Gunn
 

I noticed that on my compass beta-5 system the time was not set
correctly despite I did perform initial country, keyboard
etc...configuration. Thus I apt-get installed ntp and after one or
two minutes the console clock did display local time correctly.
That's true & I need to fix that.

Currently time defaults to using chrony & the gps. Chrony is another
implementation the Network Time Protocol. You should notice that when
you install ntp, chrony is removed.
I need to look into using chrony without a gps.

/Basil

 

Chrony works without GPS as a client on the Internet. 


On Tue, Dec 18, 2018, 08:13 Basil Gunn <basil@... wrote:

> I noticed that on my compass beta-5 system the time was not set
> correctly despite I did perform initial country, keyboard
> etc...configuration.  Thus I apt-get installed ntp and after one or
> two minutes the console clock did display local time correctly.

That's true & I need to fix that.

Currently time defaults to using chrony & the gps.  Chrony is another
implementation the Network Time Protocol. You should notice that when
you install ntp, chrony is removed.
I need to look into using chrony without a gps.

/Basil



f6bvp
 

Ok. I reinstalled chrony for it had been removed when installing ntp. 
This time command 
systemctl status chrony 
showed that it was started as ntp client/server and
chrony sources command found 6 sources while gps is not activated.

Thanks,

73 de Bernard f6bvp


Le 18 déc. 2018 à 17:20, John D Hays - K7VE <john@...> a écrit :

Chrony works without GPS as a client on the Internet. 

On Tue, Dec 18, 2018, 08:13 Basil Gunn <basil@... wrote:

> I noticed that on my compass beta-5 system the time was not set
> correctly despite I did perform initial country, keyboard
> etc...configuration.  Thus I apt-get installed ntp and after one or
> two minutes the console clock did display local time correctly.

That's true & I need to fix that.

Currently time defaults to using chrony & the gps.  Chrony is another
implementation the Network Time Protocol. You should notice that when
you install ntp, chrony is removed.
I need to look into using chrony without a gps.

/Basil



Basil Gunn
 

Bernard,

I have been playing around with chrony for a few hours now and I've
convinced myself that chronyd should work fine with or without a gps
antenna connected.

If you look at the output of this command without a GPS antenna:

sudo timedatectl

it should have "Network time on: yes"

I have experienced chrony sometimes taking several minutes to get the
local time correct. I think installing the battery on the DRAWS board
could help that behavior. Let me know if you see other time related
problems.

/Basil



f6bvp <f6bvp@...> writes:

Ok. I reinstalled chrony for it had been removed when installing ntp.
This time command
systemctl status chrony
showed that it was started as ntp client/server and
chrony sources command found 6 sources while gps is not activated.

Thanks,

73 de Bernard f6bvp


Le 18 déc. 2018 à 17:20, John D Hays - K7VE <@john_hays> a écrit :

Chrony works without GPS as a client on the Internet.

On Tue, Dec 18, 2018, 08:13 Basil Gunn <@basil860 wrote:

I noticed that on my compass beta-5 system the time was not set
correctly despite I did perform initial country, keyboard
etc...configuration. Thus I apt-get installed ntp and after one or
two minutes the console clock did display local time correctly.
That's true & I need to fix that.

Currently time defaults to using chrony & the gps. Chrony is another
implementation the Network Time Protocol. You should notice that when
you install ntp, chrony is removed.
I need to look into using chrony without a gps.

/Basil


 

I will add that if you go into /etc/chrony/chrony.conf and modify the line for PPS and add prefer to the end, that should give you the most accurate time when the GPS is running.

refclock SHM 2 refid PPS precision 1e-9 poll 3 trust prefer


On Tue, Dec 18, 2018 at 4:35 PM Basil Gunn <basil@...> wrote:

Bernard,

I have been playing around with chrony for a few hours now and I've
convinced myself that chronyd should work fine with or without a gps
antenna connected.

If you look at the output of this command without a GPS antenna:

sudo timedatectl

it should have "Network time on: yes"

I have experienced chrony sometimes taking several minutes to get the
local time correct. I think installing the battery on the DRAWS board
could help that behavior. Let me know if you see other time related
problems.

/Basil



f6bvp <f6bvp@...> writes:

> Ok. I reinstalled chrony for it had been removed when installing ntp.
> This time command
> systemctl status chrony
> showed that it was started as ntp client/server and
> chrony sources command found 6 sources while gps is not activated.
>
> Thanks,
>
> 73 de Bernard f6bvp
>
>
>> Le 18 déc. 2018 à 17:20, John D Hays - K7VE <john@...> a écrit :
>>
>> Chrony works without GPS as a client on the Internet.
>>
>>> On Tue, Dec 18, 2018, 08:13 Basil Gunn <basil@... wrote:
>>>
>>> > I noticed that on my compass beta-5 system the time was not set
>>> > correctly despite I did perform initial country, keyboard
>>> > etc...configuration.  Thus I apt-get installed ntp and after one or
>>> > two minutes the console clock did display local time correctly.
>>>
>>> That's true & I need to fix that.
>>>
>>> Currently time defaults to using chrony & the gps.  Chrony is another
>>> implementation the Network Time Protocol. You should notice that when
>>> you install ntp, chrony is removed.
>>> I need to look into using chrony without a gps.
>>>
>>> /Basil
>>>
>>>
>>>
>>
>>
>
>





--


John D. Hays
Edmonds, WA
K7VE

   

Gayland Gump
 

FYI,  I installed a battery before I first powered up the DRAWS but the time did not update even with a network connection and the gps antenna installed.  I ended up setting it manually using the date command.  Haven't been back to it to see if it has held will try to get around to that soon.

Gayland
KG7GCF


On Tue, Dec 18, 2018 at 4:35 PM Basil Gunn <basil@...> wrote:

Bernard,

I have been playing around with chrony for a few hours now and I've
convinced myself that chronyd should work fine with or without a gps
antenna connected.

If you look at the output of this command without a GPS antenna:

sudo timedatectl

it should have "Network time on: yes"

I have experienced chrony sometimes taking several minutes to get the
local time correct. I think installing the battery on the DRAWS board
could help that behavior. Let me know if you see other time related
problems.

/Basil



f6bvp <f6bvp@...> writes:

> Ok. I reinstalled chrony for it had been removed when installing ntp.
> This time command
> systemctl status chrony
> showed that it was started as ntp client/server and
> chrony sources command found 6 sources while gps is not activated.
>
> Thanks,
>
> 73 de Bernard f6bvp
>
>
>> Le 18 déc. 2018 à 17:20, John D Hays - K7VE <john@...> a écrit :
>>
>> Chrony works without GPS as a client on the Internet.
>>
>>> On Tue, Dec 18, 2018, 08:13 Basil Gunn <basil@... wrote:
>>>
>>> > I noticed that on my compass beta-5 system the time was not set
>>> > correctly despite I did perform initial country, keyboard
>>> > etc...configuration.  Thus I apt-get installed ntp and after one or
>>> > two minutes the console clock did display local time correctly.
>>>
>>> That's true & I need to fix that.
>>>
>>> Currently time defaults to using chrony & the gps.  Chrony is another
>>> implementation the Network Time Protocol. You should notice that when
>>> you install ntp, chrony is removed.
>>> I need to look into using chrony without a gps.
>>>
>>> /Basil
>>>
>>>
>>>
>>
>>
>
>



 

The RTC is part of the GPS and is set by the GPS, make sure your GPS is receiving to get the RTC set, you can use gpsmon or cgps to check the gps.  Then gpsd and chrony need to be running for the system clock updates.

On Tue, Dec 18, 2018 at 4:51 PM Gayland Gump <kg7gcf@...> wrote:
FYI,  I installed a battery before I first powered up the DRAWS but the time did not update even with a network connection and the gps antenna installed.  I ended up setting it manually using the date command.  Haven't been back to it to see if it has held will try to get around to that soon.

Gayland
KG7GCF


On Tue, Dec 18, 2018 at 4:35 PM Basil Gunn <basil@...> wrote:

Bernard,

I have been playing around with chrony for a few hours now and I've
convinced myself that chronyd should work fine with or without a gps
antenna connected.

If you look at the output of this command without a GPS antenna:

sudo timedatectl

it should have "Network time on: yes"

I have experienced chrony sometimes taking several minutes to get the
local time correct. I think installing the battery on the DRAWS board
could help that behavior. Let me know if you see other time related
problems.

/Basil



f6bvp <f6bvp@...> writes:

> Ok. I reinstalled chrony for it had been removed when installing ntp.
> This time command
> systemctl status chrony
> showed that it was started as ntp client/server and
> chrony sources command found 6 sources while gps is not activated.
>
> Thanks,
>
> 73 de Bernard f6bvp
>
>
>> Le 18 déc. 2018 à 17:20, John D Hays - K7VE <john@...> a écrit :
>>
>> Chrony works without GPS as a client on the Internet.
>>
>>> On Tue, Dec 18, 2018, 08:13 Basil Gunn <basil@... wrote:
>>>
>>> > I noticed that on my compass beta-5 system the time was not set
>>> > correctly despite I did perform initial country, keyboard
>>> > etc...configuration.  Thus I apt-get installed ntp and after one or
>>> > two minutes the console clock did display local time correctly.
>>>
>>> That's true & I need to fix that.
>>>
>>> Currently time defaults to using chrony & the gps.  Chrony is another
>>> implementation the Network Time Protocol. You should notice that when
>>> you install ntp, chrony is removed.
>>> I need to look into using chrony without a gps.
>>>
>>> /Basil
>>>
>>>
>>>
>>
>>
>
>





--


John D. Hays
Edmonds, WA
K7VE

   

Basil Gunn
 

FYI, I installed a battery before I first powered up the DRAWS but the
time did not update even with a network connection and the gps antenna
installed.
My experience is that it can sometimes take 10 minutes for chronyd to
sync.
/Basil


I ended up setting it manually using the date command. Haven't
been back to it to see if it has held will try to get around to that soon.

Gayland
KG7GCF

Gayland Gump
 

I believe it ran for a few hours without the update, in fact I was surprised when I finally noticed that the date and time were so off.  I did not do anything with chrony nor the gps other than install the battery and hooked up the antenna.  

Gayland
KG7GCF


On Tue, Dec 18, 2018 at 5:56 PM Basil Gunn <basil@...> wrote:

> FYI,  I installed a battery before I first powered up the DRAWS but the
> time did not update even with a network connection and the gps antenna
> installed.

My experience is that it can sometimes take 10 minutes for chronyd to
sync.
/Basil


> I ended up setting it manually using the date command.  Haven't
> been back to it to see if it has held will try to get around to that soon.
>
> Gayland
> KG7GCF



Basil Gunn
 

From some google-fu:

Note that the chrony service does not change the time. The often
misconception is that the chrony service is setting the time to the one
given by the NTP server. This is incorrect – what actually happens is
that based on the answer from the NTP server, chrony just tells the
system clock to go faster or slower. For this reason, sometimes even
though the time is wrong and the NTP server is working, the time does
not get corrected immediately.

If your system time is off by a lot you can try this.
To step the system clock immediately, bypassing any adjustments in
progress by slewing, issue the following command as root:

chronyc makestep

Also check out entries in:
https://github.com/nwdigitalradio/n7nix/blob/master/VERIFY_CONFIG.md
Look for "Check GPS"

Also send me the console output from this script.
https://github.com/nwdigitalradio/n7nix/blob/master/gps/verify_time.sh

/Basil

Gayland Gump <kg7gcf@...> writes:

I believe it ran for a few hours without the update, in fact I was
surprised when I finally noticed that the date and time were so off. I did
not do anything with chrony nor the gps other than install the battery and
hooked up the antenna.

Gayland
KG7GCF


On Tue, Dec 18, 2018 at 5:56 PM Basil Gunn <@basil860> wrote:


FYI, I installed a battery before I first powered up the DRAWS but the
time did not update even with a network connection and the gps antenna
installed.
My experience is that it can sometimes take 10 minutes for chronyd to
sync.
/Basil


I ended up setting it manually using the date command. Haven't
been back to it to see if it has held will try to get around to that
soon.

Gayland
KG7GCF

f6bvp
 

I did not install a battery yet in my DRAWS hat.
None of the button batteries I have in stock fits into the case.
Could someone give me a model reference or number.

Bernard

Le 19 déc. 2018 à 07:20, Basil Gunn <@basil860> a écrit :


From some google-fu:

Note that the chrony service does not change the time. The often
misconception is that the chrony service is setting the time to the one
given by the NTP server. This is incorrect – what actually happens is
that based on the answer from the NTP server, chrony just tells the
system clock to go faster or slower. For this reason, sometimes even
though the time is wrong and the NTP server is working, the time does
not get corrected immediately.

If your system time is off by a lot you can try this.
To step the system clock immediately, bypassing any adjustments in
progress by slewing, issue the following command as root:

chronyc makestep

Also check out entries in:
https://github.com/nwdigitalradio/n7nix/blob/master/VERIFY_CONFIG.md
Look for "Check GPS"

Also send me the console output from this script.
https://github.com/nwdigitalradio/n7nix/blob/master/gps/verify_time.sh

/Basil

Gayland Gump <kg7gcf@...> writes:

I believe it ran for a few hours without the update, in fact I was
surprised when I finally noticed that the date and time were so off. I did
not do anything with chrony nor the gps other than install the battery and
hooked up the antenna.

Gayland
KG7GCF


On Tue, Dec 18, 2018 at 5:56 PM Basil Gunn <@basil860> wrote:


FYI, I installed a battery before I first powered up the DRAWS but the
time did not update even with a network connection and the gps antenna
installed.
My experience is that it can sometimes take 10 minutes for chronyd to
sync.
/Basil


I ended up setting it manually using the date command. Haven't
been back to it to see if it has held will try to get around to that
soon.

Gayland
KG7GCF

f6bvp
 

If not already present adding 
chronyc makestep
in n7nix  install core script could be usefull to perform initial system time adjustment when GPS is not yet switched. This is my case for I did’not put any antenna for indoor use.

Bernard


Le 19 déc. 2018 à 07:20, Basil Gunn <basil@...> a écrit :


From some google-fu:

Note that the chrony service does not change the time. The often
misconception is that the chrony service is setting the time to the one
given by the NTP server.  This is incorrect – what actually happens is
that based on the answer from the NTP server, chrony just tells the
system clock to go faster or slower.  For this reason, sometimes even
though the time is wrong and the NTP server is working, the time does
not get corrected immediately.

If your system time is off by a lot you can try this.
To step the system clock immediately, bypassing any adjustments in
progress by slewing, issue the following command as root:

chronyc makestep

Also check out entries in:
https://github.com/nwdigitalradio/n7nix/blob/master/VERIFY_CONFIG.md
Look for "Check GPS"

Also send me the console output from this script.
https://github.com/nwdigitalradio/n7nix/blob/master/gps/verify_time.sh

/Basil

 

Battery is CR1220 NON RECHARGEABLE

Basil Gunn
 

If not already present adding
chronyc makestep
in n7nix install core script could be usefull to perform initial
system time adjustment when GPS is not yet switched. This is my case
for I did’not put any antenna for indoor use.
Yes. Exactly what I was going to do.
Just want to make sure that is sufficient to solve Gayland's problem.
/Basil



Le 19 déc. 2018 à 07:20, Basil Gunn <@basil860> a écrit :


From some google-fu:

Note that the chrony service does not change the time. The often
misconception is that the chrony service is setting the time to the one
given by the NTP server. This is incorrect – what actually happens is
that based on the answer from the NTP server, chrony just tells the
system clock to go faster or slower. For this reason, sometimes even
though the time is wrong and the NTP server is working, the time does
not get corrected immediately.

If your system time is off by a lot you can try this.
To step the system clock immediately, bypassing any adjustments in
progress by slewing, issue the following command as root:

chronyc makestep

Also check out entries in:
https://github.com/nwdigitalradio/n7nix/blob/master/VERIFY_CONFIG.md
Look for "Check GPS"

Also send me the console output from this script.
https://github.com/nwdigitalradio/n7nix/blob/master/gps/verify_time.sh

/Basil

David [kg5eiu]
 

These CR1220s work well in mine:


73!!  David (KG5EIU)


On Dec 19, 2018, at 3:06 AM, f6bvp <f6bvp@...> wrote:

I did not install a battery yet  in my DRAWS hat.
None of the button batteries I have in stock fits into the case.
Could someone give me a model reference or number.

Bernard


Le 19 déc. 2018 à 07:20, Basil Gunn <basil@...> a écrit :


From some google-fu:

Note that the chrony service does not change the time. The often
misconception is that the chrony service is setting the time to the one
given by the NTP server.  This is incorrect – what actually happens is
that based on the answer from the NTP server, chrony just tells the
system clock to go faster or slower.  For this reason, sometimes even
though the time is wrong and the NTP server is working, the time does
not get corrected immediately.

If your system time is off by a lot you can try this.
To step the system clock immediately, bypassing any adjustments in
progress by slewing, issue the following command as root:

chronyc makestep

Also check out entries in:
https://github.com/nwdigitalradio/n7nix/blob/master/VERIFY_CONFIG.md
Look for "Check GPS"

Also send me the console output from this script.
https://github.com/nwdigitalradio/n7nix/blob/master/gps/verify_time.sh

/Basil

Gayland Gump <kg7gcf@...> writes:

I believe it ran for a few hours without the update, in fact I was
surprised when I finally noticed that the date and time were so off.  I did
not do anything with chrony nor the gps other than install the battery and
hooked up the antenna.

Gayland
KG7GCF


On Tue, Dec 18, 2018 at 5:56 PM Basil Gunn <basil@...> wrote:


FYI,  I installed a battery before I first powered up the DRAWS but the
time did not update even with a network connection and the gps antenna
installed.

My experience is that it can sometimes take 10 minutes for chronyd to
sync.
/Basil


I ended up setting it manually using the date command.  Haven't
been back to it to see if it has held will try to get around to that
soon.

Gayland
KG7GCF








f6bvp
 

Hi Basil,

I ran your script verify_time.sh and saw NTP synchronized: no !
Consequently I concluded that my NTP install operation followed by another chrony install introduced some issue.
Thus I apt-get removed chrony and tried to install it again.
However new install failed until I used the following parameter in order to remove ALL chrnoy related files :
apt-get purge chrony
before install it again with success.
Then your script showed me that NTP was synchronized.
Many thanks for your help.

Bernard, f6bvp

Basil Gunn
 

Hi Bernard,
Thanks for the feedback.

Will be releasing a beta6 image in the next day or so with more updates
including your suggestions:
Prompt for AX.25 IP addresses.
Added chronyc makestep to core_install.sh

Also added iptables default install with drop of 239.255.255.250 on
ax.25 interfaces. This address is an SSDP (Simple Service Discovery
Protocol) udp multicast coming from google chrome to discover chromecast
servers. I am thinking this might solve the panic you are seeing in
rose_route_frame where one of the addresses is a NULL pointer.

/Basil



f6bvp <f6bvp@...> writes:

Hi Basil,

I ran your script verify_time.sh and saw NTP synchronized: no !
Consequently I concluded that my NTP install operation followed by another chrony install introduced some issue.
Thus I apt-get removed chrony and tried to install it again.
However new install failed until I used the following parameter in order to remove ALL chrnoy related files :
*apt-get purge chrony*
before install it again with success.
Then your script showed me that NTP was synchronized.
Many thanks for your help.

Bernard, f6bvp