Topics

DRAWS7 does not recognize udrc or draws


Roderick Wayne Hart Sr.
 

I get the following msg 

Found udrcver.st here /home/pi/n7nix/bin
Draws installed
No udrc sound card found by aplay ... exiting

Can someone tell me what corrections I need to make. Everything seems to have loaded properly but the udrc/draws devices does not load.


 

Is your DRAWS board installed and property seated?


On Tue, Jan 8, 2019, 18:20 Roderick Wayne Hart Sr. <rod.hart@... wrote:
I get the following msg 

Found udrcver.st here /home/pi/n7nix/bin
Draws installed
No udrc sound card found by aplay ... exiting

Can someone tell me what corrections I need to make. Everything seems to have loaded properly but the udrc/draws devices does not load.


Roderick Wayne Hart Sr.
 

Yes. It runs version 5 ok. I believe something is mangled in config.txt. It looks like the drivers are loaded there. The fact that it says Draws installed but looks for and can not find udrc is confusing.

Rod Hart



On January 8, 2019, at 10:04 PM, John D Hays - K7VE <john@...> wrote:


Is your DRAWS board installed and property seated?

On Tue, Jan 8, 2019, 18:20 Roderick Wayne Hart Sr. <rod.hart@... wrote:
I get the following msg 

Found udrcver.st here /home/pi/n7nix/bin
Draws installed
No udrc sound card found by aplay ... exiting

Can someone tell me what corrections I need to make. Everything seems to have loaded properly but the udrc/draws devices does not load.


 

If you have a UDRC, look in config.txt and see if it is loading draws and change it to udrc


On Tue, Jan 8, 2019, 19:58 Roderick Wayne Hart Sr. <rod.hart@... wrote:

Yes. It runs version 5 ok. I believe something is mangled in config.txt. It looks like the drivers are loaded there. The fact that it says Draws installed but looks for and can not find udrc is confusing.

Rod Hart



On January 8, 2019, at 10:04 PM, John D Hays - K7VE <john@...> wrote:


Is your DRAWS board installed and property seated?

On Tue, Jan 8, 2019, 18:20 Roderick Wayne Hart Sr. <rod.hart@... wrote:
I get the following msg 

Found udrcver.st here /home/pi/n7nix/bin
Draws installed
No udrc sound card found by aplay ... exiting

Can someone tell me what corrections I need to make. Everything seems to have loaded properly but the udrc/draws devices does not load.


Basil Gunn
 

Did you follow the instructions found here:
https://nw-digital-radio.groups.io/g/udrc/wiki/DRAWS%3A-Getting-Started

As user pi could you please send us the console output of showudrc.sh.

Thanks,
/Basil

Roderick Wayne Hart Sr. <rod.hart@...> writes:

I get the following msg

Found udrcver.st here /home/pi/n7nix/bin
Draws installed
No udrc sound card found by aplay ... exiting

Can someone tell me what corrections I need to make. Everything seems to have loaded properly but the udrc/draws devices does not load.


Roderick Wayne Hart Sr.
 

I'll reflash. Thanks.

Rod Hart



On January 8, 2019, at 11:19 PM, John D Hays - K7VE <john@...> wrote:


If you have a UDRC, look in config.txt and see if it is loading draws and change it to udrc

On Tue, Jan 8, 2019, 19:58 Roderick Wayne Hart Sr. <rod.hart@... wrote:

Yes. It runs version 5 ok. I believe something is mangled in config.txt. It looks like the drivers are loaded there. The fact that it says Draws installed but looks for and can not find udrc is confusing.

Rod Hart



On January 8, 2019, at 10:04 PM, John D Hays - K7VE <john@...> wrote:


Is your DRAWS board installed and property seated?

On Tue, Jan 8, 2019, 18:20 Roderick Wayne Hart Sr. <rod.hart@... wrote:
I get the following msg 

Found udrcver.st here /home/pi/n7nix/bin
Draws installed
No udrc sound card found by aplay ... exiting

Can someone tell me what corrections I need to make. Everything seems to have loaded properly but the udrc/draws devices does not load.


Joseph Vilardo
 

Rod Hart

I ran into a similar problem. When I would run aplay -l only card 0 would show, card 1  udrc [udrc] was not displayed. I raised the question on this forum and got reply from Annaleise and Basil. Annaleise's response is what follows. If you change the order of the directive "dtparam=audio=on" in the $ /boot/config.txt file to follow the directive "dtoverlay=" and "dtoverlay=draws" reboot and run aplay -l you should see card 1 udrc load.

Joe K3JV

On 1/1/2019 7:40 PM, Annaliese McDermond wrote:
It appears to me that you have incorrect settings in your config.txt file.  I will make this very explicit because I’m not sure I’ve made myself clear before:

*ORDER MATTERS IN LINES IN config.txt*

If you do not get the directives in the correct order, the OS kernel will not load the correct drivers for you.

If you intend to use the onboard audio on the Pi, the line

dtparam=audio=on

*MUST* come after the lines

dtoverlay=
dtoverlay=draws

Otherwise the device tree will not be loaded correctly and you won’t get a proper driver set.

--
Annaliese McDermond (NH6Z)
nh6z@...



On 1/8/2019 10:58 PM, Roderick Wayne Hart Sr. wrote:

Yes. It runs version 5 ok. I believe something is mangled in config.txt. It looks like the drivers are loaded there. The fact that it says Draws installed but looks for and can not find udrc is confusing.

Rod Hart



On January 8, 2019, at 10:04 PM, John D Hays - K7VE <john@...> wrote:


Is your DRAWS board installed and property seated?

On Tue, Jan 8, 2019, 18:20 Roderick Wayne Hart Sr. <rod.hart@... wrote:
I get the following msg 

Found udrcver.st here /home/pi/n7nix/bin
Draws installed
No udrc sound card found by aplay ... exiting

Can someone tell me what corrections I need to make. Everything seems to have loaded properly but the udrc/draws devices does not load.