Topics

IC-7300 with USB CAT control problem corrected in Beta 7 #draws #gpsd #fldigi #wsjtx


Basil Gunn
 

Thanks for finding this.
USBAUTO="true" in /etc/default/gpsd is an error.
That line has been removed in the BETA8 image.
See below.
/Basil n7nix

Julie McGrew via Groups.Io <juliemcgrew=mac.com@groups.io> writes:

The goal was to control an IC-7300 with a USB cable and operate fldigi, wsjt-x, and JS8Call using the radio's sound card. DRAWS received the audio fine, but would not control the radio. The IC-7300 was on ttyUSB0, but the command "stty -F /dev/ttyUSB0" returned the "device or resource busy" error. Unable to find the culprit I installed lsof with this command: "sudo apt-get install lsof" and ran: "sudo lsof /dev/ttyUSB0". The response showed that ttyUSB0 was being used by gpsd.

The Wiki directions for setting up gpsd read as follows:
Update, or create, the configuration file, /etc/default/gpsd, using a text editor, and set the following values:
START_DAEMON="true"
DEVICES="/dev/ttySC0 /dev/pps0"
GPSD_OPTIONS="-n"

I checked the file and it looked like this:
#Configure gpsd
START_DAEMON="true"
USBAUTO="true"
DEVICES="/dev/ttySC0 /dev/pps0"
GPSD_OPTIONS="-n -G"

So, I commented out USBAUTO="true" and rebooted DRAWS. Now "stty -F /dev/ttyUSB0" reported the port speed at 115,200 so I issued "stty -F /dev/ttyUSB0 19,200" to get the speed to match what was set in fldigi and on the radio. I created a symlink between /dev/ttyUSB0 and /dev/IC-7300 for a persistant name and now the CAT control works fine with fldigi, wsjt-x, and JS8Call (ver .13).

The question now becomes is it necessary to hotplug gpsd with
"USBAUTO="true"?
No. The draws board uses devices /dev/ttySC0 & /dev/pps0 to control the
GPS chip and NOT a USB device.

If not, perhaps rather than comment out the line I
should have used USBAUTO="false"?
If USBAUTO is commented out, gpsd config defaults to USBAUTO="false"

I would very much appreciated some
input on whether I need to make further corrections to this
configuration to insure that gpsd runs correctly.

Many thanks for DRAWS. What a fantastic product!

73,
julie mcgrew
ac0wn


Julie McGrew
 

The goal was to control an IC-7300 with a USB cable and operate fldigi, wsjt-x, and JS8Call using the radio's sound card.  DRAWS received the audio fine, but would not control the radio. The IC-7300 was on ttyUSB0, but the command "stty -F /dev/ttyUSB0" returned the "device or resource busy" error.  Unable to find the culprit I installed lsof with this command:  "sudo apt-get install lsof" and ran:  "sudo lsof /dev/ttyUSB0".  The response showed that ttyUSB0 was being used by gpsd.

The Wiki directions for setting up gpsd read as follows:
Update, or create, the configuration file, /etc/default/gpsd, using a text editor, and set the following values:
START_DAEMON="true"
DEVICES="/dev/ttySC0 /dev/pps0"
GPSD_OPTIONS="-n"

I checked the file and it looked like this:
#Configure gpsd
START_DAEMON="true"
USBAUTO="true"
DEVICES="/dev/ttySC0 /dev/pps0"
GPSD_OPTIONS="-n -G"

So, I commented out USBAUTO="true" and rebooted DRAWS.  Now "stty -F /dev/ttyUSB0" reported the port speed at 115,200 so I issued "stty -F /dev/ttyUSB0 19,200" to get the speed to match what was set in fldigi and on the radio.  I created a symlink between /dev/ttyUSB0 and /dev/IC-7300 for a persistant name and now the CAT control works fine with fldigi, wsjt-x, and JS8Call (ver .13).

The question now becomes is it necessary to hotplug gpsd with "USBAUTO="true"?  If not, perhaps rather than comment out the line I should have used USBAUTO="false"?  I would very much appreciated some input on whether I need to make further corrections to this configuration to insure that gpsd runs correctly.

Many thanks for DRAWS.  What a fantastic product!

73,
julie mcgrew
ac0wn