[udrc] UDRC-II squelch on the Yaesu FT-897D → Resolved, DRAWS does *not* require this

Stuart Longland VK4MSL

On 20/8/19 9:35 pm, Stuart Longland VK4MSL wrote:
Do I need a pull-up on the SQL lines like I did for the UDRC-II in order
to have normal audio on the FT-857D/897D?
Well, I tried it at first with my FT-897D, got no audio, then tried
switching to an Icom IC-706MkIIG… still no joy.

I was using arecord/aplay and netcat for testing.

I have a Pi 3 with a UDRC-II board as well, which I had previously used
with the Icom set for packet radio, so *knew* it worked. This is a
completely separate computer, so I shut down the Pi I had the DRAWS on,
put it to one side, and plugged the UDRC-II equipped Pi, plugging it
into the same radio and power supply with the same cables.

Bingo… I had audio, badly distorted, but some tweaks in alsamixer, and I
had Triple M Brisbane's calling of the football coming through clear via
the UDRC-II. I swapped back to the other Pi with the DRAWS…

Comparing the mixer settings, the UDRC-II had the ADC Fine Gain Adjust
(ADCFGA) turned off, whereas the DRAWS had them turned on. Soon as I
turned those off, I got audio.

Swapping back to the FT-897D, it worked there too. No removal of SQL
pins or pull-ups necessary, I had audio from both the set directly, and
audio from my netbook. I didn't try watching the SQL pin to see if I
could detect squelch… that'll be another day.

So executive summary:
- There is no pull-up or modification necessary with the FT-897D, it
worked out-of-the-box with the supplied cables as-is.
- Initially I had no audio at all, this was due to ADCFGA being turned
on, audio came through when this was turned off.
Stuart Longland (aka Redhatter, VK4MSL)

I haven't lost my mind...
...it's backed up on a tape somewhere.