6-pin din


K3VIN
 

If I am reading this right, do I need to remove this pin from my cable into my 817? Does this also apply to other apps like JS8?

Running FLdigi with the Yaesu FT-817

Radio Configuration

Set Radio for Digital Mode Operation (SSB-Based AFSK)

  • Use a mDin6 cable without pin 6, Squelch connected (I wiggled pin 6 until it broke)
    • Looking into the male mDin 6 connector with the key on top, its the upper right hand pin
    • Verify this as it is easy to get it wrong


 

This is a hardware issue with some Yaesu radios including the FT 817. 

They use that pin for an input and output and it is just best to disconnect it.

On Sun, Nov 14, 2021, 05:21 K3VIN <ka8yiu@...> wrote:
If I am reading this right, do I need to remove this pin from my cable into my 817? Does this also apply to other apps like JS8?

Running FLdigi with the Yaesu FT-817

Radio Configuration

Set Radio for Digital Mode Operation (SSB-Based AFSK)

  • Use a mDin6 cable without pin 6, Squelch connected (I wiggled pin 6 until it broke)
    • Looking into the male mDin 6 connector with the key on top, its the upper right hand pin
    • Verify this as it is easy to get it wrong


K3VIN
 

Follow-up question: I know I have seen it in the docs, but cannot find now. I need to adjust the baud rate for the 817. I am using the 706_817 alsa, and the 706 is working fine. I just can't remember nor find how to adjust the right connector for the 817.

Kevin


Don Rolph
 

It is menu item 40 which sets packet rate between 1200 and 9600 baud.

You also must set the radio into packet mode if you want to use packet o 2 meters.

On Sun, Nov 14, 2021 at 11:29 AM K3VIN <ka8yiu@...> wrote:
Follow-up question: I know I have seen it in the docs, but cannot find now. I need to adjust the baud rate for the 817. I am using the 706_817 alsa, and the 706 is working fine. I just can't remember nor find how to adjust the right connector for the 817.

Kevin



--

73,
AB1PH
Don Rolph


K3VIN
 
Edited

No, I need to change the baud in the software, the alsa and linux settings, not the rig. That rig is all set.

Tnx

Kevin


Don Rolph
 

I use the 6 pin mini-din on the FT-817ND regularly with this pin enabled.  It is the squelch signal coming from the radio and is typically interpreted as the COS signal.

There is a challenge with some AllStar interfaces that the OS default handling of the COS/Squelch signal can cause the sound card output to permanently mute, requiring a manual reset of the sound level, which will then automatically mute again.

The COS/Squelch signal is typically necessary for voie modes (AllStar, Echolink), but is typically not needed for digital modes.

I am unfamiliar with the DRAWS design, but what is needed in general is the ability to disable the COS signal in the sound card.  Many of the interfaces have a jumper allowing one to disable this signal.  As a last resort, if the interface does not support disabling the COS/Squelch signal, then indeed removing the pin from the 6 pin mini-din works.

But it is usually more standard and less destructive to disable COS/Squelch handling at the interface card itself.

On Sun, Nov 14, 2021 at 10:18 AM John D Hays - K7VE <john@...> wrote:
This is a hardware issue with some Yaesu radios including the FT 817. 

They use that pin for an input and output and it is just best to disconnect it.

On Sun, Nov 14, 2021, 05:21 K3VIN <ka8yiu@...> wrote:
If I am reading this right, do I need to remove this pin from my cable into my 817? Does this also apply to other apps like JS8?

Running FLdigi with the Yaesu FT-817

Radio Configuration

Set Radio for Digital Mode Operation (SSB-Based AFSK)

  • Use a mDin6 cable without pin 6, Squelch connected (I wiggled pin 6 until it broke)
    • Looking into the male mDin 6 connector with the key on top, its the upper right hand pin
    • Verify this as it is easy to get it wrong



--

73,
AB1PH
Don Rolph


Corky
 

That is done in the radio configuration portion of the application you are running (i.e., wsjt-x).

Thanks and 73,
-Corky, AF4PM


On Sun, Nov 14, 2021, at 8:48 AM, K3VIN wrote:

[Edited Message Follows]

No, I need to change the baud in the software, the alsa and linux settings, not the rig. That rig is all set.

Tnx

Kevin


Basil Gunn
 

But it is usually more standard
Only standard if you only own Yaesu radios. iCom & Kenwood radios do NOT
have this problem.

The cable without pin 6 can be used with other sound cards and other
radios for digital modes. It is only required for AllStar, EchoLink
or other voice modes.


Loyd
 

K3VIN
you don't need to break off pin 6 as long as there is nothing connecting to it ,
Should be fine I have the connector with the pin in and nothing wired to it


K3VIN
 
Edited

well, since it mentioned squelch I decided to go ahead and break it off. Interestingly my 817 had no squelch with the cable plugged in if the pie and draws hat did not have power. Now I have squelch with the pie and hat not having power so it did give me a benefit regardless of if it’s necessary or not.

still a part two to one of my replies: where in the pi image do I adjust the baud rate for the 817? I need to use 9600 for an attachment on my accessory so I need to change it to 9600 for the hat.


 

Which serial port?  The one on the accessory port or one attached via USB?

Once you identify which port in /dev, either an application can set the serial port baud rate or you can use stty -- read about it with man stty and info stty from the command line of a terminal.

On Sun, Nov 14, 2021 at 4:59 PM K3VIN <ka8yiu@...> wrote:

[Edited Message Follows]

well, since it mentioned squelch I decided to go ahead and break it off. Interestingly my 817 had no squelch with the cable plugged in if the pie and draws hat did not have power. Now I have squelch with the pie and hat not having power so it did give me a benefit regardless of if it’s necessary or not.

still a part two to one of my replies: where in the pi image do I adjust the baud rate for the 817? I need to use 9600 for an attachment on my accessory so I need to change it to 9600 for the hat.



--
John D. Hays
Kingston, WA
K7VE / WRJT-215