Topics

PRECIPITOUS EDUCATIONAL ARC

John McRae
 

Hi everyone.

Slowly working my way around the DRAWS/Rasp Pi...

I would like to know the sound codex I/O information please.
Seems a lot of options to choose from.
That is for setting up JS8Call at this stage.

Any Advice sincerely appreciated
73. John VK5PO

 


This web tool handles settings, with out having to go into all of the controls of alsamixer.

On Mon, Feb 17, 2020 at 7:51 AM John McRae <johnfmcrae.desktop@...> wrote:
Hi everyone.

Slowly working my way around the DRAWS/Rasp Pi...

I would like to know the sound codex I/O information please.
Seems a lot of options to choose from.
That is for setting up JS8Call at this stage.

Any Advice sincerely appreciated
73. John VK5PO



--
John D. Hays
Kingston, WA
K7VE

 

John McRae
 

Thanks for the info about the youtube vid.

I'll watch it soo9n, and work from that.

cheers John

73, VK5PO

On 18/02/2020 4:05 am, John D Hays - K7VE wrote:

This web tool handles settings, with out having to go into all of the controls of alsamixer.

On Mon, Feb 17, 2020 at 7:51 AM John McRae <johnfmcrae.desktop@...> wrote:
Hi everyone.

Slowly working my way around the DRAWS/Rasp Pi...

I would like to know the sound codex I/O information please.
Seems a lot of options to choose from.
That is for setting up JS8Call at this stage.

Any Advice sincerely appreciated
73. John VK5PO


--
John D. Hays
Kingston, WA
K7VE

 

-- 
MY GMAIL desktop Email accoount,
JF McRae, VK5PO/VK5SIX

f6bvp
 

Hi,
Sorry but the video fails to explain how to install Draws-Manager and how to start it.
I do not see it on my nwdr15.img installed system.
Regards,
Bernard, f6bvp

 


On Tue, Feb 18, 2020 at 10:05 AM f6bvp <f6bvp@...> wrote:
Hi,
Sorry but the video fails to explain how to install Draws-Manager and how to start it.
I do not see it on my nwdr15.img installed system.
Regards,
Bernard, f6bvp



--
John D. Hays
Kingston, WA
K7VE

 

f6bvp
 

Hi John,
Thanks for the link.
I followed instructions but could not log in to Draws-manager.
Here ifollows a complete report.

73's Bernard

systemctl status draws-manager
● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.
   Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-02-18 19:30:08 CET; 5min ago
     Docs: https://github.com/nwdigitalradio/draws-manager
  Process: 11521 ExecStart=/usr/bin/npm start (code=exited, status=1/FAILURE)
 Main PID: 11521 (code=exited, status=1/FAILURE)
 
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! errno 1
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! webapp@0.0.0 start: `node ./bin/www`
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! Exit status 1
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR!
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! Failed at the webapp@0.0.0 start script.
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! This is probably not a problem with npm. There is likely additional loggin
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! A complete log of this run can be found in:
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR!     /root/.npm/_logs/2020-02-18T18_30_08_039Z-debug.log
févr. 18 19:30:08 raspberrypi systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/FAILURE
févr. 18 19:30:08 raspberrypi systemd[1]: draws-manager.service: Failed with result 'exit-code'.
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager#  /root/.npm/_logs/2020-02-18T18_30_08_039Z-debug.log
bash: /root/.npm/_logs/2020-02-18T18_30_08_039Z-debug.log: Permission non accordée
root@raspberrypi:/home/pi/draws-manager# cat /root/.npm/_logs/2020-02-18T18_30_08_039Z-debug.log
0 info it worked if it ends with ok
1 warn npm npm does not support Node.js v10.15.2
2 warn npm You should probably upgrade to a newer version of node as we
3 warn npm can't make any promises that npm will work with this version.
4 warn npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
5 warn npm You can find the latest version at https://nodejs.org/
6 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
7 info using npm@5.8.0
8 info using node@...
9 verbose run-script [ 'prestart', 'start', 'poststart' ]
10 info lifecycle webapp@0.0.0~prestart: webapp@0.0.0
11 info lifecycle webapp@0.0.0~start: webapp@0.0.0
12 verbose lifecycle webapp@0.0.0~start: unsafe-perm in lifecycle true
13 verbose lifecycle webapp@0.0.0~start: PATH: /usr/share/npm/node_modules/npm-lifecycle/node-gyp-bin:/usr/local/var/draws-manager/webapp/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
14 verbose lifecycle webapp@0.0.0~start: CWD: /usr/local/var/draws-manager/webapp
15 silly lifecycle webapp@0.0.0~start: Args: [ '-c', 'node ./bin/www' ]
16 silly lifecycle webapp@0.0.0~start: Returned: code: 1  signal: null
17 info lifecycle webapp@0.0.0~start: Failed to exec start script
18 verbose stack Error: webapp@0.0.0 start: `node ./bin/www`
18 verbose stack Exit status 1
18 verbose stack     at EventEmitter.<anonymous> (/usr/share/npm/node_modules/npm-lifecycle/index.js:283:16)
18 verbose stack     at EventEmitter.emit (events.js:189:13)
18 verbose stack     at ChildProcess.<anonymous> (/usr/share/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
18 verbose stack     at ChildProcess.emit (events.js:189:13)
18 verbose stack     at maybeClose (internal/child_process.js:970:16)
18 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
19 verbose pkgid webapp@0.0.0
20 verbose cwd /usr/local/var/draws-manager/webapp
21 verbose Linux 4.19.93-v7l+
22 verbose argv "/usr/bin/node" "/usr/bin/npm" "start"
23 verbose node v10.15.2
24 verbose npm  v5.8.0
25 error code ELIFECYCLE
26 error errno 1
27 error webapp@0.0.0 start: `node ./bin/www`
27 error Exit status 1
28 error Failed at the webapp@0.0.0 start script.
28 error This is probably not a problem with npm. There is likely additional logging output above.
29 verbose exit [ 1, true ]
root@raspberrypi:/home/pi/draws-manager# 
 

 

What does this return:

ls -l /usr/local/var/draws-manager/webapp
ls -l /usr/local/var/draws-manager/webapp/bin



On Tue, Feb 18, 2020 at 10:40 AM f6bvp <f6bvp@...> wrote:
Hi John,
Thanks for the link.
I followed instructions but could not log in to Draws-manager.
Here ifollows a complete report.

73's Bernard

systemctl status draws-manager
● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.
   Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-02-18 19:30:08 CET; 5min ago
  Process: 11521 ExecStart=/usr/bin/npm start (code=exited, status=1/FAILURE)
 Main PID: 11521 (code=exited, status=1/FAILURE)
 
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! errno 1
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! webapp@0.0.0 start: `node ./bin/www`
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! Exit status 1
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR!
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! Failed at the webapp@0.0.0 start script.
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! This is probably not a problem with npm. There is likely additional loggin
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR! A complete log of this run can be found in:
févr. 18 19:30:08 raspberrypi npm[11521]: npm ERR!     /root/.npm/_logs/2020-02-18T18_30_08_039Z-debug.log
févr. 18 19:30:08 raspberrypi systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/FAILURE
févr. 18 19:30:08 raspberrypi systemd[1]: draws-manager.service: Failed with result 'exit-code'.
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager# 
root@raspberrypi:/home/pi/draws-manager#  /root/.npm/_logs/2020-02-18T18_30_08_039Z-debug.log
bash: /root/.npm/_logs/2020-02-18T18_30_08_039Z-debug.log: Permission non accordée
root@raspberrypi:/home/pi/draws-manager# cat /root/.npm/_logs/2020-02-18T18_30_08_039Z-debug.log
0 info it worked if it ends with ok
1 warn npm npm does not support Node.js v10.15.2
2 warn npm You should probably upgrade to a newer version of node as we
3 warn npm can't make any promises that npm will work with this version.
4 warn npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
5 warn npm You can find the latest version at https://nodejs.org/
6 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
7 info using npm@5.8.0
8 info using node@...
9 verbose run-script [ 'prestart', 'start', 'poststart' ]
10 info lifecycle webapp@0.0.0~prestart: webapp@0.0.0
11 info lifecycle webapp@0.0.0~start: webapp@0.0.0
12 verbose lifecycle webapp@0.0.0~start: unsafe-perm in lifecycle true
13 verbose lifecycle webapp@0.0.0~start: PATH: /usr/share/npm/node_modules/npm-lifecycle/node-gyp-bin:/usr/local/var/draws-manager/webapp/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
14 verbose lifecycle webapp@0.0.0~start: CWD: /usr/local/var/draws-manager/webapp
15 silly lifecycle webapp@0.0.0~start: Args: [ '-c', 'node ./bin/www' ]
16 silly lifecycle webapp@0.0.0~start: Returned: code: 1  signal: null
17 info lifecycle webapp@0.0.0~start: Failed to exec start script
18 verbose stack Error: webapp@0.0.0 start: `node ./bin/www`
18 verbose stack Exit status 1
18 verbose stack     at EventEmitter.<anonymous> (/usr/share/npm/node_modules/npm-lifecycle/index.js:283:16)
18 verbose stack     at EventEmitter.emit (events.js:189:13)
18 verbose stack     at ChildProcess.<anonymous> (/usr/share/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
18 verbose stack     at ChildProcess.emit (events.js:189:13)
18 verbose stack     at maybeClose (internal/child_process.js:970:16)
18 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
19 verbose pkgid webapp@0.0.0
20 verbose cwd /usr/local/var/draws-manager/webapp
21 verbose Linux 4.19.93-v7l+
22 verbose argv "/usr/bin/node" "/usr/bin/npm" "start"
23 verbose node v10.15.2
24 verbose npm  v5.8.0
25 error code ELIFECYCLE
26 error errno 1
27 error webapp@0.0.0 start: `node ./bin/www`
27 error Exit status 1
28 error Failed at the webapp@0.0.0 start script.
28 error This is probably not a problem with npm. There is likely additional logging output above.
29 verbose exit [ 1, true ]
root@raspberrypi:/home/pi/draws-manager# 
 



--
John D. Hays
Kingston, WA
K7VE

 

Basil Gunn
 

I do not see it on my nwdr15.img installed system.
draws-manager is installed & running by default on the nwdr15 image.
Verify draws-manager running like this:

systemctl status draws-manager.service

Run like this on a remote computer:

<ip-address-of-pi>:8080

or on a local RPi

localhost:8080

/Basil n7nix

Basil Gunn
 

I just burned and booted an nwdr15.img and draws-manager ran and worked
in both remote & local browser without doing anything further.

I then:

cd
cd n7nix
git pull
cd config
./bin_refresh.sh

sudo su
apt-get update
apt-get dist-upgrade

and after a reboot draws-manager again ran fine.

If you did something other than the above or attempted to install
draws-manager when it is already installed then that possibly could be
your problem.

/Basil n7nix


Basil Gunn <@basil860> writes:

I do not see it on my nwdr15.img installed system.
draws-manager is installed & running by default on the nwdr15 image.
Verify draws-manager running like this:

systemctl status draws-manager.service

Run like this on a remote computer:

<ip-address-of-pi>:8080

or on a local RPi

localhost:8080

/Basil n7nix

f6bvp
 

Hi Basil,
I performed all instructions you gave and rebooted.
However I could not connect to localhost:8080

Hi John,
Here it is :
root@raspberrypi:/home/pi# ls -l /usr/local/var/draws-manager/webapp
total 228
-rw-r--r--   1 root staff   3372 sept. 19 23:25 amixer.js
-rw-r--r--   1 root staff   1166 sept. 19 23:25 app.js
drwxr-sr-x   2 root staff   4096 sept. 19 23:25 bin
-rw-r--r--   1 root staff      0 févr. 18 18:33 draws-apps.json
-rw-r--r--   1 root staff   6111 sept. 19 23:25 io.js
-rw-r--r--   1 root staff   2593 sept. 19 23:25 mixerState.js
drwxr-sr-x 255 root staff  12288 sept. 28 22:02 node_modules
-rw-r--r--   1 root staff    506 sept. 19 23:25 package.json
-rw-r--r--   1 root staff 175710 sept. 19 23:29 package-lock.json
drwxr-sr-x   5 root staff   4096 sept. 19 23:25 public
-rw-r--r--   1 root staff   1254 sept. 19 23:25 radios.json
drwxr-sr-x   2 root staff   4096 sept. 19 23:25 routes
drwxr-sr-x   4 root staff   4096 sept. 19 23:25 views
root@raspberrypi:/home/pi# ls -l /usr/local/var/draws-manager/webapp/bin
total 4
-rwxr-xr-x 1 root staff 1905 sept. 19 23:25 www
root@raspberrypi:/home/pi# ls -l /usr/local/var/draws-manager/webapp/bin/
total 4
-rwxr-xr-x 1 root staff 1905 sept. 19 23:25 www

However, after doing a second time 
systemctl stop draws-manager.service
This time
systemctl status draws-manager.service
displayed : active running
but soon after it turns to active failed.

Here is the complete bebug log.
root@raspberrypi:/home/pi# systemctl status draws-manager
● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.
   Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-02-18 22:17:04 CET; 19s ago
     Docs: https://github.com/nwdigitalradio/draws-manager
  Process: 2795 ExecStart=/usr/bin/npm start (code=exited, status=1/FAILURE)
 Main PID: 2795 (code=exited, status=1/FAILURE)
 
févr. 18 22:17:04 raspberrypi npm[2795]: npm ERR! errno 1
févr. 18 22:17:04 raspberrypi npm[2795]: npm ERR! webapp@0.0.0 start: `node ./bin/www`
févr. 18 22:17:04 raspberrypi npm[2795]: npm ERR! Exit status 1
févr. 18 22:17:04 raspberrypi npm[2795]: npm ERR!
févr. 18 22:17:04 raspberrypi npm[2795]: npm ERR! Failed at the webapp@0.0.0 start script.
févr. 18 22:17:04 raspberrypi npm[2795]: npm ERR! This is probably not a problem with npm. There is likely a
févr. 18 22:17:04 raspberrypi npm[2795]: npm ERR! A complete log of this run can be found in:
févr. 18 22:17:04 raspberrypi npm[2795]: npm ERR!     /root/.npm/_logs/2020-02-18T21_17_04_429Z-debug.log
févr. 18 22:17:04 raspberrypi systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/
févr. 18 22:17:04 raspberrypi systemd[1]: draws-manager.service: Failed with result 'exit-code'.
root@raspberrypi:/home/pi# 
root@raspberrypi:/home/pi# 
root@raspberrypi:/home/pi# 
root@raspberrypi:/home/pi# 
root@raspberrypi:/home/pi# cat /root/.npm/_logs/2020-02-18T21_17_04_429Z-debug.log
0 info it worked if it ends with ok
1 warn npm npm does not support Node.js v10.15.2
2 warn npm You should probably upgrade to a newer version of node as we
3 warn npm can't make any promises that npm will work with this version.
4 warn npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
5 warn npm You can find the latest version at https://nodejs.org/
6 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
7 info using npm@5.8.0
8 info using node@...
9 verbose run-script [ 'prestart', 'start', 'poststart' ]
10 info lifecycle webapp@0.0.0~prestart: webapp@0.0.0
11 info lifecycle webapp@0.0.0~start: webapp@0.0.0
12 verbose lifecycle webapp@0.0.0~start: unsafe-perm in lifecycle true
13 verbose lifecycle webapp@0.0.0~start: PATH: /usr/share/npm/node_modules/npm-lifecycle/node-gyp-bin:/usr/local/var/draws-manager/webapp/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
14 verbose lifecycle webapp@0.0.0~start: CWD: /usr/local/var/draws-manager/webapp
15 silly lifecycle webapp@0.0.0~start: Args: [ '-c', 'node ./bin/www' ]
16 silly lifecycle webapp@0.0.0~start: Returned: code: 1  signal: null
17 info lifecycle webapp@0.0.0~start: Failed to exec start script
18 verbose stack Error: webapp@0.0.0 start: `node ./bin/www`
18 verbose stack Exit status 1
18 verbose stack     at EventEmitter.<anonymous> (/usr/share/npm/node_modules/npm-lifecycle/index.js:283:16)
18 verbose stack     at EventEmitter.emit (events.js:189:13)
18 verbose stack     at ChildProcess.<anonymous> (/usr/share/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
18 verbose stack     at ChildProcess.emit (events.js:189:13)
18 verbose stack     at maybeClose (internal/child_process.js:970:16)
18 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
19 verbose pkgid webapp@0.0.0
20 verbose cwd /usr/local/var/draws-manager/webapp
21 verbose Linux 4.19.97-v7l+
22 verbose argv "/usr/bin/node" "/usr/bin/npm" "start"
23 verbose node v10.15.2
24 verbose npm  v5.8.0
25 error code ELIFECYCLE
26 error errno 1
27 error webapp@0.0.0 start: `node ./bin/www`
27 error Exit status 1
28 error Failed at the webapp@0.0.0 start script.
28 error This is probably not a problem with npm. There is likely additional logging output above.
29 verbose exit [ 1, true ]
 
As I do not need presently that Draws-manager I will not take your time and will wait for a fresh install when I get the opportunity or need to do so. Everything else is doing well presently.

73 de Bernard
Thanks both for your help.