app_config.sh core


Steve, N9VW
 

Basil,
You may not recall but early on with the DRAWS board I discovered an issue with the script not setting the IP addresses that the user selected. It always reverted back to 192.168.... default addresses. You found the issue somewhere back in release 11 or so where after running the user setup the next command wrote over it with the defaults. It's back...

Screen captures of the sessions:
=== Set ip addresses on AX.25 interfaces
Current AX.25 ip addresses: ax0: 192.168.255.2, ax1: 192.168.255.3
If you do not understand or care about the following just hit enter for default values
Enter ip address for AX.25 interface ax0 followed by [enter]: 172.24.54.2
Verifying ip address: 172.24.54.2
Verifying ip address ret: 0
Valid ip address: 172.24.54.2
Setting ax0 to 172.24.54.2
Enter ip address for AX.25 interface ax1 followed by [enter]: 172.24.54.3
Verifying ip address: 172.24.54.3
Verifying ip address ret: 0
Valid ip address: 172.24.54.3
Setting ax1 to 172.24.54.3

    before:

ax25_ipaddr[0]="192.168.255.2"
ax25_ipaddr[1]="192.168.255.3"

    after:

ax25_ipaddr[0]="172.24.54.2"
ax25_ipaddr[1]="172.24.54.3"
=== FINISHED Setting up ip addresses for AX.25 interfaces
200 OK
2021 01 30 18:43:31 PST: app_config.sh: core config script FINISHED



Rebooted:
Enabled AX25
Rebooted:

pi@DRAWS-1:~ $ ax25-status
Status for direwolf.service: RUNNING and ENABLED
Status for ax25dev.service: RUNNING and ENABLED
Status for ax25dev.path: RUNNING and ENABLED
Status for ax25-mheardd.service: RUNNING and ENABLED
Status for ax25d.service: RUNNING and ENABLED
AX.25 device: ax0 successfully configured with ip: 192.168.255.2
AX.25 device: ax1 successfully configured with ip: 192.168.255.3
Direwolf is running with pid of 538
port: 0, speed: 1200, slottime: 200, txdelay: 500, t1 timeout: 3000, t2 timeout: 1000
port: 1, speed: 1200, slottime: 200, txdelay: 500, t1 timeout: 3000, t2 timeout: 1000
Device: ax0 exists, Device: ax1 exists
Happy Trails,
Steve, N9VW


Basil Gunn
 

Which image are you using?
head -n 1 /var/log/udr_install.log

Steve, N9VW <steve@vanwambeck.net> writes:

It always reverted back to 192.168.... default addresses. You
found the issue somewhere back in release 11 or so where after running
the user setup the next command wrote over it with the defaults. It's
back...


Steve, N9VW
 

2021 01 23 09:46:30 PST: SD image version: nwdr19

On 1/31/2021 3:09 PM, Basil Gunn wrote:
Which image are you using?
head -n 1 /var/log/udr_install.log

Steve, N9VW <steve@vanwambeck.net> writes:

It always reverted back to 192.168.... default addresses. You
found the issue somewhere back in release 11 or so where after running
the user setup the next command wrote over it with the defaults. It's
back...


Basil Gunn
 

Yes, thanks I confirmed this problem in NWDR19. The /etc/ax25/port.conf
file contains the two AX.25 IP addresses. If you need to change them
just edit that file. The app_config.sh core script should be fixed with
a recent commit.

1. Work around is to edit /etc/ax25/port.conf and run ax25-restart
2. core_config.sh script fixed ip_address problem with this commit:
https://github.com/nwdigitalradio/n7nix/commit/fe73b4c57d1e01ef74f8a0d1a644d91807452845

To get latest commit:
cd
cd n7nix
git pull
cd config
./bin_refresh.sh


Steve, N9VW <steve@vanwambeck.net> writes:

Basil,
You may not recall but early on with the DRAWS board I discovered an
issue with the script not setting the IP addresses that the user
selected. It always reverted back to 192.168.... default addresses. You
found the issue somewhere back in release 11 or so where after running
the user setup the next command wrote over it with the defaults. It's
back...

Screen captures of the sessions:

=== Set ip addresses on AX.25 interfaces
Current AX.25 ip addresses: ax0: 192.168.255.2, ax1: 192.168.255.3
If you do not understand or care about the following just hit enter
for default values
Enter ip address for AX.25 interface ax0 followed by [enter]:
172.24.54.2
Verifying ip address: 172.24.54.2
Verifying ip address ret: 0
Valid ip address: 172.24.54.2
Setting ax0 to 172.24.54.2
Enter ip address for AX.25 interface ax1 followed by [enter]:
172.24.54.3
Verifying ip address: 172.24.54.3
Verifying ip address ret: 0
Valid ip address: 172.24.54.3
Setting ax1 to 172.24.54.3

before:

ax25_ipaddr[0]="192.168.255.2"
ax25_ipaddr[1]="192.168.255.3"

after:

ax25_ipaddr[0]="172.24.54.2"
ax25_ipaddr[1]="172.24.54.3"
=== FINISHED Setting up ip addresses for AX.25 interfaces
200 OK
2021 01 30 18:43:31 PST: app_config.sh: core config script FINISHED



Rebooted:
Enabled AX25
Rebooted:

pi@DRAWS-1:~ $ ax25-status
Status for direwolf.service: RUNNING and ENABLED
Status for ax25dev.service: RUNNING and ENABLED
Status for ax25dev.path: RUNNING and ENABLED
Status for ax25-mheardd.service: RUNNING and ENABLED
Status for ax25d.service: RUNNING and ENABLED
AX.25 device: ax0 successfully configured with ip: 192.168.255.2
AX.25 device: ax1 successfully configured with ip: 192.168.255.3
Direwolf is running with pid of 538
port: 0, speed: 1200, slottime: 200, txdelay: 500, t1 timeout: 3000,
t2 timeout: 1000
port: 1, speed: 1200, slottime: 200, txdelay: 500, t1 timeout: 3000,
t2 timeout: 1000
Device: ax0 exists, Device: ax1 exists

Happy Trails,
Steve, N9VW




Steve, N9VW
 

Great, thanks Basil...!

/SvW

On 1/31/2021 4:12 PM, Basil Gunn wrote:
Yes, thanks I confirmed this problem in NWDR19. The /etc/ax25/port.conf
file contains the two AX.25 IP addresses. If you need to change them
just edit that file. The app_config.sh core script should be fixed with
a recent commit.

1. Work around is to edit /etc/ax25/port.conf and run ax25-restart
2. core_config.sh script fixed ip_address problem with this commit:
https://github.com/nwdigitalradio/n7nix/commit/fe73b4c57d1e01ef74f8a0d1a644d91807452845

To get latest commit:
cd
cd n7nix
git pull
cd config
./bin_refresh.sh


Steve, N9VW <steve@vanwambeck.net> writes:

Basil,
You may not recall but early on with the DRAWS board I discovered an
issue with the script not setting the IP addresses that the user
selected. It always reverted back to 192.168.... default addresses. You
found the issue somewhere back in release 11 or so where after running
the user setup the next command wrote over it with the defaults. It's
back...

Screen captures of the sessions:

=== Set ip addresses on AX.25 interfaces
Current AX.25 ip addresses: ax0: 192.168.255.2, ax1: 192.168.255.3
If you do not understand or care about the following just hit enter
for default values
Enter ip address for AX.25 interface ax0 followed by [enter]:
172.24.54.2
Verifying ip address: 172.24.54.2
Verifying ip address ret: 0
Valid ip address: 172.24.54.2
Setting ax0 to 172.24.54.2
Enter ip address for AX.25 interface ax1 followed by [enter]:
172.24.54.3
Verifying ip address: 172.24.54.3
Verifying ip address ret: 0
Valid ip address: 172.24.54.3
Setting ax1 to 172.24.54.3

before:

ax25_ipaddr[0]="192.168.255.2"
ax25_ipaddr[1]="192.168.255.3"

after:

ax25_ipaddr[0]="172.24.54.2"
ax25_ipaddr[1]="172.24.54.3"
=== FINISHED Setting up ip addresses for AX.25 interfaces
200 OK
2021 01 30 18:43:31 PST: app_config.sh: core config script FINISHED



Rebooted:
Enabled AX25
Rebooted:

pi@DRAWS-1:~ $ ax25-status
Status for direwolf.service: RUNNING and ENABLED
Status for ax25dev.service: RUNNING and ENABLED
Status for ax25dev.path: RUNNING and ENABLED
Status for ax25-mheardd.service: RUNNING and ENABLED
Status for ax25d.service: RUNNING and ENABLED
AX.25 device: ax0 successfully configured with ip: 192.168.255.2
AX.25 device: ax1 successfully configured with ip: 192.168.255.3
Direwolf is running with pid of 538
port: 0, speed: 1200, slottime: 200, txdelay: 500, t1 timeout: 3000,
t2 timeout: 1000
port: 1, speed: 1200, slottime: 200, txdelay: 500, t1 timeout: 3000,
t2 timeout: 1000
Device: ax0 exists, Device: ax1 exists

Happy Trails,
Steve, N9VW