Pat ARDOP configure issues #pat #rigctld


KI5EVJ - Richard
 

Trying to set up Pat following the KM4ACK videos and descriptions listed here. ARDOP loads, rigctld gives the error below Pat http loads but says it can't get the frequency from rigctld. I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the /dev/ folder so I must have missed something somewhere.

pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
rig_open: error = IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6) 
pi@draws:~ $ 

Suggestions, please
Richard KI5EVJ


 

What are you using as your CAT control cable?   Usually something like


On Sun, Jul 11, 2021, 11:30 Richard Gilbert via groups.io <rpgilbert1=verizon.net@groups.io> wrote:
Trying to set up Pat following the KM4ACK videos and descriptions listed here. ARDOP loads, rigctld gives the error below Pat http loads but says it can't get the frequency from rigctld. I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the /dev/ folder so I must have missed something somewhere.

pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
rig_open: error = IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6) 
pi@draws:~ $ 

Suggestions, please
Richard KI5EVJ


Basil Gunn
 

Trying to set up Pat following the KM4ACK videos and descriptions
listed here
. ARDOP loads, rigctld gives the error below
port_open: serial_open status=-6
errno 6 is No such device or address

Pat http loads but says it can't get the frequency from rigctld.
Because rigctld is not running

I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the
/dev/ folder so I must have missed something somewhere.
Do this to see if the device is enumerated at some other USB number

ls /dev/ttyUSB*

Either you are using the wrong device name (ie. could be /dev/ttyUSB1)
OR you don't have the CAT cable for your FT-818ND plugged into the radio
or RPi.

If the above command comes back like this:
ls /dev/ttyUSB*
ls: cannot access '/dev/ttyUSB*': No such file or directory

then you don't have a CAT cable for your radio.

Yaesu USB FTDI CT-62 CAT Cable FT-818,
https://www.amazon.com/gp/product/B0035DV1ZM/ref=ask_ql_qh_dp_hza

pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
rig_open: error = IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6)


KI5EVJ - Richard
 

I am using the 6-pin cable that came with the DRAWS plugged into the right socket on the hat and the data port on the 818.

On Jul 11, 2021, at 2:02 PM, Basil Gunn <basil@pacabunga.com> wrote:



Trying to set up Pat following the KM4ACK videos and descriptions
listed here
. ARDOP loads, rigctld gives the error below
port_open: serial_open status=-6
errno 6 is No such device or address

Pat http loads but says it can't get the frequency from rigctld.
Because rigctld is not running

I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the
/dev/ folder so I must have missed something somewhere.
Do this to see if the device is enumerated at some other USB number

ls /dev/ttyUSB*

Either you are using the wrong device name (ie. could be /dev/ttyUSB1)
OR you don't have the CAT cable for your FT-818ND plugged into the radio
or RPi.

If the above command comes back like this:
ls /dev/ttyUSB*
ls: cannot access '/dev/ttyUSB*': No such file or directory

then you don't have a CAT cable for your radio.

Yaesu USB FTDI CT-62 CAT Cable FT-818,
https://www.amazon.com/gp/product/B0035DV1ZM/ref=ask_ql_qh_dp_hza

pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
rig_open: error = IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6)




KI5EVJ - Richard
 

/dev/tyyUSB* no such file or directory

On Jul 11, 2021, at 2:53 PM, RICHARD GILBERT <rpgilbert1@verizon.net> wrote:

I am using the 6-pin cable that came with the DRAWS plugged into the right socket on the hat and the data port on the 818.

Sent from my iPhone

On Jul 11, 2021, at 2:02 PM, Basil Gunn <basil@pacabunga.com> wrote:



Trying to set up Pat following the KM4ACK videos and descriptions
listed here
. ARDOP loads, rigctld gives the error below
port_open: serial_open status=-6
errno 6 is No such device or address

Pat http loads but says it can't get the frequency from rigctld.
Because rigctld is not running

I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the
/dev/ folder so I must have missed something somewhere.
Do this to see if the device is enumerated at some other USB number

ls /dev/ttyUSB*

Either you are using the wrong device name (ie. could be /dev/ttyUSB1)
OR you don't have the CAT cable for your FT-818ND plugged into the radio
or RPi.

If the above command comes back like this:
ls /dev/ttyUSB*
ls: cannot access '/dev/ttyUSB*': No such file or directory

then you don't have a CAT cable for your radio.

Yaesu USB FTDI CT-62 CAT Cable FT-818,
https://www.amazon.com/gp/product/B0035DV1ZM/ref=ask_ql_qh_dp_hza

pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
rig_open: error = IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6)




KI5EVJ - Richard
 

Viola! Helps to used the correct cable. USB0 is there 😂😋
Thanks
Richard

On Jul 11, 2021, at 2:55 PM, Richard Gilbert via groups.io <rpgilbert1=verizon.net@groups.io> wrote:

/dev/tyyUSB* no such file or directory
On Jul 11, 2021, at 2:53 PM, RICHARD GILBERT <rpgilbert1@verizon.net> wrote:

I am using the 6-pin cable that came with the DRAWS plugged into the right socket on the hat and the data port on the 818.

Sent from my iPhone

On Jul 11, 2021, at 2:02 PM, Basil Gunn <basil@pacabunga.com> wrote:


Trying to set up Pat following the KM4ACK videos and descriptions
listed here
. ARDOP loads, rigctld gives the error below
port_open: serial_open status=-6
errno 6 is No such device or address

Pat http loads but says it can't get the frequency from rigctld.
Because rigctld is not running

I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the
/dev/ folder so I must have missed something somewhere.
Do this to see if the device is enumerated at some other USB number

ls /dev/ttyUSB*

Either you are using the wrong device name (ie. could be /dev/ttyUSB1)
OR you don't have the CAT cable for your FT-818ND plugged into the radio
or RPi.

If the above command comes back like this:
ls /dev/ttyUSB*
ls: cannot access '/dev/ttyUSB*': No such file or directory

then you don't have a CAT cable for your radio.

Yaesu USB FTDI CT-62 CAT Cable FT-818,
https://www.amazon.com/gp/product/B0035DV1ZM/ref=ask_ql_qh_dp_hza

pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
rig_open: error = IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6)








KI5EVJ - Richard
 

Ok so rigctld worked but when I started Pat http it came back with “818NDready. Dial frequency is 145.000.00. Does Ardop work on 2m?
Then “bind: address already in use”
Not sure what is happening here.
Richard

On Jul 11, 2021, at 3:06 PM, Richard Gilbert via groups.io <rpgilbert1=verizon.net@groups.io> wrote:

Viola! Helps to used the correct cable. USB0 is there 😂😋
Thanks
Richard
On Jul 11, 2021, at 2:55 PM, Richard Gilbert via groups.io <rpgilbert1=verizon.net@groups.io> wrote:

/dev/tyyUSB* no such file or directory
On Jul 11, 2021, at 2:53 PM, RICHARD GILBERT <rpgilbert1@verizon.net> wrote:
I am using the 6-pin cable that came with the DRAWS plugged into the right socket on the hat and the data port on the 818.

Sent from my iPhone

On Jul 11, 2021, at 2:02 PM, Basil Gunn <basil@pacabunga.com> wrote:


Trying to set up Pat following the KM4ACK videos and descriptions
listed here
. ARDOP loads, rigctld gives the error below
port_open: serial_open status=-6
errno 6 is No such device or address

Pat http loads but says it can't get the frequency from rigctld.
Because rigctld is not running

I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the
/dev/ folder so I must have missed something somewhere.
Do this to see if the device is enumerated at some other USB number

ls /dev/ttyUSB*

Either you are using the wrong device name (ie. could be /dev/ttyUSB1)
OR you don't have the CAT cable for your FT-818ND plugged into the radio
or RPi.

If the above command comes back like this:
ls /dev/ttyUSB*
ls: cannot access '/dev/ttyUSB*': No such file or directory

then you don't have a CAT cable for your radio.

Yaesu USB FTDI CT-62 CAT Cable FT-818,
https://www.amazon.com/gp/product/B0035DV1ZM/ref=ask_ql_qh_dp_hza

pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
rig_open: error = IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6)












 

Richard,

As you are discovering.  The 6 pin socket on the DRAWS™ carries audio in/out as well as PTT (and SQL, but the SQL pin can be a problem on Yaesu radios) to the matching data port (4).  To do computer control of the radio, eg. set frequency, command style PTT, etc. you use the accessory port (5) with a USB cable. From page 15 of the Yaesu manual.

image.png
image.png

On the 'Data' jack.  The data out 1200bps is de-emphasized audio (like speaker audio) from the radio, the data out 9600bps is raw output from the discriminator (in FM/Packet mode).  Data in goes straight to the modulator. 

On Sun, Jul 11, 2021 at 12:55 PM Richard Gilbert via groups.io <rpgilbert1=verizon.net@groups.io> wrote:
/dev/tyyUSB* no such file or directory
> On Jul 11, 2021, at 2:53 PM, RICHARD GILBERT <rpgilbert1@...> wrote:
>
> I am using the 6-pin cable that came with the DRAWS plugged into the right socket on the hat and the data port on the 818.
>
> Sent from my iPhone
>
>> On Jul 11, 2021, at 2:02 PM, Basil Gunn <basil@...> wrote:
>>
>> 
>>
>>> Trying to set up Pat following the KM4ACK videos and descriptions
>>> listed here
>>> . ARDOP loads, rigctld gives the error below
>>> port_open: serial_open status=-6
>>
>> errno 6 is No such device or address
>>
>>> Pat http loads but says it can't get the frequency from rigctld.
>>
>> Because rigctld is not running
>>
>>> I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the
>>> /dev/ folder so I must have missed something somewhere.
>>
>> Do this to see if the device is enumerated at some other USB number
>>
>> ls /dev/ttyUSB*
>>
>> Either you are using the wrong device name (ie. could be /dev/ttyUSB1)
>> OR you don't have the CAT cable for your FT-818ND plugged into the radio
>> or RPi.
>>
>> If the above command comes back like this:
>> ls /dev/ttyUSB*
>> ls: cannot access '/dev/ttyUSB*': No such file or directory
>>
>> then you don't have a CAT cable for your radio.
>>
>> Yaesu USB FTDI CT-62 CAT Cable FT-818,
>> https://www.amazon.com/gp/product/B0035DV1ZM/ref=ask_ql_qh_dp_hza
>>
>>> pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
>>> rig_open: error = IO error
>>> port_open: serial_open status=-6
>>> iofunc.c(80):port_open return(-6)
>>> rig.c(773):rig_open return(-6)
>>
>>
>>
>>
>>








--
John D. Hays
Kingston, WA
K7VE / WRJT-215