Topics

Can't access Draws Manager


 

Tried updating FLdigi and was unsuccessful and realized the Draws Manager program was not accessible anymore. Does anyone know if there is a way to access it? Draws manager that is, old fldigi version seems still intact.
Thanks,
Todd
AL7PX 


Basil Gunn
 

Regarding DRAWS manager: at the bottom of this post you will find your
answer. https://nw-digital-radio.groups.io/g/udrc/message/5111

DRAWS manager will not work properly on kernel versions newer than
4.19.118 ie. if you have done any upgrades the current Raspberry Pi OS
kernel is 5.4.51-v7l+ #1333

Do NOT run draws-manager web app as it needs some work to be
compatible with the new sensors driver. The NWDR17 image has the
draws-manager daemon disabled.
Tried updating FLdigi and was unsuccessful
How did you try to update FLdigi?
Show the console output of:

cd
cd n7nix/hfprogs
./hf_verchk.sh -u

# Then verify

./hf_verchk.sh
js8call: current version: 2.2.0, installed: 2.2.0
wsjtx: current version: 2.2.2, installed: 2.2.2
Library: libflxmlrpc IS loaded.
flxmlrpc: current version: 0.1.4, installed: 0.1.4
fldigi: current version: 4.1.14, installed: 4.1.14
flrig: current version: 1.3.51, installed: 1.3.51
flmsg: current version: 4.0.16, installed: 4.0.16
flamp: current version: 2.2.05, installed: 2.2.05
fllog: current version: 1.2.6, installed: 1.2.6

Todd via groups.io <ic7461=yahoo.com@groups.io> writes:

Tried updating FLdigi and was unsuccessful and realized the Draws
Manager program was not accessible anymore. Does anyone know if there
is a way to access it? Draws manager that is, old fldigi version seems
still intact. Thanks, Todd AL7PX


 

Hello Basil: Current versions.

pi@radiopi:~/n7nix/hfprogs $ ./hf_verchk.sh
js8call: current version: 2.2.0-ga, installed: 1.0.0-rc3
wsjtx:   current version: , installed: 2.0.1
Library: libflxmlrpc IS loaded.
flxmlrpc:  current version: 0.1.4, installed: 0.1.4
fldigi:  current version: 4.1.14, installed: 4.1.01
flrig:  current version: 1.3.51, installed: 1.3.42
flmsg:  current version: 4.0.16, installed: 4.0.8
flamp:  current version: 2.2.05, installed: 2.2.04

Todd
AL7PX


Basil Gunn
 

In a console do the following:

cd
cd n7nix
git pull
cd hfprogs
./hf_verchk.sh -u

# then to verify
./hf_verchk.sh

If you have problems I will need to see all the console output.

Todd via groups.io <ic7461=yahoo.com@groups.io> writes:

Hello Basil: Current versions.

pi@radiopi:~/n7nix/hfprogs $ ./hf_verchk.sh
js8call: current version: 2.2.0-ga, installed: 1.0.0-rc3
wsjtx: current version: , installed: 2.0.1
Library: libflxmlrpc IS loaded.
flxmlrpc: current version: 0.1.4, installed: 0.1.4
fldigi: current version: 4.1.14, installed: 4.1.01
flrig: current version: 1.3.51, installed: 1.3.42
flmsg: current version: 4.0.16, installed: 4.0.8
flamp: current version: 2.2.05, installed: 2.2.04

Todd
AL7PX


 

Hello Basil:
Linux radiopi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux

2020 08 31 10:23:02 AKDT: hf_install.sh: HF program (flmsg) install script FINISHED
 
flamp:  current version: 2.2.05, installed: 2.2.05
        version is current
fllog:  current version: 1.2.6, installed: 1.2.6
        version is current
 
2020 08 31 10:23:03 AKDT: hf_verchk.sh: hf program update script FINISHED
 
root@radiopi:/home/pi/n7nix/hfprogs# ./hf_verchk.sh
js8call: current version: 2.2.0, installed: 2.2.0
wsjtx:   current version: 2.2.2, installed: 2.2.2
Library: libflxmlrpc IS loaded.
flxmlrpc:  current version: 0.1.4, installed: 0.1.4
fldigi:  current version: 4.1.14, installed: 4.1.14
flrig:  current version: 1.3.51, installed: 1.3.51
flmsg:  current version: 4.0.16, installed: 4.0.8
flamp:  current version: 2.2.05, installed: 2.2.05
fllog:  current version: 1.2.6, installed: 1.2.6
root@radiopi:/home/pi/n7nix/hfprogs# 
Completed the version check for the programs. All match, but still can't get DRAWS Manager to come up in the browser localhost8080. 
Todd
AL7PX


Basil Gunn
 

Since you are running an older kernel the following might work to start
DRAWS manager otherwise my previous answer holds.

cd
cd n7nix/config
./bin_refresh.sh

manager-sysd.sh status
manager-sysd.sh start
manager-sysd.sh status

Send me the console output of above.

Previous answer:
Regarding DRAWS manager: at the bottom of this post you will find your
answer. https://nw-digital-radio.groups.io/g/udrc/message/5111
Completed the version check for the programs. All match,
This isn't true, I am interested in why flmsg didn't get updated.
I put some error checking in a new fl apps install script and wonder if
you would please run it and post the console output.

cd
cd n7nix
git pull
cd hfprogs
./hf_install.sh pi flmsg 4.0.16
./hf_verchk.sh


Todd via groups.io <ic7461=yahoo.com@groups.io> writes:

Hello Basil:
Linux radiopi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux

2020 08 31 10:23:02 AKDT: hf_install.sh: HF program (flmsg) install script FINISHED
2020 08 31 10:23:03 AKDT: hf_verchk.sh: hf program update script FINISHED

flmsg: current version: 4.0.16, installed: 4.0.8


 

First set Commands output:

pi@radiopi:~/n7nix/config $ ./bin_refresh.sh
 Updating local bin directory for user: pi
Already up-to-date.
 
FINISHED copying desktop files
 
FINISHED copying bin files
 
FINISHED copying AX.25 files
script: /home/pi/bin/sensor_update.sh found
Incorrect sensor config file found ... replacing.
Making sensor config file based on this version of DRAWS hat
Product ver: 0x0405, Assembly rev: 4, fab rev: 5
5V not connected to DRAWS A/D
 
FINISHED updating sensor config file


Second set of commands:  manager-sysd.sh status

pi@radiopi:~/n7nix/config $ manager-sysd.sh status
Systemd draws-manager.service is enabled
● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.
   Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2020-08-31 12:04:53 AKDT; 30min ago
     Docs: https://github.com/nwdigitalradio/draws-manager
 Main PID: 12818 (code=exited, status=1/FAILURE)
 
Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read
Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian
Aug 31 12:04:53 radiopi npm[12818]:  
Aug 31 12:04:53 radiopi npm[12818]: npm ERR!
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! Additional logging details can be found in:
Aug 31 12:04:53 radiopi npm[12818]: npm ERR!     /usr/local/var/draws-manager/webapp…g.log
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! not ok code 0
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Main process exited, code…ILURE
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Unit entered failed state.
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! You can get their info via:
Aug 31 12:04:53 radiopi npm[12818]: npm ERR!     npm owner ls webapp
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! There is likely additional logging output above.
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! System Linux 4.14.98-v7+
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! command "/usr/bin/node" "/usr/bin/npm" "start"
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! cwd /usr/local/var/draws-manager/webapp
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! node -v v8.11.1
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! npm -v 1.4.21
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! code ELIFECYCLE
Aug 31 12:04:53 radiopi npm[12818]: npm WARN This failure might be due to the use of legacy binary "node"
Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read
Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian
Aug 31 12:04:53 radiopi npm[12818]:  
Aug 31 12:04:53 radiopi npm[12818]: npm ERR!
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! Additional logging details can be found in:
Aug 31 12:04:53 radiopi npm[12818]: npm ERR!     /usr/local/var/draws-manager/webapp/npm-debug.log
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! not ok code 0
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/FAILURE
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Unit entered failed state.
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Failed with result 'exit-code'.

Last 2 commands:

pi@radiopi:~/n7nix/config $ manager-sysd.sh start

pi@radiopi:~/n7nix/config $ manager-sysd.sh status

Systemd draws-manager.service is enabled

● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.

   Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)

   Active: failed (Result: exit-code) since Mon 2020-08-31 12:04:53 AKDT; 37min ago

Condition: start condition failed at Mon 2020-08-31 12:41:50 AKDT; 38s ago

           └─ ConditionPathExists=/proc/asound/udrc was not met

     Docs: https://github.com/nwdigitalradio/draws-manager

 Main PID: 12818 (code=exited, status=1/FAILURE)

 

Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read

Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian

Aug 31 12:04:53 radiopi npm[12818]:  

Aug 31 12:04:53 radiopi npm[12818]: npm ERR!

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! Additional logging details can be found in:

Aug 31 12:04:53 radiopi npm[12818]: npm ERR!     /usr/local/var/draws-manager/webapp…g.log

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! not ok code 0

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Main process exited, code…ILURE

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Unit entered failed state.

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Failed with result 'exit-code'.

Hint: Some lines were ellipsized, use -l to show in full.

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! You can get their info via:

Aug 31 12:04:53 radiopi npm[12818]: npm ERR!     npm owner ls webapp

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! There is likely additional logging output above.

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! System Linux 4.14.98-v7+

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! command "/usr/bin/node" "/usr/bin/npm" "start"

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! cwd /usr/local/var/draws-manager/webapp

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! node -v v8.11.1

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! npm -v 1.4.21

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! code ELIFECYCLE

Aug 31 12:04:53 radiopi npm[12818]: npm WARN This failure might be due to the use of legacy binary "node"

Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read

Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian

Aug 31 12:04:53 radiopi npm[12818]:  

Aug 31 12:04:53 radiopi npm[12818]: npm ERR!

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! Additional logging details can be found in:

Aug 31 12:04:53 radiopi npm[12818]: npm ERR!     /usr/local/var/draws-manager/webapp/npm-debug.log

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! not ok code 0

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/FAILURE

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Unit entered failed state.

 

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Failed with result 'exit-code'.

 


 

Basil:  
This isn't true, I am interested in why flmsg didn't get updated.
I put some error checking in a new fl apps install script and wonder if
you would please run it and post the console output.

cd
cd n7nix
git pull
cd hfprogs
./hf_install.sh pi flmsg 4.0.16
./hf_verchk.sh

Output:
2020 08 31 13:00:04 AKDT: hf_install.sh: HF program (flmsg) install script FINISHED pi@radiopi:~/n7nix/hfprogs $ ./hfverchk.sh bash: ./hfverchk.sh: No such file or directory pi@radiopi:~/n7nix/hfprogs $ ./hf_verchk.sh /tmp/js8call_changelog.txt: Permission denied Failed getting js8call changelog needed for version check. wsjtx: current version: 2.2.2, installed: 2.2.2 Library: libflxmlrpc IS loaded. flxmlrpc: current version: 0.1.4, installed: 0.1.4 fldigi: current version: 4.1.14, installed: 4.1.14 flrig: current version: 1.3.51, installed: 1.3.51 flmsg: current version: 4.0.16, installed: 4.0.8 flamp: current version: 2.2.05, installed: 2.2.05 fllog: current version: 1.2.6, installed: 1.2.6
 


Basil Gunn
 

Not seeing where you ran:
./hf_install.sh pi flmsg 4.0.16

I need all the console output of this command to see where it is failing.

Also : /tmp/js8call_changelog.txt: Permission denied
I have no idea how this is possible.

Get rid of the /tmp/js8call_changelog.txt file by deleting or a re-boot
will also clear the /tmp directory.


Todd via groups.io <ic7461=yahoo.com@groups.io> writes:

Basil:
This isn't true, I am interested in why flmsg didn't get updated.
I put some error checking in a new fl apps install script and wonder if
you would please run it and post the console output.

cd
cd n7nix
git pull
cd hfprogs
./hf_install.sh pi flmsg 4.0.16
./hf_verchk.sh
Would be nice if you didn't get rid of the line terminator when posting
console output.

*Output:
* 2020 08 31 13:00:04 AKDT: hf_install.sh:
HF program (flmsg) install script FINISHED
pi@radiopi:~/n7nix/hfprogs

$ ./hfverchk.sh
bash: ./hfverchk.sh: No such file or directory

pi@radiopi:~/n7nix/hfprogs $ ./hf_verchk.sh
/tmp/js8call_changelog.txt: Permission denied
Failed getting js8call changelog needed for version check.

wsjtx: current version: 2.2.2, installed: 2.2.2
Library: libflxmlrpc IS loaded.
flxmlrpc: current version: 0.1.4, installed: 0.1.4
fldigi: current version: 4.1.14, installed: 4.1.14
flrig: current version: 1.3.51, installed: 1.3.51
*flmsg: current version: 4.0.16, installed: 4.0.8*
flamp: current version: 2.2.05, installed: 2.2.05
fllog: current version: 1.2.6, installed: 1.2.6


Basil Gunn
 

John K7VE needs to take a look at your output.
You could verify that the sensor file was updated properly by running:

sensor_update.sh -s

Todd via groups.io <ic7461=yahoo.com@groups.io> writes:

----------------------------
*First set Commands output:*
----------------------------

pi@radiopi:~/n7nix/config $ ./bin_refresh.sh
Updating local bin directory for user: pi
Already up-to-date.

FINISHED copying desktop files

FINISHED copying bin files

FINISHED copying AX.25 files
script: /home/pi/bin/sensor_update.sh found
Incorrect sensor config file found ... replacing.
Making sensor config file based on this version of DRAWS hat
Product ver: 0x0405, Assembly rev: 4, fab rev: 5
5V not connected to DRAWS A/D

FINISHED updating sensor config file

------------------------------------------------

*Second set of commands: manager-sysd.sh status*

------------------------------------------------

pi@radiopi:~/n7nix/config $ manager-sysd.sh status
Systemd draws-manager.service is enabled
● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.
Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2020-08-31 12:04:53 AKDT; 30min ago
Docs: https://github.com/nwdigitalradio/draws-manager
Main PID: 12818 (code=exited, status=1/FAILURE)

Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read
Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian
Aug 31 12:04:53 radiopi npm[12818]:
Aug 31 12:04:53 radiopi npm[12818]: npm ERR!
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! Additional logging details can be found in:
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! /usr/local/var/draws-manager/webapp…g.log
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! not ok code 0
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Main process exited, code…ILURE
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Unit entered failed state.
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! You can get their info via:
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! npm owner ls webapp
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! There is likely additional logging output above.
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! System Linux 4.14.98-v7+
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! command "/usr/bin/node" "/usr/bin/npm" "start"
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! cwd /usr/local/var/draws-manager/webapp
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! node -v v8.11.1
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! npm -v 1.4.21
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! code ELIFECYCLE
Aug 31 12:04:53 radiopi npm[12818]: npm WARN This failure might be due to the use of legacy binary "node"
Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read
Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian
Aug 31 12:04:53 radiopi npm[12818]:
Aug 31 12:04:53 radiopi npm[12818]: npm ERR!
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! Additional logging details can be found in:
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! /usr/local/var/draws-manager/webapp/npm-debug.log
Aug 31 12:04:53 radiopi npm[12818]: npm ERR! not ok code 0
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/FAILURE
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Unit entered failed state.
Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Failed with result 'exit-code'.

******************
*Last 2 commands:*
******************

pi@radiopi:~/n7nix/config $ manager-sysd.sh start
-------------------------------------------------

pi@radiopi:~/n7nix/config $ manager-sysd.sh status
--------------------------------------------------

Systemd draws-manager.service is enabled
----------------------------------------

● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.
---------------------------------------------------------------------------------------------------

Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)
-------------------------------------------------------------------------------------------

Active: failed (Result: exit-code) since Mon 2020-08-31 12:04:53 AKDT; 37min ago
--------------------------------------------------------------------------------

Condition: start condition failed at Mon 2020-08-31 12:41:50 AKDT; 38s ago
--------------------------------------------------------------------------

└─ ConditionPathExists=/proc/asound/udrc was not met
----------------------------------------------------

Docs: https://github.com/nwdigitalradio/draws-manager
-----------------------------------------------------

Main PID: 12818 (code=exited, status=1/FAILURE)
-----------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read
----------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian
-----------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]:
-----------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR!
--------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! Additional logging details can be found in:
----------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! /usr/local/var/draws-manager/webapp…g.log
------------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! not ok code 0
----------------------------------------------------------

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Main process exited, code…ILURE
------------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Unit entered failed state.
-------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Failed with result 'exit-code'.
------------------------------------------------------------------------------------------

Hint: Some lines were ellipsized, use -l to show in full.
---------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! You can get their info via:
------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! npm owner ls webapp
--------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! There is likely additional logging output above.
---------------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! System Linux 4.14.98-v7+
---------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! command "/usr/bin/node" "/usr/bin/npm" "start"
-------------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! cwd /usr/local/var/draws-manager/webapp
------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! node -v v8.11.1
------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! npm -v 1.4.21
----------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! code ELIFECYCLE
------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm WARN This failure might be due to the use of legacy binary "node"
---------------------------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read
----------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian
-----------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]:
-----------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR!
--------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! Additional logging details can be found in:
----------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! /usr/local/var/draws-manager/webapp/npm-debug.log
--------------------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! not ok code 0
----------------------------------------------------------

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/FAILURE
-------------------------------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Unit entered failed state.
-------------------------------------------------------------------------------------

Aug 31 12:04:53 radiopi systemd[1]: draws-manager.service: Failed with result 'exit-code'.
------------------------------------------------------------------------------------------


 

Here it is Basil:

pi@radiopi:~ $ sensor_update.sh -s
===== Kernel version
Linux radiopi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
 
===== Draws assembly & fab revision
DRAWS version: 0x0405
 
===== Sensor config file
chip "ads1015-*"
    label in4 "+12V"
    label in6 "User ADC 1"
    label in7 "User ADC 2"
    compute in4 ((48.7/10)+1)*@, @/((48.7/10)+1)
    ignore in5
 
===== sensors output
No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.
 


 

Started new complete image and started over clean. Everything seems ok but still can't access DRAWS Manager.
Same message continues. 
"Local host refused to connect"

Used "Localhost:8080"

Todd 


 

What does

sudo systemctl status draws-manager 

return?

Are you running the browser directly on the Pi with the DRAWS™ HAT to localhost:8080?

Have you read https://github.com/nwdigitalradio/draws-manager

On Mon, Aug 31, 2020 at 9:13 PM Todd via groups.io <ic7461=yahoo.com@groups.io> wrote:
Started new complete image and started over clean. Everything seems ok but still can't access DRAWS Manager.
Same message continues. 
"Local host refused to connect"

Used "Localhost:8080"

Todd 



--
John D. Hays
Kingston, WA
K7VE

 


 

Hi John:

Here is the output. Yes I am running the browser directly on the Pi with the DRAWS™ HAT to localhost:8080

pi@draws:~ $ sudo systemctl status draws-manager
● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™
   Loaded: loaded (/etc/systemd/system/draws-manager.service; disabled; vendor p
   Active: inactive (dead)
     Docs: https://github.com/nwdigitalradio/draws-manager
Todd
 


 

pi@draws:~ $ uname -a

Linux draws 5.4.51-v7+ #1333 SMP Mon Aug 10 16:45:19 BST 2020 armv7l GNU/Linux

 




pi@draws:~ $ journalctl -u draws-manager.service

-- Logs begin at Thu 2019-02-14 01:11:59 AKST, end at Mon 2020-08-31 21:31:30 AK

Aug 31 21:27:50 draws systemd[1]: Started DRAWS™ Manager - A web application to 

Aug 31 21:27:55 draws npm[4267]: npm WARN npm npm does not support Node.js v10.2

Aug 31 21:27:55 draws npm[4267]: npm WARN npm You should probably upgrade to a n

Aug 31 21:27:55 draws npm[4267]: npm WARN npm can't make any promises that npm w

Aug 31 21:27:55 draws npm[4267]: npm WARN npm Supported releases of Node.js are 

Aug 31 21:27:55 draws npm[4267]: npm WARN npm You can find the latest version at

Aug 31 21:27:55 draws npm[4267]: > webapp@0.0.1 start /usr/local/var/draws-manag

Aug 31 21:27:55 draws npm[4267]: > node ./bin/www

Aug 31 21:28:02 draws npm[4267]: ::

Aug 31 21:28:03 draws npm[4267]: Specified sensor(s) not found!

Aug 31 21:28:03 draws npm[4267]: child_process.js:669

Aug 31 21:28:03 draws npm[4267]:     throw err;

Aug 31 21:28:03 draws npm[4267]:     ^

Aug 31 21:28:03 draws npm[4267]: Error: Command failed: /usr/bin/sensors *-i2c-1

Aug 31 21:28:03 draws npm[4267]: Specified sensor(s) not found!

Aug 31 21:28:03 draws npm[4267]:     at checkExecSyncError (child_process.js:629

Aug 31 21:28:03 draws npm[4267]:     at execSync (child_process.js:666:13)

Aug 31 21:28:03 draws npm[4267]:     at getSensors (/usr/local/var/draws-manager

Aug 31 21:28:03 draws npm[4267]:     at Timeout._onTimeout (/usr/local/var/draws

Aug 31 21:28:03 draws npm[4267]:     at ontimeout (timers.js:436:11)

Aug 31 21:28:03 draws npm[4267]:     at tryOnTimeout (timers.js:300:5)

Aug 31 21:28:03 draws npm[4267]:     at listOnTimeout (timers.js:263:5)

lines 1-23

 


Mark J Culross
 

Todd:

One thing to note: make sure "localhost" is all lowercase, with no spaces, when you attempt your connection.

Mark J Culross

On Mon, Aug 31, 2020 at 11:13 PM, Todd via groups.io
<ic7461@...> wrote:
Started new complete image and started over clean. Everything seems ok but still can't access DRAWS Manager.
Same message continues. 
"Local host refused to connect"

Used "Localhost:8080"

Todd 


 

In your errors, we see:

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! node -v v8.11.1

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! npm -v 1.4.21

Aug 31 12:04:53 radiopi npm[12818]: npm ERR! code ELIFECYCLE

Aug 31 12:04:53 radiopi npm[12818]: npm WARN This failure might be due to the use of legacy binary "node"

Aug 31 12:04:53 radiopi npm[12818]: npm WARN For further explanations, please read

Aug 31 12:04:53 radiopi npm[12818]: /usr/share/doc/nodejs/README.Debian

Aug 31 12:04:53 radiopi npm[12818]:  

Two actions to take:

Then 

cd /usr/local/var/draws-manager
sudo git pull
npm install


Then

sudo systemctl stop draws-manager
sudo systemctl start draws-manager 
sudo systemctl status draws-manager
 

Unfortunately, I have just moved my home and haven't gotten to unpacking my test Pi and uploading NWDR 17 to replicate the issue.

--
John D. Hays
Kingston, WA
K7VE

 


 

Hi John:
That post was from my old image. I sttarted a new one. Same command. Here.

pi@draws:~ $ manager-sysd.sh start
ENABLING draws-manager
Created symlink /etc/systemd/system/multi-user.target.wants/draws-manager.service → /etc/systemd/system/draws-manager.service.
pi@draws:~ $ manager-sysd.sh status
Systemd draws-manager.service is enabled
● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.
   Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-09-01 09:10:13 AKDT; 17s ago
     Docs: https://github.com/nwdigitalradio/draws-manager
  Process: 2340 ExecStart=/usr/bin/npm start (code=exited, status=1/FAILURE)
 Main PID: 2340 (code=exited, status=1/FAILURE)
 
Sep 01 09:10:12 draws npm[2340]: npm ERR! errno 1
Sep 01 09:10:12 draws npm[2340]: npm ERR! webapp@0.0.1 start: `node ./bin/www`
Sep 01 09:10:12 draws npm[2340]: npm ERR! Exit status 1
Sep 01 09:10:12 draws npm[2340]: npm ERR!
Sep 01 09:10:12 draws npm[2340]: npm ERR! Failed at the webapp@0.0.1 start…ript.
Sep 01 09:10:12 draws npm[2340]: npm ERR! This is probably not a problem w…bove.
Sep 01 09:10:13 draws npm[2340]: npm ERR! A complete log of this run can b…d in:
Sep 01 09:10:13 draws npm[2340]: npm ERR!     /root/.npm/_logs/2020-09-01T…g.log
Sep 01 09:10:13 draws systemd[1]: draws-manager.service: Main process exite…LURE
Sep 01 09:10:13 draws systemd[1]: draws-manager.service: Failed with result…de'.
Hint: Some lines were ellipsized, use -l to show in full.
Sep 01 09:10:12 draws npm[2340]: Specified sensor(s) not found!
Sep 01 09:10:12 draws npm[2340]:     at checkExecSyncError (child_process.js:629:11)
Sep 01 09:10:12 draws npm[2340]:     at execSync (child_process.js:666:13)
Sep 01 09:10:12 draws npm[2340]:     at getSensors (/usr/local/var/draws-manager/webapp/io.js:45:15)
Sep 01 09:10:12 draws npm[2340]:     at Timeout._onTimeout (/usr/local/var/draws-manager/webapp/io.js:118:27)
Sep 01 09:10:12 draws npm[2340]:     at ontimeout (timers.js:436:11)
Sep 01 09:10:12 draws npm[2340]:     at tryOnTimeout (timers.js:300:5)
Sep 01 09:10:12 draws npm[2340]:     at listOnTimeout (timers.js:263:5)
Sep 01 09:10:12 draws npm[2340]:     at Timer.processTimers (timers.js:223:10)
Sep 01 09:10:12 draws npm[2340]: npm ERR! code ELIFECYCLE
Sep 01 09:10:12 draws npm[2340]: npm ERR! errno 1
Sep 01 09:10:12 draws npm[2340]: npm ERR! webapp@0.0.1 start: `node ./bin/www`
Sep 01 09:10:12 draws npm[2340]: npm ERR! Exit status 1
Sep 01 09:10:12 draws npm[2340]: npm ERR!
Sep 01 09:10:12 draws npm[2340]: npm ERR! Failed at the webapp@0.0.1 start script.
Sep 01 09:10:12 draws npm[2340]: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
Sep 01 09:10:13 draws npm[2340]: npm ERR! A complete log of this run can be found in:
Sep 01 09:10:13 draws npm[2340]: npm ERR!     /root/.npm/_logs/2020-09-01T17_10_12_993Z-debug.log
Sep 01 09:10:13 draws systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/FAILURE
Sep 01 09:10:13 draws systemd[1]: draws-manager.service: Failed with result 'exit-code'.
 


 

Well, I have the draws board setup and connected to the 706 radio. Everything in Fldigi seems to be working with the radio. Frequency CAT control and keying. Can't really use it though without gaining access to the draws manager to adjust audio. Not enough audio drive with the file setalsa-ic706.sh. Is there any other way to adjust audio besides the manager? 
Todd
AL7PX 


Basil Gunn
 

Draws manager has been fixed for latest sensor driver. Follow John's
previous instructions to get current version.

There is a note on ICOM IC-706MKIIG here:
https://github.com/nwdigitalradio/n7nix/blob/master/docs/RADIO_HW_NOTES.md

I have this radio and the script works for me. To verify your ALSA
settings run script alsa-show.sh

For setting deviation you can use console program alsamixer for changing
LO Driver Gain & PCM values. See notes on setting radio deviation here:
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

Todd via groups.io <ic7461=yahoo.com@groups.io> writes:

Well, I have the draws board setup and connected to the 706 radio. Everything in Fldigi seems to be working with the radio. Frequency CAT control and keying. Can't really use it though without gaining access to the draws manager to adjust audio. Not enough audio drive with the file setalsa-ic706.sh. Is there any other way to adjust audio besides the manager?
Todd
AL7PX