Topics

DRAWS (nwdr16) and APRS and HT not triggering PTT

Jon Gross
 

Hey all,

I have started with a fresh install of nwdr16.  I am following this: 

https://nw-digital-radio.groups.io/g/udrc/wiki/8949

and I'm in the "Test Transmit" phase - so far everything works.

I have a 6pin cable that terminates in a kenwood plug that goes into a Wouxun uv8d plus HT.

The light on the DRAWS fires red when I issue:

./btest.sh -P udr1

However the radio doesn't seem to be doing anything at all.

Does anyone have any advice on how to troubleshoot this, and get the DRAWS to transmit via the radio?

Thanks!

Basil Gunn
 

You can continue to use btest.sh script or the
deviation/measure_deviate.sh script which you will need to use later to
set your alsa settings.

You are specifying the right mDin6 connector for btest.sh. Is that the
connector you are using? If so then you may have a cable problem which
you can diagnose with a volt meter. PTT is on pin 3 of the mDin6 cable

Jon Gross <jong@...> writes:

Hey all,

I have started with a fresh install of nwdr16. I am following this:

https://nw-digital-radio.groups.io/g/udrc/wiki/8949

and I'm in the "Test Transmit" phase - so far everything works.

I have a 6pin cable that terminates in a kenwood plug that goes into a Wouxun uv8d plus HT.

The light on the DRAWS fires red when I issue:

./ btest. sh - P udr1
However the radio doesn't seem to be doing anything at all.

Does anyone have any advice on how to troubleshoot this, and get the DRAWS to transmit via the radio?

Thanks!

Jon Gross
 

Thanks Basil for the advice!

Yes, I am using the right hand DIN port.  I've tested the cable, and pin 3 goes to the PTT segment on the HT adapter plug (the base of the 3.5mm pin), the continuity is there.

Oh, I just plugged it in and ran the measure_deviate.sh, and it's functioning, but when I start up dire wolf and run btest -P udr0, nothing.

-jon

Jon Gross
 

Further followup - using the ptt_ctrl script, I can't get it to trigger PTT on the radio, although the measure_deviation lights the PTT up fine.

Basil Gunn
 

Oh, I just plugged it in and ran the measure_deviate.sh, and it's
functioning, but when I start up dire wolf and run btest -P udr0,
nothing.
Plug your mDin6 cable from your radio into the LEFT connector, the one
closest to the GPS chip.

Jon Gross
 

Hmmm, same result.

PTT triggers on the radio with measure_deviate, but ptt_ctrl and btest both fail to trigger PTT on the radio (plugged into left DIN port).

Basil Gunn
 

PTT triggers on the radio with measure_deviate,
Are you saying the measure_deviate.sh script works for controlling ptt
on the Wouxon but ptt_ctrl.sh & btest.sh do not?

Try ptt_ctrl.sh using both -l & -r without changing the cable
location. Maybe we have a right left reference problem. ie.

ptt_ctrl.sh -r on
ptt_ctrl.sh -l on

Usage: ptt_ctrl.sh [-l][-r][-on][-off][-c][-h]
-l | --left Select left connector gpio
-r | --right Select right connector gpio
-on | on Turn selected gpio ON
-off | off Turn selected gpio OFF
-t | --toggle Toggle PTT state
-c | --check Check gpio state ie. read gpio
-d | --debug Turn debug on
-h display this message

Jon Gross <jong@...> writes:

Hmmm, same result.

PTT triggers on the radio with measure_deviate, but ptt_ctrl and btest both fail to trigger PTT on the radio (plugged into left DIN port).

Jon Gross
 

Sorry for the lack of clarity, I'm still feeling my way around this.

Here are the actual symptoms (my previous posts of PTT characterization have been vicious lies due to misunderstandings on my part. I apologize for that!).

The radio setup:
6 pin DIN plugged into left port on DRAWS -> kenwood plug plugged into Wouxun HT.  Plug pin 3 verified continuity to PTT segment of HT plug
secondary HT for monitoring same channel Wouxun is on

ptt_ctrl -r on: red light on right DIN socket, radio doesn't react, secondary radio silent
ptt_ctrl -l on: red light on left DIN socket, radio doesn't react, secondary radio silent

measure_deviate -c right: red light on right DIN socket, radio lights up receive light, indicates sound received on display, secondary radio emits bursts of static
measure_deviate -c left: red light on left DIN socket, radio lights up receive light, indicates sound being received on display, secondary radio emits bursts of static

I apologize for previous inaccurate depictions of the symptoms.

-jon


Jon Gross
 


Interestingly, when I plug the second radio in (a baofeng), and make the wouxun the secondary, ptt_ctrl -l on turns PTT on on the baofeng, but ptt_ctrl -l off doesn't turn PTT off on the baofeng.  I'm unsure how to go about tuning things so that PTT is triggered correctly though.

I've looked through the wiki, but maybe missed something on how to tune this?

-jon

Basil Gunn
 

So your observations sound like things are working. ie. your mDin6 to
handy cable is working & you are controlling ptt on the handy.

If you use the ptt_ctrl.sh script you will only be turning on carrier
and depending on your squelch setting on your receiving radio you won't
hear anything. For this test I usually turn the receiving radio volume
up and squelch down or off. You should be able to tell that the radio
under test is transmitting carrier. measure_deviate wiggles the same
gpios (12 & 23) that ptt_ctrl does.

Your next task is to set ALSA settings so deviation is set properly on
your Wouxon. This is accomplished by using John's draws-manager web app
and seting ALSA controls using alsamixer.

Although there are 44 ALSA controls (amixer -c udrc scontrols) for the
Draws hat, in order to set deviation you only need to look at LO Drive
Gain, PCM & maybe DAC PowerTune. Please carefully read the following:

- draws-manager README.md here
https://github.com/nwdigitalradio/draws-manager
On a new NWDR image this program is already installed & running. You
need to start a browser & use a url of: localhost:8080

- Please read deviation README.md file 'How to use measure_deviate.sh'
(https://github.com/nwdigitalradio/n7nix/tree/master/deviation). Your
goal is to hear a reasonable tone in your receiving handy not just
bursts of static. Please follow the link to John Ackermann N8UR write
up on setting deviation.

I don't use Chinese handies for my digital modes at all. Other people on
this forum have more experience than I and hopefully they will chime in.

/Basil n7nix

Jon Gross <jong@...> writes:

Sorry for the lack of clarity, I'm still feeling my way around this.

Here are the actual symptoms (my previous posts of PTT characterization have been vicious lies due to misunderstandings on my part. I apologize for that!).

The radio setup:
6 pin DIN plugged into left port on DRAWS -> kenwood plug plugged into Wouxun HT. Plug pin 3 verified continuity to PTT segment of HT plug
secondary HT for monitoring same channel Wouxun is on

ptt_ctrl -r on: red light on right DIN socket, radio doesn't react, secondary radio silent
ptt_ctrl -l on: red light on left DIN socket, radio doesn't react, secondary radio silent

measure_deviate -c right: red light on right DIN socket, radio lights up receive light, indicates sound received on display, secondary radio emits bursts of static
measure_deviate -c left: red light on left DIN socket, radio lights up receive light, indicates sound being received on display, secondary radio emits bursts of static

I apologize for previous inaccurate depictions of the symptoms.

-jon