Topics

dstarrepeater not working

Dave N2OA
 

I had some issues and as a result I'm rebuilding my repeater. DR-1X/UDRC combo. I followed the install up to the testing of the repeater and DSTAR is not getting decoded. Looking at the log it looks like the UDRC is recognized but no decodes..

M: 2017-11-22 03:27:39: Opened hw:CARD=udrc,DEV=0 hw:CARD=udrc,DEV=0 Rate 48000
E: 2017-11-22 03:27:39: UDRCController: NWDR UDRC II Detected
M: 2017-11-22 03:27:39: Starting ALSA reader thread
M: 2017-11-22 03:27:39: Starting ALSA writer thread
M: 2017-11-22 03:27:39: Starting Sound Card Controller thread
M: 2017-11-22 03:27:39: Poll text set to "linux_sound-20160131---debug"
M: 2017-11-22 03:27:39: Starting the D-Star repeater thread

The repeater display is showing RX in Auto and TX in FIX mode. The repeater was configured and hasn't been touched.

If I look at the config sudo -E dstarrepeaterconfig 1 I looked under the Modem tab and the Type is sound card, I selected configure. Both RX Device and TX Device are blank and there are no options to select them.

Any thoughts?

Thanks,

Dave
N2OA





Johnny
 

Had sort of the same problem. You must STOP The dstarrepeater first. 
sudo systemctl stop dstarrepeaterd@1

Then you should be able to see the UDRC being chosen in those settings

Then restart the Dstar repeater 

Good luck, 
w5pfr



On Nov 21, 2017, at 9:34 PM, Dave N2OA <kdcarlso@...> wrote:

I had some issues and as a result I'm rebuilding my repeater. DR-1X/UDRC combo. I followed the install up to the testing of the repeater and DSTAR is not getting decoded. Looking at the log it looks like the UDRC is recognized but no decodes..

M: 2017-11-22 03:27:39: Opened hw:CARD=udrc,DEV=0 hw:CARD=udrc,DEV=0 Rate 48000
E: 2017-11-22 03:27:39: UDRCController: NWDR UDRC II Detected
M: 2017-11-22 03:27:39: Starting ALSA reader thread
M: 2017-11-22 03:27:39: Starting ALSA writer thread
M: 2017-11-22 03:27:39: Starting Sound Card Controller thread
M: 2017-11-22 03:27:39: Poll text set to "linux_sound-20160131---debug"
M: 2017-11-22 03:27:39: Starting the D-Star repeater thread

The repeater display is showing RX in Auto and TX in FIX mode. The repeater was configured and hasn't been touched.

If I look at the config sudo -E dstarrepeaterconfig 1 I looked under the Modem tab and the Type is sound card, I selected configure. Both RX Device and TX Device are blank and there are no options to select them.

Any thoughts?

Thanks,

Dave
N2OA





Dave N2OA
 

Ok thanks.. Well that tells me that it is an expected behavior and not an indication of the problem. Now I have no leads..

Dave
N2OA

On Wed, Nov 22, 2017 at 8:28 AM, Johnny <w5pfr@...> wrote:
Had sort of the same problem. You must STOP The dstarrepeater first. 
sudo systemctl stop dstarrepeaterd@1

Then you should be able to see the UDRC being chosen in those settings

Then restart the Dstar repeater 

Good luck, 
w5pfr



On Nov 21, 2017, at 9:34 PM, Dave N2OA <kdcarlso@...> wrote:

I had some issues and as a result I'm rebuilding my repeater. DR-1X/UDRC combo. I followed the install up to the testing of the repeater and DSTAR is not getting decoded. Looking at the log it looks like the UDRC is recognized but no decodes..

M: 2017-11-22 03:27:39: Opened hw:CARD=udrc,DEV=0 hw:CARD=udrc,DEV=0 Rate 48000
E: 2017-11-22 03:27:39: UDRCController: NWDR UDRC II Detected
M: 2017-11-22 03:27:39: Starting ALSA reader thread
M: 2017-11-22 03:27:39: Starting ALSA writer thread
M: 2017-11-22 03:27:39: Starting Sound Card Controller thread
M: 2017-11-22 03:27:39: Poll text set to "linux_sound-20160131---debug"
M: 2017-11-22 03:27:39: Starting the D-Star repeater thread

The repeater display is showing RX in Auto and TX in FIX mode. The repeater was configured and hasn't been touched.

If I look at the config sudo -E dstarrepeaterconfig 1 I looked under the Modem tab and the Type is sound card, I selected configure. Both RX Device and TX Device are blank and there are no options to select them.

Any thoughts?

Thanks,

Dave
N2OA





Dave N2OA
 

As a follow-up when I powered everything on this morning the repeater was keyed up and wouldn't stop TXing until I stopped the dstarrepeater service.

 

On Wed, Nov 22, 2017 at 6:44 AM, Dave N2OA <kdcarlso@...> wrote:
Ok thanks.. Well that tells me that it is an expected behavior and not an indication of the problem. Now I have no leads..

Dave
N2OA

On Wed, Nov 22, 2017 at 8:28 AM, Johnny <w5pfr@...> wrote:
Had sort of the same problem. You must STOP The dstarrepeater first. 
sudo systemctl stop dstarrepeaterd@1

Then you should be able to see the UDRC being chosen in those settings

Then restart the Dstar repeater 

Good luck, 
w5pfr



On Nov 21, 2017, at 9:34 PM, Dave N2OA <kdcarlso@...> wrote:

I had some issues and as a result I'm rebuilding my repeater. DR-1X/UDRC combo. I followed the install up to the testing of the repeater and DSTAR is not getting decoded. Looking at the log it looks like the UDRC is recognized but no decodes..

M: 2017-11-22 03:27:39: Opened hw:CARD=udrc,DEV=0 hw:CARD=udrc,DEV=0 Rate 48000
E: 2017-11-22 03:27:39: UDRCController: NWDR UDRC II Detected
M: 2017-11-22 03:27:39: Starting ALSA reader thread
M: 2017-11-22 03:27:39: Starting ALSA writer thread
M: 2017-11-22 03:27:39: Starting Sound Card Controller thread
M: 2017-11-22 03:27:39: Poll text set to "linux_sound-20160131---debug"
M: 2017-11-22 03:27:39: Starting the D-Star repeater thread

The repeater display is showing RX in Auto and TX in FIX mode. The repeater was configured and hasn't been touched.

If I look at the config sudo -E dstarrepeaterconfig 1 I looked under the Modem tab and the Type is sound card, I selected configure. Both RX Device and TX Device are blank and there are no options to select them.

Any thoughts?

Thanks,

Dave
N2OA









--


John D. Hays
Edmonds, WA
K7VE

   

Dave N2OA
 

Thanks John, The solution turned out to be in the Pi 3 addendum. I forgot about this. :-(

Edit /boot/config.txt and add to the end of the file:

force_turbo=1