Topics

[Ham-Pi] Audio issues


 

Take your DRAWS™ support questions to https://nw-digital-radio.groups.io/g/udrc




On Sun, Dec 20, 2020, 15:50 Dave Slotter, W3DJS <slotter@...> wrote:
John Hays... Are you seeing this thread? Can you provide any hints?

73,

On Sat, Dec 19, 2020 at 7:34 PM John Lauber <jlauber@...> wrote:
Still tearing my hair out!  I've tried/checked everything I can think of but to no avail...has anyone been successful in getting the draws hat working on HamPi?  What am I doing wrong?

John 
WI6P


--
- Dave
  W3DJS


 

When you go to the DRAWS™/UDRC support group, you can use some diagnostic tools.

Install them by


Capture diagnostic info on the DRAWS™ install with

cd n7nix/bin
./showudrc.sh

Cut and paste the output/results to your request for help. (Cut and Paste from a terminal or ssh session, don't use screen shots).



On Sun, Dec 20, 2020 at 6:04 PM John D Hays - K7VE via groups.io <john=hays.org@groups.io> wrote:
Take your DRAWS™ support questions to https://nw-digital-radio.groups.io/g/udrc




On Sun, Dec 20, 2020, 15:50 Dave Slotter, W3DJS <slotter@...> wrote:
John Hays... Are you seeing this thread? Can you provide any hints?

73,

On Sat, Dec 19, 2020 at 7:34 PM John Lauber <jlauber@...> wrote:
Still tearing my hair out!  I've tried/checked everything I can think of but to no avail...has anyone been successful in getting the draws hat working on HamPi?  What am I doing wrong?

John 
WI6P


--
- Dave
  W3DJS


--
John D. Hays
Kingston, WA
K7VE

 


 

On Sun, Dec 20, 2020 at 06:38 PM, John D Hays - K7VE wrote:
./showudrc.sh

John--here is the output from showurdc.sh--

So what have I missed?  

de WI6P
John

pi@draws-wi6p:~ $ cd n7nix/bin
pi@draws-wi6p:~/n7nix/bin $ ./showudrc.sh
==== Sound Card ====
udrc card number line: card 2: udrc [udrc], device 0: bcm2835-i2s-tlv320aic32x4-hifi tlv320aic32x4-hifi-0 [bcm2835-i2s-tlv320aic32x4-hifi tlv320aic32x4-hifi-0]
udrc is sound card #2
==== ALSA Controls for Radio Transmit ====
LO Driver Gain  L:[-6.00dB] R:[-6.00dB]
PCM         L:[-24.50dB] R:[-24.50dB]
DAC Playback PT L:[P3] R:[P3]
LO Playback CM [Full Chip]
==== ALSA Controls for Radio Receive ====
ADC Level L:[-0.50dB] R:[-0.50dB]
IN1 L:[Off] R:[Off]
IN2 L:[10 kOhm] R:[Off]
 
==== Pi Ver ====
 Pi 4 Model B, Rev 1.4, 8GB mem, Mfg by Sony UK with WiFi
Hardware : BCM2711
Revision : d03114
Serial : 1000000078df7ff9
Model : Raspberry Pi 4 Model B Rev 1.4
 
==== Pi Firmware VideoCore Ver ====
Nov 30 2020 22:12:08 
Copyright (c) 2012 Broadcom
version ab1181cc0cb6df52bfae3b1d3fef0ce7c325166c (clean) (release) (start)
 
==== Pi Firmware EEPROM Ver ====
Sep  3 2020 13:11:43
version c305221a6d7e532693cc7ff57fddfc8649def167 (release)
timestamp 1599135103
update-time 0
capabilities 0x00000000
 
==== Pi Firmware EEPROM Config ====
[all]
BOOT_UART=0
WAKE_ON_GPIO=1
POWER_OFF_ON_HALT=0
DHCP_TIMEOUT=45000
DHCP_REQ_TIMEOUT=4000
TFTP_FILE_TIMEOUT=30000
TFTP_IP=
TFTP_PREFIX=0
BOOT_ORDER=0x1
SD_BOOT_MAX_RETRIES=3
NET_BOOT_MAX_RETRIES=5
[none]
FREEZE_VERSION=0
 
==== udrc Ver ====
Found a DRAWS
 
     HAT ID EEPROM
Name:        hat
Product:     Digital Radio Amateur Work Station
Product ID:  0x0004
Product ver: 0x0108
UUID:        68f027a3-9427-4a88-9dd2-065fec8e9b6e
Vendor:      NW Digital Radio
 
==== sys Ver ====
----- image version
head: cannot open '/var/log/udr_install.log' for reading: No such file or directory
----- /proc/version
Linux version 5.4.79-v7l+ (dom@buildbot) (gcc version 8.4.0 (Ubuntu/Linaro 8.4.0-3ubuntu1)) #1373 SMP Mon Nov 23 13:27:40 GMT 2020
 
cat: /etc/subversion: Is a directory
----- /etc/*version: 10.6
 
----- /etc/*release
PRETTY_NAME="HamPi 1.2 (December 2020)"
NAME="HamPi"
VERSION_ID="1,2"
VERSION="1.2 (December 2020)"
HOME_URL="http://hampi.radiowaves.ca"
SUPPORT_URL="https://groups.io/g/Ham-Pi"
BUG_REPORT_URL="https://github.com/dslotter/HamPi/issues/"
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
 
----- lsb_release
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster
 
---- systemd
   Static hostname: draws-wi6p
         Icon name: computer
        Machine ID: 4890219a07b34906b35a0d48993814c7
           Boot ID: f6249cdacf584c95ad388896b3227ac8
  Operating System: Raspbian GNU/Linux 10 (buster)
            Kernel: Linux 5.4.79-v7l+
      Architecture: arm
        sd card id: 035344534333324780fa008942014600
 
---- sound modules
snd_soc_tlv320aic32x4_i2c    16384  261
snd_soc_tlv320aic32x4    40960  1 snd_soc_tlv320aic32x4_i2c
regmap_i2c             16384  4 ti_ads1015,sc16is7xx,rtl2832,snd_soc_tlv320aic32x4_i2c
snd_soc_core          200704  5 vc4,snd_soc_simple_card_utils,snd_soc_bcm2835_i2s,snd_soc_tlv320aic32x4,snd_soc_simple_card
snd_pcm                94208  6 vc4,snd_pcm_dmaengine,snd_soc_bcm2835_i2s,snd_soc_tlv320aic32x4,snd_bcm2835,snd_soc_core
snd                    73728  16 snd_compress,snd_timer,snd_soc_tlv320aic32x4,snd_bcm2835,snd_soc_core,snd_pcm
 
---- kernel
||/ Name               Version      Architecture Description
+++-==================-============-============-=====================================
ii  python3-ipykernel  4.9.0-1      all          IPython kernel for Jupyter (Python 3)
ii  raspberrypi-kernel 1.20201201-1 armhf        Raspberry Pi bootloader
 
---- Codec drivers
Found: snd-soc-tlv320aic32x4-i2c.ko, OK
Found: snd-soc-tlv320aic32x4.ko, OK
Directory: /proc/device-tree/soc/i2c@7e804000/tlv320aic32x4@18 exists and status is okay
 
---- syslog
 
---- dmesg
 
 
----- Dire Wolf DEVELOPMENT version 1.7 A (Dec  6 2020)
 
==== Filesystem ====
/dev/root        15G   11G  3.3G  77% /
 
==== boot config ====
disable_overscan=1
dtoverlay=
dtparam=audio=on
[pi4]
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
[all]
dtoverlay=draws,alsaname=udrc
force_turbo=1
 
---- gpsd
/usr/sbin/gpsd
gpsd: 3.21.1~dev (revision release-3.21-695-g2cc76873c)
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
 
---- chrony
crw------- 1 root root    239, 0 Dec 21 12:00 /dev/pps0
crw-rw---- 1 root dialout 236, 0 Dec 21 12:00 /dev/ttySC0
crw-rw---- 1 root dialout 236, 1 Dec 21 12:00 /dev/ttySC1
-- chrony sources
210 Number of sources = 4
MS Name/IP address         Stratum Poll Reach LastRx Last sample               
===============================================================================
^- 99-104-170-138.lightspee>     2   6   377    59  +1272us[+1584us] +/-   93ms
^* grom.polpo.org                2   6   377    58    -14us[ +299us] +/-   27ms
^+ segfault.boom.net             2   6   377    58  -1575us[-1262us] +/-   54ms
^+ x.ns.gin.ntt.net              2   6   377    58  +1562us[+1562us] +/-   39ms
-- chrony tracking
Reference ID    : 4113B2DB (grom.polpo.org)
Stratum         : 3
Ref time (UTC)  : Mon Dec 21 20:07:56 2020
System time     : 0.000082377 seconds slow of NTP time
Last offset     : +0.000312623 seconds
RMS offset      : 0.000938096 seconds
Frequency       : 8.631 ppm fast
Residual freq   : +0.096 ppm
Skew            : 5.137 ppm
Root delay      : 0.034072276 seconds
Root dispersion : 0.007781397 seconds
Update interval : 64.7 seconds
Leap status     : Normal
-- chrony sourcestats
210 Number of sources = 4
Name/IP Address            NP  NR  Span  Frequency  Freq Skew  Offset  Std Dev
==============================================================================
99-104-170-138.lightspee>  10   5   395     -0.125      8.715  +1827us   775us
grom.polpo.org             10   6   396     +1.526      7.041   +868us   576us
segfault.boom.net          10   5   395     +0.923     14.815  -2926us  1441us
x.ns.gin.ntt.net           10   6   395     -0.809      5.667  +1007us   414us
 
---- sensors
-rw-r--r-- 1 root root 352 Dec  6 14:27 /etc/sensors.d/draws
iio_hwmon-isa-0000
Adapter: ISA adapter
in1:          +2.04 V  
in2:          +2.50 V  
in3:          +0.01 V  
in4:          +0.01 V  
 
cpu_thermal-virtual-0
Adapter: Virtual device
temp1:        +59.9°C  
 
rpi_volt-isa-0000
Adapter: ISA adapter
in0:              N/A  
 
 
---- throttle
temp=58.9'C
throttled=0x0
 
---- locale
Locale country codes consistent among WiFi cfg file, iw reg & X11: US
grep: /var/log/udr_install.log: No such file or directory
core_config.sh has been run  time(s)
pi@draws-wi6p:~/n7nix/bin $ 


 

Problem solved!!  It was an ALSAMIXER setup problem...I now have everything working using the DRAWS hat with the HamPi Image.  Sorry to take up the bandwidth

73 
John
WI6P


 

No worries. Glad you found it. Did the output of the script help?


On Mon, Dec 21, 2020, 14:08 John Lauber <jlauber@...> wrote:
Problem solved!!  It was an ALSAMIXER setup problem...I now have everything working using the DRAWS hat with the HamPi Image.  Sorry to take up the bandwidth

73 
John
WI6P


 

Yes it did...thanks again.

There is so much to learn....

John


Basil Gunn
 

John WI6P,
A couple of things I noticed from your showudrc.sh output.

gps is not installed. Note the gpsd package that is in the Debian repo
does not support the DRAWS gps device very well.

The following script will build & install gpsd from source and configure
chrony. I have never tried this install on an image other than NWDR.

cd
cd n7nix/gps
./gp_install.sh

Also the DRAWS sensors have not been configured. Again I have never
tried this install on an image other than NWDR.

cd
cd n7nix/config
./sensor_update.sh -f

# run this command to confirm
sensors

Also your root file system is 77% full. If you decide to install a HamPI
image again I recommend using an SD card larger than 16GB.

/Basil n7nix


John Lauber <jlauber@ix.netcom.com> writes:

On Sun, Dec 20, 2020 at 06:38 PM, John D Hays - K7VE wrote:


./showudrc.sh
John--here is the output from showurdc.sh--

So what have I missed?

de WI6P
John

pi@draws-wi6p:~ $ cd n7nix/bin
pi@draws-wi6p:~/n7nix/bin $ ./showudrc.sh
==== Sound Card ====
udrc card number line: card 2: udrc [udrc], device 0: bcm2835-i2s-tlv320aic32x4-hifi tlv320aic32x4-hifi-0 [bcm2835-i2s-tlv320aic32x4-hifi tlv320aic32x4-hifi-0]
udrc is sound card #2


 

Basil, 

Thanks very much.  I decided to start from scratch with a new HamPi image (1.2a) on a new 32GB card, and then followed the guidance you and John gave me.  It looks like I've gotten it pretty much all setup and working (WSJT-X and flidigi/flrig)  although I'm sure there will be more tweaking to do as I add apps/functionality.  

Again, thanks to you and John for the helpful advice.

John
WI6P