Topics

"Lost" Claws Mail

Ed Bloom, KD9FRQ
 

Since I finally got a second antenna up and the second 2m rig, I now have my DRAWS running APRS on udr0 and wl2kax25 sending and receiving on udr1.

Claws Mail is properly sending mail out and wl2kax25 sees it ans sends it on. Wl2kax25 is also picking up the mail.

However, once picked up, it is not getting routed in the pi@localhost to Claws Mail.

What conf file(s) and setting should I check?

Thanks, Ed, KD9FRQ

Basil Gunn
 

If you are setting up Claws-mail, make sure that you follow the
Claws-mail setup instructions exactly as described here:

https://github.com/nwdigitalradio/n7nix/blob/master/email/claws/README.md

If you continue to have problems try using mutt, which should already be
installed & configured to verify that the dovecot imap server is
configured properly.

In n7nix/debug directory there is a script, chk_mail.sh that will verify
your configuration & send a wl2k message to me automatically.

/Basil


Ed Bloom, KD9FRQ via groups.io <ewbloom=verizon.net@groups.io> writes:

Since I finally got a second antenna up and the second 2m rig, I now
have my DRAWS running APRS on udr0 and wl2kax25 sending and receiving on
udr1.

Claws Mail is properly sending mail out and wl2kax25 sees it ans sends
it on. Wl2kax25 is also picking up the mail.

However, once picked up, it is not getting routed in the pi@localhost to
Claws Mail.

What conf file(s) and setting should I check?

Thanks, Ed, KD9FRQ

Ed Bloom, KD9FRQ
 

Following the Readme, everything seems to be in order.  Claws sends out to pi@localhost and whereever the wl2kax25 program needs to have outbox data.

It seems the script ran fine but defaulted to telnet and did not use the radio to send the message. It sent a copy to my Claws Inbox.

Just trying to figure out where the mail goes on the Pi once it is picked up via radio and how to get it route to the Claws inbox.

I wonder if it has to do with being on udr1 instead of udr0?  Just wondering.

Ed

On 5/31/2020 2:59 PM, Basil Gunn wrote:
If you are setting up Claws-mail, make sure that you follow the
Claws-mail setup instructions exactly as described here:

https://github.com/nwdigitalradio/n7nix/blob/master/email/claws/README.md

If you continue to have problems try using mutt, which should already be
installed & configured to verify that the dovecot imap server is
configured properly.

In n7nix/debug directory there is a script, chk_mail.sh that will verify
your configuration & send a wl2k message to me automatically.

/Basil


Ed Bloom, KD9FRQ via groups.io <ewbloom=verizon.net@groups.io> writes:

Since I finally got a second antenna up and the second 2m rig, I now
have my DRAWS running APRS on udr0 and wl2kax25 sending and receiving on
udr1.

Claws Mail is properly sending mail out and wl2kax25 sees it ans sends
it on. Wl2kax25 is also picking up the mail.

However, once picked up, it is not getting routed in the pi@localhost to
Claws Mail.

What conf file(s) and setting should I check?

Thanks, Ed, KD9FRQ

Basil Gunn
 

Ed,

It seems the script ran fine but defaulted to telnet and did not use the
radio to send the message.
Correct it is meant to ONLY verify your email configuration, postfix, dovecot
& some mail client so doesn't require a radio. It allows me to take a
look at some of your config files.

I notice in file: /usr/local/etc/wl2k.conf that you have
email=kd9frq@...

it should be:
email=pi@localhost

which confuses me because the config script sets that.


May 31 18:31:33 MyDrawsPi postfix/qmgr[843]: 17E07161335: from=<pi@...>, size=477, nrcpt=1 (queue active)

Just trying to figure out where the mail goes on the Pi once it is
picked up via radio and how to get it route to the Claws inbox.
You are running a local imap server so that's were all mail ends up
until you retrieve it with your mail client which will store your mail
in the /home/pi/Mail directory.

I wonder if it has to do with being on udr1 instead of udr0? Just
wondering.
Nope. That has nothing to do with email.

Ed

On 5/31/2020 2:59 PM, Basil Gunn wrote:
If you are setting up Claws-mail, make sure that you follow the
Claws-mail setup instructions exactly as described here:

https://github.com/nwdigitalradio/n7nix/blob/master/email/claws/README.md

If you continue to have problems try using mutt, which should already be
installed & configured to verify that the dovecot imap server is
configured properly.

In n7nix/debug directory there is a script, chk_mail.sh that will verify
your configuration & send a wl2k message to me automatically.

/Basil


Ed Bloom, KD9FRQ via groups.io <ewbloom=verizon.net@groups.io> writes:

Since I finally got a second antenna up and the second 2m rig, I now
have my DRAWS running APRS on udr0 and wl2kax25 sending and receiving on
udr1.

Claws Mail is properly sending mail out and wl2kax25 sees it ans sends
it on. Wl2kax25 is also picking up the mail.

However, once picked up, it is not getting routed in the pi@localhost to
Claws Mail.

What conf file(s) and setting should I check?

Thanks, Ed, KD9FRQ

Ed Bloom, KD9FRQ
 

Thank you.

I edited the file to make the email address correct per your note.

That corrected to problem.T

On 6/1/2020 12:47 AM, Basil Gunn wrote:
Ed,

It seems the script ran fine but defaulted to telnet and did not use the
radio to send the message.
Correct it is meant to ONLY verify your email configuration, postfix, dovecot
& some mail client so doesn't require a radio. It allows me to take a
look at some of your config files.

I notice in file: /usr/local/etc/wl2k.conf that you have
email=kd9frq@...

it should be:
email=pi@localhost

which confuses me because the config script sets that.


May 31 18:31:33 MyDrawsPi postfix/qmgr[843]: 17E07161335: from=<pi@...>, size=477, nrcpt=1 (queue active)

Just trying to figure out where the mail goes on the Pi once it is
picked up via radio and how to get it route to the Claws inbox.
You are running a local imap server so that's were all mail ends up
until you retrieve it with your mail client which will store your mail
in the /home/pi/Mail directory.

I wonder if it has to do with being on udr1 instead of udr0? Just
wondering.
Nope. That has nothing to do with email.

Ed

On 5/31/2020 2:59 PM, Basil Gunn wrote:
If you are setting up Claws-mail, make sure that you follow the
Claws-mail setup instructions exactly as described here:

https://github.com/nwdigitalradio/n7nix/blob/master/email/claws/README.md

If you continue to have problems try using mutt, which should already be
installed & configured to verify that the dovecot imap server is
configured properly.

In n7nix/debug directory there is a script, chk_mail.sh that will verify
your configuration & send a wl2k message to me automatically.

/Basil


Ed Bloom, KD9FRQ via groups.io <ewbloom=verizon.net@groups.io> writes:

Since I finally got a second antenna up and the second 2m rig, I now
have my DRAWS running APRS on udr0 and wl2kax25 sending and receiving on
udr1.

Claws Mail is properly sending mail out and wl2kax25 sees it ans sends
it on. Wl2kax25 is also picking up the mail.

However, once picked up, it is not getting routed in the pi@localhost to
Claws Mail.

What conf file(s) and setting should I check?

Thanks, Ed, KD9FRQ