Topics

No audio detected (FLDIGI) #fldigi #audio #configuration #cat #cw

Michael Sharp
 

Hello,
I am attempting to connect a Xiegu G90 to the DRAWS Hat. I am using a custom made cable from Ham Made Parts. Using my oscilloscope, I can definitely confirm that there is audio coming from the G90 through the custom cable. The cable will connect directly from the ACC port of the G90 to the DRAWS Hat Right Channel.

I am using the latest DRAWS image for Raspberry Pi 3, and I would like to use the DRAWS Hat with FLDIGI so I can send and receive CW. The problem I am having is that I don’t see any audio coming through to FLDIGI. Also, I am a bit overwhelmed with all of the configuration options in the Audio Mixer that the DRAWS Hat offers. Which inputs or outputs do I enable? Do I need to set the attenuators? How does the DRAWS Hat show up as a CAT control?

There certainly seems to be a lot of flexibility in this card to say the least. I’m sure that the problem is a configuration problem, possibly even needing Permissions or Group Access (?) from the Raspberry Pi OS.

Any help appreciated... Thanks in advance!

73,
-Michael

 
Edited

Hi Michael,

If you are not familiar with all of the workings of CODEC chip, it is best not to use alsamixer or similar tools to configure settings.  The DRAWS™ Manager is designed to control the selection of ports and levels.  Use one of the setalsa scripts in the n7nix tools to reset the CODEC into a basic configuration, then use DRAWS™ Manager to set up for your radio.

Application configuration assistance is best handled through the application support groups, though other users of fldigi on this forum may lend advice.  

On Thu, Sep 5, 2019 at 11:36 AM Michael Sharp via Groups.Io <nexxusix=yahoo.com@groups.io> wrote:
Hello,
I am attempting to connect a Xiegu G90 to the DRAWS Hat. I am using a custom made cable from Ham Made Parts. Using my oscilloscope, I can definitely confirm that there is audio coming from the G90 through the custom cable. The cable will connect directly from the ACC port of the G90 to the DRAWS Hat Right Channel.

I am using the latest DRAWS image for Raspberry Pi 3, and I would like to use the DRAWS Hat with FLDIGI so I can send and receive CW. The problem I am having is that I don’t see any audio coming through to FLDIGI. Also, I am a bit overwhelmed with all of the configuration options in the Audio Mixer that the DRAWS Hat offers. Which inputs or outputs do I enable? Do I need to set the attenuators? How does the DRAWS Hat show up as a CAT control?

There certainly seems to be a lot of flexibility in this card to say the least. I’m sure that the problem is a configuration problem, possibly even needing Permissions or Group Access (?) from the Raspberry Pi OS.

Any help appreciated... Thanks in advance!

73,
-Michael

 

 


 
--
John D. Hays
Kingston, WA
K7VE
 
 
 

 

DRAWS™ Manager has links to many application support groups.

For fldigi audio adjustment, check this page http://www.w1hkj.com/FldigiHelp/audio_adjust_page.html

On Thu, Sep 5, 2019 at 11:58 AM John D Hays - K7VE via Groups.Io <john=hays.org@groups.io> wrote:
Hi Michael,

If you are not familiar with all of the workings of CODEC chip, it is best not to use alsamixer or similar tools to configure settings.  The DRAWS™ Manager is designed to control the selection of ports and levels.  Use one of the setalsa scripts in the n7nix tools to reset the CODEC into a basic configuration, then use use DRAWS™ Manager to set up for your radio.

Application configuration assistance is best handled through the application support groups, though other users of fldigi on this forum may lend advice.  

On Thu, Sep 5, 2019 at 11:36 AM Michael Sharp via Groups.Io <nexxusix=yahoo.com@groups.io> wrote:
Hello,
I am attempting to connect a Xiegu G90 to the DRAWS Hat. I am using a custom made cable from Ham Made Parts. Using my oscilloscope, I can definitely confirm that there is audio coming from the G90 through the custom cable. The cable will connect directly from the ACC port of the G90 to the DRAWS Hat Right Channel.

I am using the latest DRAWS image for Raspberry Pi 3, and I would like to use the DRAWS Hat with FLDIGI so I can send and receive CW. The problem I am having is that I don’t see any audio coming through to FLDIGI. Also, I am a bit overwhelmed with all of the configuration options in the Audio Mixer that the DRAWS Hat offers. Which inputs or outputs do I enable? Do I need to set the attenuators? How does the DRAWS Hat show up as a CAT control?

There certainly seems to be a lot of flexibility in this card to say the least. I’m sure that the problem is a configuration problem, possibly even needing Permissions or Group Access (?) from the Raspberry Pi OS.

Any help appreciated... Thanks in advance!

73,
-Michael



--
John D. Hays
Kingston, WA
K7VE

 



--
John D. Hays
Kingston, WA
K7VE

 

Basil Gunn
 

Michael,
There are two possible choices for radio receive data with ALSA settings
for each.

There is not a lot of description on the ACC port for your radio so I'm
going to assume AF_OUT is your 1200/300 baud receive pin & DATA is your
9600 baud receive pin and AF_IN is your transmit data pin. There is a
good chance that I have this wrong so a little empirical testing
will serve you well.

On the DRAWS side make sure that you are selecting IN2 with alsamixer to
use AF_OUT.
Run alsashow.sh to verify.

Read this for more information on interfacing & controls.
https://nw-digital-radio.groups.io/g/udrc/wiki/DRAWS%E2%84%A2-Audio-CODEC-Analog-Routing%2C-Digital-Interfacing-and-Controls

From the above document.

The DRAWS™ board wires all of the "L" pins to the left DIN-6 connector
and all the "R" pins to the right DIN-6 connector. The IN1 pins are
wired to the "9600 baud" or "discriminator" pin on the DIN-6, and the
IN2 pins are wired to the "1200 baud" or "audio" pin on the DIN-6.
Please note that IN3 is not used or connected anywhere on the DRAWS™.

Depending on which DRAWS mDin6 connector you are connected to you can
control your PTT pin on your ACC port.
Left connector port 0, GPIO 12
Right connector port 1, GPIO 23

There are some notes for setting up FLdigi using older NW Digital hats
here:
https://nw-digital-radio.groups.io/g/udrc/wiki/UDRC%E2%84%A2-and-fldigi-Setup-Page


Hope that helps.

/Basil n7nix

Michael Sharp via Groups.Io <nexxusix=yahoo.com@groups.io> writes:

Hello,
I am attempting to connect a Xiegu G90 to the DRAWS Hat. I am using a custom made cable from Ham Made Parts. Using my oscilloscope, I can definitely confirm that there is audio coming from the G90 through the custom cable. The cable will connect directly from the ACC port of the G90 to the DRAWS Hat Right Channel.

I am using the latest DRAWS image for Raspberry Pi 3, and I would like to use the DRAWS Hat with FLDIGI so I can send and receive CW.The problem I am having is that I don’t see any audio coming through to FLDIGI. Also, I am a bit overwhelmed with all of the configuration options in the Audio Mixer that the DRAWS Hat offers. Which inputs or outputs do I enable? Do I need to set the attenuators? How does the DRAWS Hat show up as a CAT control?

There certainly seems to be a lot of flexibility in this card to say the least. I’m sure that the problem is a configuration problem, possibly even needing Permissions or Group Access (?) from the Raspberry Pi OS.

Any help appreciated... Thanks in advance!

73,
-Michael