Topics

No audio in/out with my FT-817, Pi4, and DRAWS

Chris Metcalf
 

I've been trying to get my Raspberry Pi 4 working with my DRAWS hat but I think either my connection is messed up or my audio setup / levels wrong. 
 
I've followed the Google Doc on how to set up your Pi4 (https://docs.google.com/document/u/2/d/1Wq-jNLXYuREIOcr0OVu1FxPNhDFGuCOu6dX5OQ2BVxA/mobilebasic) and the setup guide for the FT-817 (https://nw-digital-radio.groups.io/g/udrc/wiki/DRAWS%3A-App-Notes-for-Radios)
 
Maybe I'm doing something wrong and I've been staring at it too long to notice? Can somebody please look over my setup below and let me know if spot something amiss? I had things working with my Pi3, so I suspect I’m missing something that’s in the stock Compass image but missing in a hand-configured Buster setup.
 
## Symptoms
 
- S7 noise floor, and I can hear signals but nothing in the WSJT-X waterfall
- Panadapter shows plenty of signals I'm not getting in the WSJT-X waterfall
- Nothing on ALC meter when I tune with WSJT-X
- No signal displayed in the waterfall when I switch to VHF and send a test transmission from my HT
- Nothing received on my HT when I transmit a tuning signal on VHF
 
## Hardware
 
- Yaesu FT-817
- LDG Z-817 antenna tuner
- 4GB Raspberry Pi 4
- DRAWS hat
- PAT-V panadapter installed
 
## Settings 
 
- 03 9600 Mic: 50
- 24 Dig Disp: 0Hz
- 25 Dig Mic: 61
- 26 Dig Mode: User-U
- 27 Dig Shift: 0Hz
- 38 Op Filter: Off
- 39 Pkt Mic: 50
- 40 Pkt Rate: 1200
- AGC: Fast
- Noise Blanker: Off
 
## Connections
 
- Pin 6 removed from the Data cable
- Data cable in Left (facing the connectors) jack
- USB Serial CAT cable
- Offset fed dipole on a 6:1 balun connected via an antenna tuner
 
## WSJT-X Setup
 
- CAT control set up and working
- Input: plughw:CARD=udrc,DEV=0 in Mono mode (
- Output: plughw:CARD=udrc,DEV=0 in Mono mode
 
I've tried Left, Right, and other udrc input devices to no success)
 
## ALSA Setup
 
I ran the setup-ft817.sh script to set my levels:
 
===== ALSA Controls for Radio Transmit =====
LO Driver Gain  L:[-6.00dB]     R:[-6.00dB]
PCM             L:[-20.00dB]    R:[-20.00dB]
DAC Playback PT L:[P3]  R:[P3]
LO Playback CM  [Full Chip]
 
 ===== ALSA Controls for Radio Receive =====
ADC Level       L:[-2.00dB]     R:[-2.00dB]
IN1             L:[Off]         R:[Off]
IN2             L:[10 kOhm]     R:[10 kOhm]
CM              L:[10 kOhm]     R:[10 kOhm]
 
Thanks,
Chris Metcalf
K1NOT

 

Try DRAWS ™ Manager 


It should set levels properly. 


On Wed, Jul 31, 2019, 20:42 Chris Metcalf <chris@...> wrote:
I've been trying to get my Raspberry Pi 4 working with my DRAWS hat but I think either my connection is messed up or my audio setup / levels wrong. 
 
 
Maybe I'm doing something wrong and I've been staring at it too long to notice? Can somebody please look over my setup below and let me know if spot something amiss? I had things working with my Pi3, so I suspect I’m missing something that’s in the stock Compass image but missing in a hand-configured Buster setup.
 
## Symptoms
 
- S7 noise floor, and I can hear signals but nothing in the WSJT-X waterfall
- Panadapter shows plenty of signals I'm not getting in the WSJT-X waterfall
- Nothing on ALC meter when I tune with WSJT-X
- No signal displayed in the waterfall when I switch to VHF and send a test transmission from my HT
- Nothing received on my HT when I transmit a tuning signal on VHF
 
## Hardware
 
- Yaesu FT-817
- LDG Z-817 antenna tuner
- 4GB Raspberry Pi 4
- DRAWS hat
- PAT-V panadapter installed
 
## Settings 
 
- 03 9600 Mic: 50
- 24 Dig Disp: 0Hz
- 25 Dig Mic: 61
- 26 Dig Mode: User-U
- 27 Dig Shift: 0Hz
- 38 Op Filter: Off
- 39 Pkt Mic: 50
- 40 Pkt Rate: 1200
- AGC: Fast
- Noise Blanker: Off
 
## Connections
 
- Pin 6 removed from the Data cable
- Data cable in Left (facing the connectors) jack
- USB Serial CAT cable
- Offset fed dipole on a 6:1 balun connected via an antenna tuner
 
## WSJT-X Setup
 
- CAT control set up and working
- Input: plughw:CARD=udrc,DEV=0 in Mono mode (
- Output: plughw:CARD=udrc,DEV=0 in Mono mode
 
I've tried Left, Right, and other udrc input devices to no success)
 
## ALSA Setup
 
I ran the setup-ft817.sh script to set my levels:
 
===== ALSA Controls for Radio Transmit =====
LO Driver Gain  L:[-6.00dB]     R:[-6.00dB]
PCM             L:[-20.00dB]    R:[-20.00dB]
DAC Playback PT L:[P3]  R:[P3]
LO Playback CM  [Full Chip]
 
 ===== ALSA Controls for Radio Receive =====
ADC Level       L:[-2.00dB]     R:[-2.00dB]
IN1             L:[Off]         R:[Off]
IN2             L:[10 kOhm]     R:[10 kOhm]
CM              L:[10 kOhm]     R:[10 kOhm]
 
Thanks,
Chris Metcalf
K1NOT

 


On Wed, Jul 31, 2019, 21:22 John D Hays - K7VE via Groups.Io <john=hays.org@groups.io> wrote:
Try DRAWS ™ Manager 


It should set levels properly. 



Chris Metcalf
 

Hmm, I installed and ran DRAWS Manager from source, and set my ALSA settings using its presets. According to alsa-show.sh, the levels are tweaked a bit now but I’m still seeing the same barren field in my waterfall:

 ===== ALSA Controls for Radio Transmit =====
LO Driver Gain  L:[-6.00dB]     R:[-6.00dB]
PCM             L:[-16.50dB]    R:[-20.00dB]
DAC Playback PT L:[P3]  R:[P3]
LO Playback CM  [Full Chip]
 
 ===== ALSA Controls for Radio Receive =====
ADC Level       L:[-2.00dB]     R:[-2.00dB]
IN1             L:[Off]         R:[Off]
IN2             L:[10 kOhm]     R:[10 kOhm]
CM              L:[10 kOhm]     R:[10 kOhm]

I’m operating remotely at the moment, I’ll double-check everything when I get home. It’s got to be something hardware at this point but I’m out of ideas.

Thanks,
Chris