Topics

No repeater TX data in Dstar mode on DR-1x


 

I hooked up my UDRC and it works fine in analog and Fusion.  I am not getting repeater dstar data transmit from the DR-1x repeater.  The repeater keys up with a dead carrier.  The dstarrepeater GUI decodes my handheld fine.  I don't see any data on pin 6 behind the 15 pin connector on the UDRC. Has anybody else seen this?


Thanks

Bill 

WA7KMF


 

I was getting ready to post the same thing.  We haven't tested Fusion, lack of a radio while testing on the bench, and found that if we set it to Fixed FM / Fixed FM and set the serialconfig=4 that we can pass D-STAR audio.  Auto/Auto and serialconfig=2 means no audio but we're seeing it decode.

Just for reference, the DR-1x is running firmware 1.10D and we are running on a Pi2 with the Compass build from 05-23-2016, followed all instructions (double checked everything).  The only thing we aren't doing right now is having the daemon auto-start.  Tested using an ID-800 and ID-92, plus various analog handhelds.

The log shows us when set in auto/auto that in the line with 'Radio header decoded' we show 'Flags: 40 00 00' and 'Transmitting to' with 'Flags: 01 00 00'.  Another thing we noticed is that when this is happening the transmission frames is 1.0s with a BER: 10%.  When we run it in fixed mode we get variable frames (as expected) and a BER of 0%.  Everything else, RPT1/RPT2/UR CALL/MY CALL all look right.

One note on our environment, we are still waiting on the club callsigns for ircddb so that's not running and we're not connected to the internet at the moment.  I wouldn't expect those to create a problem, as our expectation is that the dstarrepeater software will allow it run without internet.  If this is not the case, please let me know and we can re-test accordingly.

Thanks,

Craig

KF7LLA