Topics

No Sound Cards with UDRC and aplay -l

 

I have been using my original UDRC and direwolf for a long time as one of the ports on my bpq32 node.  A while back the SD card on that Pi went belly up so I rebuilt the system from scratch using the current Raspberry Pi OS Buster.  When I boot up the system and run aplay -l it says "No sound cards". 

 

pi@af9w-bpq:~ $ aplay -l

aplay: device_list:272: no soundcards found...

 

Here is what I have:

config.txt no changes except to add

# load UDRC driver

dtoverlay=

dtoverlay=udrc

force_turbo=1

enable_uart=1

#dtoverlay=pi3-disable-bt

OS

pi@af9w-bpq:/etc $ cat os-release

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"

NAME="Raspbian GNU/Linux"

VERSION_ID="10"

VERSION="10 (buster)"

VERSION_CODENAME=buster

ID=raspbian

ID_LIKE=debian

HOME_URL="http://www.raspbian.org/"

SUPPORT_URL="http://www.raspbian.org/RaspbianForums"

BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

pi@af9w-bpq:/etc $

 

pi@af9w-bpq:/proc/device-tree/hat $ ls

name  product  product_id  product_ver  uuid  vendor

pi@af9w-bpq:/proc/device-tree/hat $ cat name

hat

pi@af9w-bpq:/proc/device-tree/hat $ cat product

Universal Digital Radio Controller

pi@af9w-bpq:/proc/device-tree/hat $ cat product_id

0x0002

pi@af9w-bpq:/proc/device-tree/hat $ cat product_ver

0x0003

pi@af9w-bpq:/proc/device-tree/hat $ cat uuid

3b87f1d1-8ff9-471e-860a-08c79b33400

bpi@af9w-bpq:/proc/device-tree/hat $ cat vendor

NW Digital Radio pi@af9w-bpq:/proc/device-tree $ cat model

Raspberry Pi 2 Model B Rev 1.1

 

I have reseated the card and all the pins are properly connected.

 

Any ideas where to go from here?

 

Bob AF9W

 

Basil Gunn
 

I do not support starting from a Raspbian image. It is possible to do
that as that's my starting point for building the NWDR image but you
need some experience with Linux.

Please use the NWDR16.img (http://nwdig.net/downloads/current_image.zip)
and follow the instructions here:
https://nw-digital-radio.groups.io/g/udrc/wiki/8921

The symptom you describe indicates something wrong with your
/boot/config.txt file (most likely) or you have found some problem
using the latest Raspbian kernel that I have not verified yet.

The last lines of my UDRC boot config file look like the following. The
boot config is picky about order and syntax.

# Flush all overlays, ie. deprecated overlays loaded from eeprom
dtoverlay=
# enable udrc/draws if no eeprom
dtoverlay=udrc
force_turbo=1

Perhaps you can edit your /boot/config.txt file to look exactly like
above and reboot to see if aplay -l enumerates the udrc sound codec.

If you ask for more help I will need to see the console output of
showudrc.sh

/Basil n7nix


Bob AF9W <@AF9W> writes:

I have been using my original UDRC and direwolf for a long time as one of the ports on my bpq32 node. A while back the SD card on that Pi went belly up so I rebuilt the system from scratch using the current Raspberry Pi OS Buster. When I boot up the system and run aplay -l it says "No sound cards".

pi@af9w-bpq:~ $ aplay -l

aplay: device_list:272: no soundcards found...

Here is what I have:

config.txt no changes except to add

# load UDRC driver

dtoverlay=

dtoverlay=udrc

force_turbo=1

enable_uart=1

#dtoverlay=pi3-disable-bt

OS

pi@af9w-bpq:/etc $ cat os-release

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"

NAME="Raspbian GNU/Linux"

VERSION_ID="10"

VERSION="10 (buster)"

VERSION_CODENAME=buster

ID=raspbian

ID_LIKE=debian

HOME_URL="http://www.raspbian.org/"

SUPPORT_URL="http://www.raspbian.org/RaspbianForums"

BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

pi@af9w-bpq:/etc $

pi@af9w-bpq:/proc/device-tree/hat $ ls

name product product_id product_ver uuid vendor

pi@af9w-bpq:/proc/device-tree/hat $ cat name

hat

pi@af9w-bpq:/proc/device-tree/hat $ cat product

Universal Digital Radio Controller

pi@af9w-bpq:/proc/device-tree/hat $ cat product_id

0x0002

pi@af9w-bpq:/proc/device-tree/hat $ cat product_ver

0x0003

pi@af9w-bpq:/proc/device-tree/hat $ cat uuid

3b87f1d1-8ff9-471e-860a-08c79b33400

bpi@af9w-bpq:/proc/device-tree/hat $ cat vendor

NW Digital Radio pi@af9w-bpq:/proc/device-tree $ cat model

Raspberry Pi 2 Model B Rev 1.1

I have reseated the card and all the pins are properly connected.

Any ideas where to go from here?

Bob AF9W

Bernard f6bvp
 

Hi Bob,
I recently ran Hampi and experienced the same kind of issue.
DRAWS board was not found while it was ok with the same hardware Rpi + DRAWS when running nwdr16 Linux image.
After exchanging /boot/config.txt file with the one from nwdr distro, then DRAWS was found on Hampi distro.
After a lot of trials and with Basil n7nix help, we found that in file config.txt the two following lines just before the line with [pi4] should be removed :

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

The important thing is that instruction line :
dtoverlay=

should never occur after a line with
dtparam=audio=on
which is already present in [all] paragraph.

Bernard, f6bvp / ai7bg

Basil Gunn
 

I believe what we found is that for the HamPi image /boot/config.txt
file you should put this line as the first line in the file:

dtoverlay=

There is something in the HamPi boot config file that caused the DRAWS
dtoverlay file to not load.


Bernard f6bvp <f6bvp@...> writes:

Hi Bob,
I recently ran Hampi and experienced the same kind of issue.
DRAWS board was not found while it was ok with the same hardware Rpi + DRAWS when running nwdr16 Linux image.
After exchanging /boot/config.txt file with the one from nwdr distro, then DRAWS was found on Hampi distro.
After a lot of trials and with Basil n7nix help, we found that in file config.txt the two following lines just before the line with [pi4] should be removed :

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

The important thing is that instruction line :
dtoverlay=

should never occur *after* a line with
dtparam=audio=on
which is already present in [all] paragraph.

Bernard, f6bvp / ai7bg

Bernard f6bvp
 

dtoverlay=
can be at the beginning or later as soon as it is declared first, i.e. before
# Enable audio (loads snd_bcm2835)
dtparam=audio=on

Something is triggered by dtparam=audio that prevent the DRAWS dtoverlay to be loaded as stated by Basil.

Bernard
f6bvp / ai7bg