Topics

Setting Up PAT with the #draws

Ed Bloom, KD9FRQ
 

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta 13. I've made a video tutorial, but need to edit before posting. It will release on my YouTube channel Tuesday Aug 27 at 1600 central.

73,
KM4ACK
Find me on YouTube

Basil Gunn
 

Ed,

IP address 0.0.0.0 is a "special IP address" for defining an unknown or
invalid target OR all IPV4 addresses on all interfaces on the local
machine.

Why don't you use some non-routable address from 192.168.0.0 address
space, ie. 192.168.1.1

/Basil n7nix

Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> writes:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already
in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager
web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config
(address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming
exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta
13. I've made a video tutorial, but need to edit before posting. It
will release on my YouTube channel <https://www.youtube.com/km4ack>
Tuesday Aug 27 at 1600 central.

K4KDR
 

Hi Ed!

There are two issues to take care of here.  As was mentioned, 0.0.0.0 is not the address for you to use.  When you are accessing a web page on the same machine you are using, the "loopback" or "localhost" address is 127.0.0.1

The other thing to take care of is that it's necessary to change the default port used by PAT since, as you mentioned, 8080 is used by the DRAWS Manager.

So, as you might have already done to setup your call sign in PAT,  type "pat configure" from a command prompt.  Scroll down a few lines and change the port to something other than "8080".  Here is what that line looks like in my setup, for example:

"http_addr": "localhost:8888",

... so, if you use 8888, the URL to type into your browser (after typing "pat http" in a terminal window) would be:


And you'll be all set!

-Scott,  K4KDR

=====================


On Sat, Sep 14, 2019 at 4:16 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta 13. I've made a video tutorial, but need to edit before posting. It will release on my YouTube channel Tuesday Aug 27 at 1600 central.

73,
KM4ACK
Find me on YouTube

Ed Bloom, KD9FRQ
 

Scott,

Thank you. That is what I was going to do next. But was not 100% sure. So I stopped and asked the question.

Networking is not my IT strong suit. I am an application programmer generally speaking.

My next thing to learn is how to create a desktop icon to run pat http.?? I also need to double check the ARDOP install.?? It is included in the DRAWS package but I an not sure if it is fully setup and available to PAT.

I will need to watch your video again to look at the connections to radio. I will using an FT-897.

73s, Ed, KD9FRQ

On 9/14/2019 6:41 PM, K4KDR wrote:
Hi Ed!

There are two issues to take care of here.?? As was mentioned, 0.0.0.0 is not the address for you to use.?? When you are accessing a web page on the same machine you are using, the "loopback" or "localhost" address is 127.0.0.1

The other thing to take care of is that it's necessary to change the default port used by PAT since, as you mentioned, 8080 is used by the DRAWS Manager.

So, as you might have already done to setup your call sign in PAT,?? type "pat configure" from a command prompt.?? Scroll down a few lines and change the port to something other than "8080".?? Here is what that line looks like in my setup, for example:

"http_addr": "localhost:8888",

... so, if you use 8888, the URL to type into your browser (after typing "pat http" in a terminal window) would be:


And you'll be all set!

-Scott,?? K4KDR

=====================

On Sat, Sep 14, 2019 at 4:16 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta 13. I've made a video tutorial, but need to edit before posting. It will release on my YouTube channel Tuesday Aug 27 at 1600 central.

73,
KM4ACK
Find me on YouTube

Ed Bloom, KD9FRQ
 

Basil,

Thank you. I do not know enough about networking to know I could actually do that.

Regards, Ed

On 9/14/2019 4:56 PM, Basil Gunn wrote:
Ed,

IP address 0.0.0.0 is a "special IP address" for defining an unknown or
invalid target OR all IPV4 addresses on all interfaces on the local
machine.

Why don't you use some non-routable address from 192.168.0.0 address
space, ie. 192.168.1.1

/Basil n7nix

Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> writes:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already
in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager
web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config
(address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming
exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta
13. I've made a video tutorial, but need to edit before posting. It
will release on my YouTube channel <https://www.youtube.com/km4ack>
Tuesday Aug 27 at 1600 central.

 


On Sat, Sep 14, 2019 at 5:20 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:


My next thing to learn is how to create a desktop icon to run pat http.?? 

--
John D. Hays
Kingston, WA
K7VE