Topics

Updated and running but... #winlink


Craig McVeay
 

  I finally had a chance to sit down and update to the latest build for the DRAWS.  It is setup, working properly for connections but, after 24 hours, it's not showing up on the map or the RMS list.  I've tested and double checked that the gateway connects and sends traffic both directions.

Any advice would be appreciated.

Craig
N0CSM


Basil Gunn
 

RMS Gateway not showing up on the Winlink map or the Winlink RMS list.
From the Linux RMS Gateway install for UDRC README file.

Test using rmsgw_aci & rmschanstat
rmsgw_aci = Winlink gateway automatic check-in

# as rmsgw run rmsgw_aci & rmschanstat

sudo -u rmsgw rmsgw_aci
channel udr0 with callsign N0CSM-10 on interface ax0 up

sudo -u rmsgw rmschanstat ax25 udr0 NOCSM-10
channel udr0 with callsign NOCSM-10 on interface ax0 up

# Verify that rmsgw_aci is in crontab
sudo -u rmsgw crontab -l

# Is your RPi connected to the Internet?

Craig McVeay <cmcveay@...> writes:

I finally had a chance to sit down and update to the latest build for
the DRAWS. It is setup, working properly for connections but, after 24
hours, it's not showing up on the map or the RMS list. I've tested and
double checked that the gateway connects and sends traffic both
directions.

Any advice would be appreciated.

Craig
N0CSM


Basil Gunn
 

Craig,

The stat directory in /etc/rmsgw might have the wrong owner &
group.

sudo su
cd /etc/rmsgw
ls -al stat
chown -R rmsgw:rmsgw stat
ls -al stat

/Basil n7nix

RMS Gateway not showing up on the Winlink map or the Winlink RMS list.
From the Linux RMS Gateway install for UDRC README file.

Test using rmsgw_aci & rmschanstat
rmsgw_aci = Winlink gateway automatic check-in

# as rmsgw run rmsgw_aci & rmschanstat

sudo -u rmsgw rmsgw_aci
channel udr0 with callsign N0CSM-10 on interface ax0 up

sudo -u rmsgw rmschanstat ax25 udr0 NOCSM-10
channel udr0 with callsign NOCSM-10 on interface ax0 up

# Verify that rmsgw_aci is in crontab
sudo -u rmsgw crontab -l

# Is your RPi connected to the Internet?

Craig McVeay <cmcveay@...> writes:

I finally had a chance to sit down and update to the latest build for
the DRAWS. It is setup, working properly for connections but, after 24
hours, it's not showing up on the map or the RMS list. I've tested and
double checked that the gateway connects and sends traffic both
directions.

Any advice would be appreciated.

Craig
N0CSM


Craig McVeay
 

Thanks Basil.

The Pi is connected to the internet, I can browse the web, update files and I can watch the gateway connect to Winlink.  I also get ingoing and outgoing traffic (tested again this morning after running the scripts).

In the end, I'm not THAT worried about this small issue since anyone that would want to use my gateway knows about it, it would just be nice to see it populate on the map and RMS list.  I'll check back in a little while to see if Winlink.org updates and populates the data.

73,
Craig

P.S.  I kept your notes from the first time that I setup the system and they were very helpful.


Basil Gunn
 

Hi Craig,

If you run the following from a console you should see your call sign in the RMS
List on the Winlink site almost immediately when the configuration is correct.

sudo -u rmsgw rmsgw_aci

You might also take a look in log files /var/log/rms.debug or
/var/log/rms for any errors related to connecting to Winlink Web
Service.

I know I've had a problem in the past with owner:group of the
/etc/rmsgw/stat directory so you might want to check that out with an:

ls -al /etc/rmsgw/stat

I kept your notes from the first time that I setup the system and
they were very helpful.
Thank you. I appreciate that.

/Basil n7nix

Craig McVeay <cmcveay@...> writes:

Thanks Basil.

The Pi is connected to the internet, I can browse the web, update files and I can watch the gateway connect to Winlink. I also get ingoing and outgoing traffic (tested again this morning after running the scripts).

In the end, I'm not THAT worried about this small issue since anyone that would want to use my gateway knows about it, it would just be nice to see it populate on the map and RMS list. I'll check back in a little while to see if Winlink.org updates and populates the data.

73,
Craig

P.S. I kept your notes from the first time that I setup the system and they were very helpful.